[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / misc / khard

File: [cvs.NetBSD.org] / pkgsrc / misc / khard / Makefile (download)

Revision 1.2, Tue Jul 21 19:17:51 2015 UTC (8 years, 9 months ago) by wiz
Branch: MAIN
Changes since 1.1: +3 -4 lines

Update to 0.4.1:

v0.3.1: 2015.03.26
- Nickname attribute added
- New parameter in config file: show_nicknames = yes / no

v0.3.2: 2015.03.27
- Read-only support for Categories attribute

v0.3.3: 2015.05.07
- twinkle option was renamed to phone: Now it prints all phone numbers like the mutt option does for
  e-mail addresses (more general approach for external phone clients)
- adapted twinkle plugin for use with the new phone option

v0.4.0: 2015.06.15
- new option "add-email": Get full email from stdin, filter senders mail address and add that
  address to an existing contact or create a new one. Feature tested with email client mutt.

v0.4.1: 2015.07.16
- improved search results for phone, mutt and alot

# $NetBSD: Makefile,v 1.2 2015/07/21 19:17:51 wiz Exp $

DISTNAME=		khard-0.4.1
CATEGORIES=		misc net
MASTER_SITES=		https://pypi.python.org/packages/source/k/khard/

MAINTAINER=		pkgsrc-users@NetBSD.org
HOMEPAGE=		https://github.com/scheibler/khard
COMMENT=		CLI contacts application built around CardDAV
LICENSE=		gnu-gpl-v3

DEPENDS+=		${PYPKGPREFIX}-configobj-[0-9]*:../../devel/py-configobj
DEPENDS+=		${PYPKGPREFIX}-vobject-[0-9]*:../../textproc/py-vobject
DEPENDS+=		${PYPKGPREFIX}-argparse-[0-9]*:../../devel/py-argparse

PYTHON_VERSIONS_INCOMPATIBLE=	33 34 # not yet ported as of 0.3.0

INSTALLATION_DIRS=	share/examples/khard
REPLACE_PYTHON+=	*/*.py

post-install:
	${INSTALL_DATA} ${WRKSRC}/khard.conf.example ${DESTDIR}${PREFIX}/share/examples/khard

.include "../../lang/python/application.mk"
.include "../../lang/python/egg.mk"
.include "../../mk/bsd.pkg.mk"