[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / misc / hanzim

File: [cvs.NetBSD.org] / pkgsrc / misc / hanzim / Makefile (download)

Revision 1.19, Wed May 20 06:09:04 2020 UTC (3 years ago) by rillig
Branch: MAIN
CVS Tags: pkgsrc-2020Q2-base, pkgsrc-2020Q2
Changes since 1.18: +8 -1 lines

mark packages that fail with -Werror=char-subscripts

These packages are susceptible to bugs when confronted with non-ASCII
characters.

See https://gcc.gnu.org/bugzilla/show_bug.cgi?id=94182.

It takes some time to analyze and fix these individually, therefore they
are only marked as "needs work".

# $NetBSD: Makefile,v 1.19 2020/05/20 06:09:04 rillig Exp $
#

DISTNAME=	hanzim-1.3
PKGREVISION=	8
CATEGORIES=	misc
MASTER_SITES=	http://kamares.ucsd.edu/~arobert/Files/Chinese/
EXTRACT_SUFX=	.tgz

MAINTAINER=	rxg@NetBSD.org
#HOMEPAGE=	http://kamares.ucsd.edu/~arobert/hanzim.html
COMMENT=	Chinese character learning-aid program

WRKSRC=		${WRKDIR}/Hanzim

BUILD_TARGET=	hanzim

# XXX This is presumably needed during installation according to revision
# XXX 1.1 of this Makefile, but needs to be tested.
# XXX
#MAKE_ENV+=	SHELL=${SH:Q} LC_CTYPE=en_US.ISO8859-1

# hanwin.c: In function 'charinfo':
# hanwin.c:481:25: error: array subscript has type 'char' [-Werror=char-subscripts]
#    strcpy(pinyin,init_str[pinyintbl[cht->pinyins.ent[0]].init]);
#                          ^
# Maybe fix this later.
BUILDLINK_TRANSFORM+=	rm:-Werror=char-subscripts

INSTALLATION_DIRS+=	bin ${PKGMANDIR}/man1

.include "../../lang/tcl/buildlink3.mk"
.include "../../x11/libX11/buildlink3.mk"
.include "../../x11/tk/buildlink3.mk"
.include "../../mk/pthread.buildlink3.mk"

CFLAGS+=	-DUSE_INTERP_RESULT

pre-install:
	@if ${TEST} -z "$$DISPLAY"; then				\
		${ERROR_MSG} "${PKGNAME} runs a binary during installation"; \
		${ERROR_MSG} "that requires an Xserver to be running.";	\
		exit 1;							\
	fi

.include "../../mk/bsd.pkg.mk"