[BACK]Return to Makefile.common CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / meta-pkgs / gnuradio

File: [cvs.NetBSD.org] / pkgsrc / meta-pkgs / gnuradio / Attic / Makefile.common (download)

Revision 1.13, Tue May 19 08:59:23 2009 UTC (13 years, 10 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2009Q2-base, pkgsrc-2009Q2
Changes since 1.12: +2 -3 lines

Use standard location for LICENSE line (in MAINTAINER/HOMEPAGE/COMMENT
block). Uncomment some commented out LICENSE lines while here.

# $NetBSD: Makefile.common,v 1.13 2009/05/19 08:59:23 wiz Exp $
#
# This Makefile fragment is included at the top of package Makefiles for
# GNU Radio distributed packages (they all share common configure and build
# settings).

.include        "../../meta-pkgs/gnuradio/Makefile.version"

DISTNAME?=	gnuradio-${VERSION}
CATEGORIES+=	ham
MASTER_SITES?=	http://gnuradio.org/releases/gnuradio/

MAINTAINER?=	wulf@NetBSD.org
HOMEPAGE?=	http://www.gnu.org/software/gnuradio/
LICENSE=	gnu-gpl-v3

USE_LIBTOOL=	yes
GNU_CONFIGURE=	yes
USE_LANGUAGES=	c c++
USE_TOOLS+=	gmake automake autoconf pkg-config

BUILD_DEPENDS+=doxygen>=1.5.1:../../devel/doxygen

PY_PATCHPLIST=	yes

EGDIR=		${PREFIX}/share/examples/gnuradio/conf.d
PKG_SYSCONFSUBDIR=gnuradio/conf.d

CONFIGURE_ARGS+=        --sysconfdir=${PREFIX}/share/examples
CONFIGURE_ARGS+=        --disable-all-components

pre-configure:
.if  empty(PKGNAME:Mgnuradio-howto-*)
	cd ${WRKSRC} && ./bootstrap
.endif

.include "../../mk/bsd.prefs.mk"