[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / meta-pkgs / desktop-gnome

File: [cvs.NetBSD.org] / pkgsrc / meta-pkgs / desktop-gnome / Makefile (download)

Revision 1.15, Sun Nov 12 16:03:36 2017 UTC (11 months ago) by khorben
Branch: MAIN
CVS Tags: pkgsrc-2018Q3-base, pkgsrc-2018Q3, pkgsrc-2018Q2-base, pkgsrc-2018Q2, pkgsrc-2018Q1-base, pkgsrc-2018Q1, pkgsrc-2017Q4-base, pkgsrc-2017Q4, HEAD
Changes since 1.14: +2 -2 lines

Bump PKGREVISION on packages depending on CUPS

This should be the last part of the renaming operation for print/cups to
print/cups-base.

Rationale: packages depending on CUPS but not relying on a functional
printing setup only need to depend on print/cups-base (equivalent to the
former print/cups). The new print/cups now depends on print/cups-base
and on print/cups-filters, thus directly providing a functional printing
setup. This bump reflects this change of dependency.

As discussed on tech-pkg@

# $NetBSD: Makefile,v 1.15 2017/11/12 16:03:36 khorben Exp $
#

DISTNAME=	desktop-gnome-0.5
PKGREVISION=	3
CATEGORIES=	meta-pkgs x11 gnome
MASTER_SITES=	# empty

MAINTAINER=	pkgsrc-users@NetBSD.org
COMMENT=	Software stack for the NetBSD Desktop Project
#HOMEPAGE=	http://wiki.netbsd.se/Desktop_Project

META_PACKAGE=	yes

# implements http://wiki.netbsd.se/Desktop_Phase_1
#
DEPENDS+=	pkgin-[0-9]*:../../pkgtools/pkgin
DEPENDS+=	cups-[0-9]*:../../print/cups
DEPENDS+=	firefox-[0-9]*:../../www/firefox
DEPENDS+=	gnome-[0-9]*:../../meta-pkgs/gnome
DEPENDS+=	gimp-[0-9]*:../../graphics/gimp
DEPENDS+=	notification-daemon-[0-9]*:../../sysutils/notification-daemon
DEPENDS+=	thunderbird-[0-9]*:../../mail/thunderbird
DEPENDS+=	pidgin-[0-9]*:../../chat/pidgin
DEPENDS+=	pidgin-libnotify-[0-9]*:../../chat/pidgin-libnotify
#DEPENDS+=	transmission-gtk-[0-9]*:../../net/transmission-gtk
DEPENDS+=	filezilla-[0-9]*:../../net/filezilla

# useful fonts and themes
#
DEPENDS+=	dejavu-ttf-[0-9]*:../../fonts/dejavu-ttf
DEPENDS+=	liberation-ttf-[0-9]*:../../fonts/liberation-ttf

# the space taken by some major shells shouldnt be a problem
#
DEPENDS+=	bash-[0-9]*:../../shells/bash
DEPENDS+=	tcsh-[0-9]*:../../shells/tcsh
DEPENDS+=	zsh-[0-9]*:../../shells/zsh
DEPENDS+=	mksh-[0-9]*:../../shells/mksh

.include "../../mk/bsd.pkg.mk"