[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / math / speedcrunch

File: [cvs.NetBSD.org] / pkgsrc / math / speedcrunch / Makefile (download)

Revision 1.47, Sun Jan 29 21:17:05 2023 UTC (4 months ago) by ryoon
Branch: MAIN
CVS Tags: pkgsrc-2023Q1-base, pkgsrc-2023Q1
Changes since 1.46: +2 -2 lines

*: Recursive revbup from graphics/freetype2

# $NetBSD: Makefile,v 1.47 2023/01/29 21:17:05 ryoon Exp $
#

DISTNAME=	release-0.12.0
PKGNAME=	${DISTNAME:C/release/speedcrunch/}
PKGREVISION=	20
CATEGORIES=	math
MASTER_SITES=	http://bitbucket.org/heldercorreia/speedcrunch/get/
DIST_SUBDIR=	speedcrunch

MAINTAINER=	pkgsrc-users@NetBSD.org
HOMEPAGE=	https://www.speedcrunch.org/
COMMENT=	Calculator
LICENSE=	gnu-gpl-v2

WRKSRC=		${WRKDIR}/heldercorreia-speedcrunch-ea93b21f9498/src
USE_LANGUAGES=	c c++
USE_CMAKE=	yes
USE_TOOLS=	gmake # Required for handling file names with whitespaces

post-build:
	(cd ${WRKSRC} && ${QTDIR}/bin/lrelease speedcrunch.pro)

.include "../../x11/qt5-qtbase/buildlink3.mk"
.include "../../x11/qt5-qttools/buildlink3.mk"
.include "../../sysutils/desktop-file-utils/desktopdb.mk"
.include "../../mk/bsd.pkg.mk"