[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / math / scilab

Annotation of pkgsrc/math/scilab/Makefile, Revision 1.62

1.62    ! jlam        1: # $NetBSD: Makefile,v 1.61 2005/04/11 21:46:31 tv Exp $
1.1       agc         2: #
                      3:
1.24      dmcmahil    4: DISTNAME=      ${SCIBASE}.src
1.28      hubertf     5: PKGNAME=       ${SCIBASE}
1.58      jmmv        6: PKGREVISION=   3
1.1       agc         7: CATEGORIES=    math
1.54      dmcmahil    8: MASTER_SITES=  ftp://ftp.inria.fr/INRIA/Scilab/distributions/
1.2       garbled     9:
1.40      grant      10: MAINTAINER=    dmcmahill@NetBSD.org
1.54      dmcmahil   11: HOMEPAGE=      http://www.scilab.org/
1.21      wiz        12: COMMENT=       High-level scientific math programming environment with graphics
1.1       agc        13:
1.54      dmcmahil   14: SCIBASE=       scilab-3.0
1.45      agc        15: WRKSRC=                ${WRKDIR}/${SCIBASE}
1.42      dmcmahil   16:
1.30      dmcmahil   17: #needs FPC code not found in older versions of NetBSD
                     18: NOT_FOR_PLATFORM=      NetBSD-1.[0-4]*-alpha NetBSD-1.5-alpha \
                     19:                        NetBSD-1.5.*-alpha NetBSD-1.5[A-U]-alpha
1.22      dmcmahil   20:
1.59      jlam       21: USE_LANGUAGES=         fortran
1.32      jlam       22: USE_X11BASE=           yes
1.22      dmcmahil   23: USE_LIBTOOL=           yes
1.62    ! jlam       24: PKGSRC_USE_TOOLS+=     tee
1.32      jlam       25:
1.22      dmcmahil   26: GNU_CONFIGURE=         yes
1.33      dmcmahil   27: CONFIGURE_ARGS+=       --without-xaw3d
1.50      dmcmahil   28:
1.52      dmcmahil   29: EVAL_PREFIX+=          TCL_PREFIX=tcl
                     30: EVAL_PREFIX+=          TK_PREFIX=tk
                     31: CONFIGURE_ARGS+=       --with-tcl-library=${TCL_PREFIX}/lib
                     32: CONFIGURE_ARGS+=       --with-tcl-include=${TCL_PREFIX}/include
                     33: CONFIGURE_ARGS+=       --with-tk-library=${TK_PREFIX}/lib
                     34: CONFIGURE_ARGS+=       --with-tk-include=${TK_PREFIX}/include
                     35: CONFIGURE_ENV+=                TCL_CONFIG_SH=${BUILDLINK_PREFIX.tcl}/lib/tclConfig.sh
                     36: CONFIGURE_ENV+=                TK_CONFIG_SH=${BUILDLINK_PREFIX.tk}/lib/tkConfig.sh
1.1       agc        37:
1.32      jlam       38: # override HOME to avoid picking up a bad ${HOME}/.scilab during the build
                     39: MAKE_ENV+=             HOME=${WRKSRC}
                     40: MAKE_ENV+=             PVM_ROOT=${PVM_ROOT}
                     41: CONFIGURE_ENV+=                LOCALBASE=${LOCALBASE}
                     42:
                     43: PVM_ROOT?=             ${LOCALBASE}/pvm3
                     44: CONFIGURE_ENV+=                PVM_ROOT=${PVM_ROOT}
                     45: CONFIGURE_ENV+=                X11BASE=${X11BASE}
                     46: PLIST_SUBST+=          SCIBASE=${SCIBASE}
1.1       agc        47:
1.55      jlam       48: UNWRAP_FILES+=         Makemex config/configuration config/Makeso.incl
1.50      dmcmahil   49:
1.54      dmcmahil   50: BUILDLINK_DEPMETHOD.sablotron= build
                     51:
1.30      dmcmahil   52: .include "../../mk/bsd.prefs.mk"
                     53:
                     54: .if (${MACHINE_ARCH} == "alpha")
1.60      dmcmahil   55: pre-fetch: ${WRKDIR}
1.30      dmcmahil   56:        @${ECHO} "===> Checking if you have working FPC"
                     57:        ${CC} ${CFLAGS} -o ${WRKDIR}/chk_ieee ${FILESDIR}/chk_ieee.c
                     58:        @cd ${WRKDIR} && if ./chk_ieee ; then ${ECHO} "yes" ; else \
                     59:                ${ECHO} "no" ; \
                     60:                ${ECHO} "${PKGNAME} requires floating point completion on this system" ;\
                     61:                ${ECHO} "Possible causes for this check failing are:" ;\
                     62:                ${ECHO} "   - you have an old /usr/lib/* which was not compiled with -mieee" ;\
                     63:                ${ECHO} "   - you have overridden CFLAGS for pkgsrc removing the -mieee flag" ;\
                     64:                ${ECHO} "Without fixing this problem ${PKGNAME} will not work." ; ${FALSE} ; fi
1.31      dmcmahil   65: .endif
1.35      dmcmahil   66:
1.42      dmcmahil   67: EXTRACT_ONLY=  ${DISTNAME}${EXTRACT_SUFX}
1.54      dmcmahil   68: #post-extract:
                     69: #.for f in scicos scicos_blocks
                     70: #      @extract_file=${DISTDIR}/${DIST_SUBDIR}/${f}.tar.gz ; export extract_file ; \
                     71: #              cd ${WRKSRC}/macros/${f} && ${EXTRACT_CMD}
                     72: #.endfor
1.42      dmcmahil   73:
1.50      dmcmahil   74: # clean up any possible leftovers from 'make test' so that our PLIST
                     75: # will still be right.  Also clean up a reference to WRKSRC.
                     76: pre-install:
                     77:        cd ${WRKSRC}/tests && ${SETENV} ${MAKE_ENV} ${MAKE_PROGRAM} distclean
                     78:        cd ${WRKSRC}/examples && ${SETENV} ${MAKE_ENV} ${MAKE_PROGRAM} distclean
1.54      dmcmahil   79:        ${FIND} ${WRKSRC}/tests -name \*.blsav -exec ${RM} {} \;
                     80:        ${FIND} ${WRKSRC}/examples -name \*.blsav -exec ${RM} {} \;
                     81:        ${MV} ${WRKSRC}/maple/maple2scilab.mpl ${WRKSRC}/maple/maple2scilab.mpl.bak
1.50      dmcmahil   82:        ${SED} 's;${WRKSRC};${PREFIX}/lib/${SCIBASE};g' ${WRKSRC}/maple/maple2scilab.mpl.bak > \
                     83:                ${WRKSRC}/maple/maple2scilab.mpl
                     84:        ${RM} -f ${WRKSRC}/maple/maple2scilab.mpl.bak
                     85:
1.36      jmmv       86: # delete some .orig files that got created by patching
1.44      dmcmahil   87: # also fix the libtool link
1.35      dmcmahil   88: post-install:
1.42      dmcmahil   89:        ${RM} -f ${PREFIX}/lib/${SCIBASE}/config/Makeso.incl.in.orig
                     90:        ${RM} -f ${PREFIX}/lib/${SCIBASE}/macros/util/scipad.sci.orig
1.44      dmcmahil   91:        ${RM} -f ${PREFIX}/lib/${SCIBASE}/libtool
1.50      dmcmahil   92:        ${LN} -s ${LOCALBASE}/bin/libtool ${PREFIX}/lib/${SCIBASE}/libtool
1.57      dmcmahil   93:        ${RM} -f ${PREFIX}/lib/${SCIBASE}/config/*.subst.sav
1.31      dmcmahil   94:
1.38      abs        95: .if ${MACHINE_ARCH} == "arm" || ${MACHINE_ARCH} == "arm32"
1.47      jlam       96: GCC_REQD+=             2.95.3
1.30      dmcmahil   97: .endif
                     98:
1.22      dmcmahil   99: # the "SCI=0 && unset SCI" is done because some of the tests really will
                    100: # fail if SCI is set to anything.
1.39      dillo     101: do-test:
1.22      dmcmahil  102:        SCI=0 && unset SCI && cd ${WRKSRC}/tests && \
                    103:                ${MAKE_ENV} ${MAKE_PROGRAM} tests 2>&1 | \
1.54      dmcmahil  104:                 ${TEE} ${WRKDIR}/tests.log
1.22      dmcmahil  105:        SCI=0 && unset SCI && cd ${WRKSRC}/examples && \
                    106:                ${MAKE_ENV} ${MAKE_PROGRAM} tests 2>&1 | \
1.54      dmcmahil  107:                ${TEE} ${WRKDIR}/examples.log
1.1       agc       108:
1.57      dmcmahil  109: # scilab wants ocamlopt so use the same list here as in the
                    110: # lang/ocaml package
                    111: .if (${MACHINE_ARCH} == "i386") || (${MACHINE_ARCH} == "powerpc") || \
                    112:     (${MACHINE_ARCH} == "sparc")
                    113: PLIST_SRC=     ${PKGDIR}/PLIST.opt ${PKGDIR}/PLIST
                    114: .include "../../lang/ocaml/buildlink3.mk"
                    115: .else
                    116: PLIST_SRC=     ${PKGDIR}/PLIST
                    117: CONFIGURE_ARGS+=       --without-ocaml
                    118: .endif
1.50      dmcmahil  119: .include "../../parallel/pvm3/buildlink3.mk"
1.54      dmcmahil  120: .include "../../textproc/sablotron/buildlink3.mk"
1.51      dmcmahil  121: .include "../../x11/tk/buildlink3.mk"
1.1       agc       122: .include "../../mk/bsd.pkg.mk"

CVSweb <webmaster@jp.NetBSD.org>