[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / math / scilab

Annotation of pkgsrc/math/scilab/Makefile, Revision 1.50

1.49      minskim     1: # $NetBSD: Makefile,v 1.48 2004/02/14 17:21:44 jlam Exp $
1.1       agc         2: #
                      3:
1.24      dmcmahil    4: DISTNAME=      ${SCIBASE}.src
1.28      hubertf     5: PKGNAME=       ${SCIBASE}
1.44      dmcmahil    6: PKGREVISION=   3
1.1       agc         7: CATEGORIES=    math
1.6       frueauf     8: MASTER_SITES=  ftp://ftp.inria.fr/INRIA/Projects/Meta2/Scilab/distributions/
1.42      dmcmahil    9: DISTFILES=     ${DISTNAME}${EXTRACT_SUFX}  scicos.tar.gz scicos_blocks.tar.gz
1.2       garbled    10:
1.40      grant      11: MAINTAINER=    dmcmahill@NetBSD.org
1.1       agc        12: HOMEPAGE=      http://www-rocq.inria.fr/scilab/
1.21      wiz        13: COMMENT=       High-level scientific math programming environment with graphics
1.1       agc        14:
1.42      dmcmahil   15: DIST_SUBDIR=   ${SCIBASE}
                     16: SCIBASE=       scilab-2.7
1.45      agc        17: WRKSRC=                ${WRKDIR}/${SCIBASE}
1.42      dmcmahil   18:
                     19: SITES_scicos.tar.gz=           ftp://ftp.inria.fr/INRIA/Projects/Meta2/Scilab/misc/
                     20: SITES_scicos_blocks.tar.gz=    ftp://ftp.inria.fr/INRIA/Projects/Meta2/Scilab/misc/
                     21:
1.30      dmcmahil   22: #needs FPC code not found in older versions of NetBSD
                     23: NOT_FOR_PLATFORM=      NetBSD-1.[0-4]*-alpha NetBSD-1.5-alpha \
                     24:                        NetBSD-1.5.*-alpha NetBSD-1.5[A-U]-alpha
1.22      dmcmahil   25:
1.50    ! dmcmahil   26: USE_BUILDLINK3=                yes
1.22      dmcmahil   27: USE_FORTRAN=           yes
1.32      jlam       28: USE_X11BASE=           yes
1.22      dmcmahil   29: USE_LIBTOOL=           yes
1.32      jlam       30:
1.22      dmcmahil   31: GNU_CONFIGURE=         yes
1.33      dmcmahil   32: CONFIGURE_ARGS+=       --without-xaw3d
1.50    ! dmcmahil   33:
        !            34: TCL_DIR=${LOCALBASE}
        !            35: CONFIGURE_ARGS+=       --with-tcl-library=${TCL_DIR}/lib
        !            36: CONFIGURE_ARGS+=       --with-tcl-include=${TCL_DIR}/include
        !            37: CONFIGURE_ARGS+=       --with-tk-library=${TCL_DIR}/lib
        !            38: CONFIGURE_ARGS+=       --with-tk-include=${TCL_DIR}/include
1.1       agc        39:
1.32      jlam       40: # override HOME to avoid picking up a bad ${HOME}/.scilab during the build
                     41: MAKE_ENV+=             HOME=${WRKSRC}
                     42: MAKE_ENV+=             PVM_ROOT=${PVM_ROOT}
                     43: CONFIGURE_ENV+=                LOCALBASE=${LOCALBASE}
                     44:
                     45: PVM_ROOT?=             ${LOCALBASE}/pvm3
                     46: CONFIGURE_ENV+=                PVM_ROOT=${PVM_ROOT}
                     47: CONFIGURE_ENV+=                X11BASE=${X11BASE}
                     48: PLIST_SUBST+=          SCIBASE=${SCIBASE}
1.1       agc        49:
1.50    ! dmcmahil   50: UNBUILDLINK_FILES+=    Makemex config/configuration config/Makeso.incl
        !            51:
1.30      dmcmahil   52: .include "../../mk/bsd.prefs.mk"
                     53:
                     54: .if (${MACHINE_ARCH} == "alpha")
                     55: pre-fetch:
                     56:        @${ECHO} "===> Checking if you have working FPC"
                     57:        @${MKDIR} ${WRKDIR}
                     58:        ${CC} ${CFLAGS} -o ${WRKDIR}/chk_ieee ${FILESDIR}/chk_ieee.c
                     59:        @cd ${WRKDIR} && if ./chk_ieee ; then ${ECHO} "yes" ; else \
                     60:                ${ECHO} "no" ; \
                     61:                ${ECHO} "${PKGNAME} requires floating point completion on this system" ;\
                     62:                ${ECHO} "Possible causes for this check failing are:" ;\
                     63:                ${ECHO} "   - you have an old /usr/lib/* which was not compiled with -mieee" ;\
                     64:                ${ECHO} "   - you have overridden CFLAGS for pkgsrc removing the -mieee flag" ;\
                     65:                ${ECHO} "Without fixing this problem ${PKGNAME} will not work." ; ${FALSE} ; fi
1.31      dmcmahil   66: .endif
1.35      dmcmahil   67:
1.42      dmcmahil   68: EXTRACT_ONLY=  ${DISTNAME}${EXTRACT_SUFX}
                     69: post-extract:
                     70: .for f in scicos scicos_blocks
                     71:        @extract_file=${DISTDIR}/${DIST_SUBDIR}/${f}.tar.gz ; export extract_file ; \
                     72:                cd ${WRKSRC}/macros/${f} && ${EXTRACT_CMD}
                     73: .endfor
                     74:
1.50    ! dmcmahil   75: # clean up any possible leftovers from 'make test' so that our PLIST
        !            76: # will still be right.  Also clean up a reference to WRKSRC.
        !            77: pre-install:
        !            78:        cd ${WRKSRC}/tests && ${SETENV} ${MAKE_ENV} ${MAKE_PROGRAM} distclean
        !            79:        cd ${WRKSRC}/examples && ${SETENV} ${MAKE_ENV} ${MAKE_PROGRAM} distclean
        !            80:        mv ${WRKSRC}/maple/maple2scilab.mpl ${WRKSRC}/maple/maple2scilab.mpl.bak
        !            81:        ${SED} 's;${WRKSRC};${PREFIX}/lib/${SCIBASE};g' ${WRKSRC}/maple/maple2scilab.mpl.bak > \
        !            82:                ${WRKSRC}/maple/maple2scilab.mpl
        !            83:        ${RM} -f ${WRKSRC}/maple/maple2scilab.mpl.bak
        !            84:
1.36      jmmv       85: # delete some .orig files that got created by patching
1.44      dmcmahil   86: # also fix the libtool link
1.35      dmcmahil   87: post-install:
1.42      dmcmahil   88:        ${RM} -f ${PREFIX}/lib/${SCIBASE}/config/Makeso.incl.in.orig
                     89:        ${RM} -f ${PREFIX}/lib/${SCIBASE}/macros/util/scipad.sci.orig
1.50    ! dmcmahil   90:        ${RM} -f ${PREFIX}/lib/${SCIBASE}/config/Makeso.incl.subst.sav
        !            91:        ${RM} -f ${PREFIX}/lib/${SCIBASE}/config/configuration.subst.sav
1.44      dmcmahil   92:        ${RM} -f ${PREFIX}/lib/${SCIBASE}/libtool
1.50    ! dmcmahil   93:        ${LN} -s ${LOCALBASE}/bin/libtool ${PREFIX}/lib/${SCIBASE}/libtool
1.31      dmcmahil   94:
1.38      abs        95: .if ${MACHINE_ARCH} == "arm" || ${MACHINE_ARCH} == "arm32"
1.47      jlam       96: GCC_REQD+=             2.95.3
1.30      dmcmahil   97: .endif
                     98:
1.22      dmcmahil   99: # the "SCI=0 && unset SCI" is done because some of the tests really will
                    100: # fail if SCI is set to anything.
1.39      dillo     101: do-test:
1.22      dmcmahil  102:        SCI=0 && unset SCI && cd ${WRKSRC}/tests && \
                    103:                ${MAKE_ENV} ${MAKE_PROGRAM} tests 2>&1 | \
                    104:                 tee ${WRKDIR}/tests.log
                    105:        SCI=0 && unset SCI && cd ${WRKSRC}/examples && \
                    106:                ${MAKE_ENV} ${MAKE_PROGRAM} tests 2>&1 | \
                    107:                tee ${WRKDIR}/examples.log
1.1       agc       108:
1.50    ! dmcmahil  109: .include "../../parallel/pvm3/buildlink3.mk"
        !           110: .include "../../x11/tk83/buildlink3.mk"
1.1       agc       111: .include "../../mk/bsd.pkg.mk"

CVSweb <webmaster@jp.NetBSD.org>