[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / math / scilab

Annotation of pkgsrc/math/scilab/Makefile, Revision 1.27

1.27    ! wiz         1: # $NetBSD: Makefile,v 1.26 2001/11/28 04:21:46 dmcmahill Exp $
1.1       agc         2: #
                      3:
1.24      dmcmahil    4: DISTNAME=      ${SCIBASE}.src
                      5: PKGNAME=       ${SCIBASE}nb1
                      6: SCIBASE=       scilab-2.6
1.23      dmcmahil    7: WRKSRC=                ${WRKDIR}/${DISTNAME:.src=}
1.1       agc         8: CATEGORIES=    math
1.6       frueauf     9: MASTER_SITES=  ftp://ftp.inria.fr/INRIA/Projects/Meta2/Scilab/distributions/
1.2       garbled    10:
1.11      dmcmahil   11: MAINTAINER=    dmcmahill@netbsd.org
1.1       agc        12: HOMEPAGE=      http://www-rocq.inria.fr/scilab/
1.21      wiz        13: COMMENT=       High-level scientific math programming environment with graphics
1.1       agc        14:
1.25      jlam       15: DEPENDS+=      xless-[0-9]*:../../x11/xless
1.20      dmcmahil   16: DEPENDS+=      pvm-3.4.3:../../parallel/pvm3
1.1       agc        17:
1.22      dmcmahil   18: # needs full floating point math.  Once the FPC code for alpha is integrated
                     19: # this line can be changed to only exclude older versions of the operating
1.24      dmcmahil   20: # system.  Additionally, -mieee will need to be added.
1.22      dmcmahil   21: NOT_FOR_PLATFORM=      *-*-alpha
                     22:
                     23: USE_FORTRAN=           yes
                     24: USE_LIBTOOL=           yes
                     25: LTCONFIG_OVERRIDE=     ${WRKSRC}/config/ltconfig
                     26: USE_X11BASE=           yes
                     27: USE_X11=               yes
                     28: GNU_CONFIGURE=         yes
1.1       agc        29:
1.17      dmcmahil   30: CONFIGURE_ARGS+=       --without-xless --with-xaw
1.15      dmcmahil   31: #override HOME to avoid picking up a bad ${HOME}/.scilab during the build
1.22      dmcmahil   32: MAKE_ENV+=     HOME=${WRKSRC} PVM_ROOT=${PVM_ROOT}
1.6       frueauf    33: CONFIGURE_ENV+=        LOCALBASE=${LOCALBASE}
1.15      dmcmahil   34: PVM_ROOT?=     ${LOCALBASE}/pvm3
                     35: CONFIGURE_ENV+=        PVM_ROOT=${PVM_ROOT}
1.6       frueauf    36: CONFIGURE_ENV+=        X11BASE=${X11BASE}
1.24      dmcmahil   37: PLIST_SUBST+=  SCIBASE=${SCIBASE}
1.1       agc        38:
1.22      dmcmahil   39: # remove some stuff which is broken in the distfile.  The config's
                     40: # are links to ../config (ie circular).
                     41: post-extract:
1.26      dmcmahil   42:        ${RM} -f ${WRKSRC}/examples/callsci/callsciJava/config/config
                     43:        ${RM} -f ${WRKSRC}/examples/callsci/callsciFortran/config/config
                     44:        ${RM} -f ${WRKSRC}/examples/callsci/callsciC/config/config
                     45:        ${RM} -f ${WRKSRC}/examples/callsci/callsciC++/config/config
1.22      dmcmahil   46:
                     47: # clean up any possible leftovers from 'make test' so that our PLIST
                     48: # will still be right
                     49: pre-install:
                     50:        cd ${WRKSRC}/tests && ${MAKE_PROGRAM} distclean
                     51:        cd ${WRKSRC}/examples && ${MAKE_PROGRAM} distclean
                     52:
                     53: post-install:
1.27    ! wiz        54:        ${LN} -sf ${X11PREFIX}/bin/xless ${PREFIX}/${SCIBASE}/bin/xless
1.22      dmcmahil   55:
                     56: # the "SCI=0 && unset SCI" is done because some of the tests really will
                     57: # fail if SCI is set to anything.
                     58: test: build
                     59:        SCI=0 && unset SCI && cd ${WRKSRC}/tests && \
                     60:                ${MAKE_ENV} ${MAKE_PROGRAM} tests 2>&1 | \
                     61:                 tee ${WRKDIR}/tests.log
                     62:        SCI=0 && unset SCI && cd ${WRKSRC}/examples && \
                     63:                ${MAKE_ENV} ${MAKE_PROGRAM} tests 2>&1 | \
                     64:                tee ${WRKDIR}/examples.log
1.1       agc        65:
                     66: .include "../../mk/bsd.pkg.mk"

CVSweb <webmaster@jp.NetBSD.org>