File:  [cvs.NetBSD.org] / pkgsrc / math / py-statsmodels / Makefile
Revision 1.11: download - view: text, annotated - select for diffs
Tue Jan 4 20:54:17 2022 UTC (2 years, 10 months ago) by wiz
Branches: MAIN
CVS tags: pkgsrc-2022Q1-base, pkgsrc-2022Q1, HEAD
*: bump PKGREVISION for egg.mk users

They now have a tool dependency on py-setuptools instead of a DEPENDS

# $NetBSD: Makefile,v 1.11 2022/01/04 20:54:17 wiz Exp $

DISTNAME=	statsmodels-0.12.2
PKGNAME=	${PYPKGPREFIX}-${DISTNAME}
PKGREVISION=	1
CATEGORIES=	math python
MASTER_SITES=	${MASTER_SITE_PYPI:=s/statsmodels/}

MAINTAINER=	jihbed.research@gmail.com
HOMEPAGE=	https://www.statsmodels.org/
COMMENT=	Statistical computations and models for Python
LICENSE=	modified-bsd

PYTHON_VERSIONS_INCOMPATIBLE=	27 # py-scipy
USE_LANGUAGES=			c

BUILD_DEPENDS+=	${PYPKGPREFIX}-cython>=0.29:../../devel/py-cython
DEPENDS+=	${PYPKGPREFIX}-pandas>=0.21:../../math/py-pandas
DEPENDS+=	${PYPKGPREFIX}-patsy>=0.5:../../math/py-patsy
DEPENDS+=	${PYPKGPREFIX}-scipy>=1.1:../../math/py-scipy

post-extract:
	${CHMOD} -R o-w,g-w ${WRKSRC}
	${FIND} ${WRKSRC} -type f -printx | ${XARGS} ${CHMOD} a-x

.include "../../lang/python/egg.mk"
BUILDLINK_API_DEPENDS.py-numpy+=	${PYPKGPREFIX}-numpy>=1.15
.include "../../math/py-numpy/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

CVSweb <webmaster@jp.NetBSD.org>