The NetBSD Project

CVS log for pkgsrc/math/py-numexpr/Makefile

[BACK] Up to [cvs.NetBSD.org] / pkgsrc / math / py-numexpr

Request diff between arbitrary revisions


Default branch: MAIN


Revision 1.27 / (download) - annotate - [select for diffs], Thu Nov 3 10:46:15 2022 UTC (4 months, 3 weeks ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2023Q1-base, pkgsrc-2023Q1, pkgsrc-2022Q4-base, pkgsrc-2022Q4, HEAD
Changes since 1.26: +2 -2 lines
Diff to previous 1.26 (colored)

py-numexpr: updated to 2.8.4

Changes from 2.8.3 to 2.8.4
---------------------------
* Support for Python 3.11 has been added.
* Thanks to Tobias Hangleiter for an improved accuracy complex `expm1` function.
  While it is 25 % slower, it is significantly more accurate for the real component
  over a range of values and matches NumPy outputs much more closely.
* Thanks to Kirill Kouzoubov for a range of fixes to constants parsing that was
  resulting in duplicated constants of the same value.
* Thanks to Mark Harfouche for noticing that we no longer need `numpy` version
  checks. `packaging` is no longer a requirement as a result.

Revision 1.26 / (download) - annotate - [select for diffs], Sun Sep 11 15:55:43 2022 UTC (6 months, 2 weeks ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2022Q3-base, pkgsrc-2022Q3
Changes since 1.25: +2 -2 lines
Diff to previous 1.25 (colored)

py-numexpr: update to 2.8.3.

Changes from 2.8.1 to 2.8.3
---------------------------

* 2.8.2 was skipped due to an error in uploading to PyPi.
* Support for Python 3.6 has been dropped due to the need to substitute the flag
  `NPY_ARRAY_WRITEBACKIFCOPY` for `NPY_ARRAY_UPDATEIFCOPY`. This flag change was
  initiated in NumPy 1.14 and finalized in 1.23. The only changes were made to
  cases where an unaligned constant was passed in with a pre-allocated output
  variable:

```
    x = np.empty(5, dtype=np.uint8)[1:].view(np.int32)
    ne.evaluate('3', out=x)
```

  We think the risk of issues is very low, but if you are using NumExpr as a
  expression evaluation tool you may want to write a test for this edge case.
* Thanks to Matt Einhorn (@matham) for improvements to the GitHub Actions build process to
  add support for Apple Silicon and aarch64.
* Thanks to Biswapriyo Nath (@biswa96) for a fix to allow `mingw` builds on Windows.
* There have been some changes made to not import `platform.machine()` on `sparc`
  but it is highly advised to upgrade to Python 3.9+ to avoid this issue with
  the Python core package `platform`.

Revision 1.25 / (download) - annotate - [select for diffs], Fri Apr 15 11:27:41 2022 UTC (11 months, 1 week ago) by nia
Branch: MAIN
CVS Tags: pkgsrc-2022Q2-base, pkgsrc-2022Q2
Changes since 1.24: +2 -2 lines
Diff to previous 1.24 (colored)

math: Mark some packages incompatible with Python 3.7 due to numpy

Revision 1.24 / (download) - annotate - [select for diffs], Tue Jan 4 23:35:37 2022 UTC (14 months, 3 weeks ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2022Q1-base, pkgsrc-2022Q1
Changes since 1.23: +4 -4 lines
Diff to previous 1.23 (colored)

py-numexpr: update to 2.8.1.

Changes from 2.8.0 to 2.8.1
---------------------------

* Fixed dependency list.
* Added ``pyproject.toml`` and modernize the ``setup.py`` script. Thanks to
Antonio Valentino for the PR.

Changes from 2.7.3 to 2.8.0
---------------------------

* Wheels for Python 3.10 are now provided.
* Support for Python 2.7 and 3.5 has been discontinued.
* All residual support for Python 2.X syntax has been removed, and therefore
  the setup build no longer makes calls to the `2to3` script. The `setup.py`
  has been refactored to be more modern.
* The examples on how to link into Intel VML/MKL/oneAPI now use the dynamic
  library.

Revision 1.23 / (download) - annotate - [select for diffs], Tue Jan 4 20:54:15 2022 UTC (14 months, 3 weeks ago) by wiz
Branch: MAIN
Changes since 1.22: +2 -1 lines
Diff to previous 1.22 (colored)

*: bump PKGREVISION for egg.mk users

They now have a tool dependency on py-setuptools instead of a DEPENDS

Revision 1.22 / (download) - annotate - [select for diffs], Thu Dec 30 13:05:37 2021 UTC (14 months, 3 weeks ago) by adam
Branch: MAIN
Changes since 1.21: +2 -2 lines
Diff to previous 1.21 (colored)

Forget about Python 3.6

Revision 1.21 / (download) - annotate - [select for diffs], Sun Dec 19 14:00:47 2021 UTC (15 months, 1 week ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2021Q4-base, pkgsrc-2021Q4
Changes since 1.20: +2 -2 lines
Diff to previous 1.20 (colored)

py-numexpr: mark as not for python 2.7

Revision 1.20 / (download) - annotate - [select for diffs], Tue Jun 29 08:42:01 2021 UTC (20 months, 4 weeks ago) by nia
Branch: MAIN
CVS Tags: pkgsrc-2021Q3-base, pkgsrc-2021Q3
Changes since 1.19: +3 -1 lines
Diff to previous 1.19 (colored)

py-numpy: "Python version >= 3.7 required."

Revision 1.19 / (download) - annotate - [select for diffs], Wed May 5 10:05:19 2021 UTC (22 months, 3 weeks ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2021Q2-base, pkgsrc-2021Q2
Changes since 1.18: +3 -4 lines
Diff to previous 1.18 (colored)

py-numexpr: updated to 2.7.3

Changes from 2.7.2 to 2.7.3
---------------------------
- Pinned Numpy versions to minimum supported version in an effort to alleviate
  issues seen in Windows machines not having the same MSVC runtime installed as
  was used to build the wheels.
- ARMv8 wheels are now available, thanks to `odidev` for the pull request.


Changes from 2.7.1 to 2.7.2
---------------------------
- Support for Python 2.7 and 3.5 is deprecated and will be discontinued when
  `cibuildwheels` and/or GitHub Actions no longer support these versions.
- Wheels are now provided for Python 3.7, 3.5, 3.6, 3.7, 3.8, and 3.9 via
  GitHub Actions.
- The block size is now exported into the namespace as `numexpr.__BLOCK_SIZE1__`
  as a read-only value.
- If using MKL, the number of threads for VML is no longer forced to 1 on loading
  the module. Testing has shown that VML never runs in multi-threaded mode for
  the default BLOCKSIZE1 of 1024 elements, and forcing to 1 can have deleterious
  effects on NumPy functions when built with MKL.
- Use of `ndarray.tostring()` in tests has been switch to `ndarray.tobytes()`
  for future-proofing deprecation of `.tostring()`, if the version of NumPy is
  greater than 1.9.
- Added a utility method `get_num_threads` that returns the (maximum) number of
  threads currently in use by the virtual machine. The functionality of
  `set_num_threads` whereby it returns the previous value has been deprecated
  and will be removed in 2.8.X.

Revision 1.18 / (download) - annotate - [select for diffs], Mon Oct 12 21:52:03 2020 UTC (2 years, 5 months ago) by bacon
Branch: MAIN
CVS Tags: pkgsrc-2021Q1-base, pkgsrc-2021Q1, pkgsrc-2020Q4-base, pkgsrc-2020Q4
Changes since 1.17: +2 -1 lines
Diff to previous 1.17 (colored)

math/blas, math/lapack: Install interchangeable BLAS system

Install the new interchangeable BLAS system created by Thomas Orgis,
currently supporting Netlib BLAS/LAPACK, OpenBLAS, cblas, lapacke, and
Apple's Accelerate.framework.  This system allows the user to select any
BLAS implementation without modifying packages or using package options, by
setting PKGSRC_BLAS_TYPES in mk.conf. See mk/blas.buildlink3.mk for details.

This commit should not alter behavior of existing packages as the system
defaults to Netlib BLAS/LAPACK, which until now has been the only supported
implementation.

Details:

Add new mk/blas.buildlink3.mk for inclusion in dependent packages
Install compatible Netlib math/blas and math/lapack packages
Update math/blas and math/lapack MAINTAINER approved by adam@
OpenBLAS, cblas, and lapacke will follow in separate commits
Update direct dependents to use mk/blas.buildlink3.mk
Perform recursive revbump

Revision 1.17 / (download) - annotate - [select for diffs], Tue Apr 28 13:21:33 2020 UTC (2 years, 10 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2020Q3-base, pkgsrc-2020Q3, pkgsrc-2020Q2-base, pkgsrc-2020Q2
Changes since 1.16: +2 -2 lines
Diff to previous 1.16 (colored)

py-numexpr: updated to 2.7.1

Changes from 2.7.0 to 2.7.1
- Python 3.8 support has been added.
- Python 3.4 support is discontinued.
- The tests are now compatible with NumPy 1.18.
- `site.cfg.example` was updated to use the `libraries` tag instead of `mkl_libs`,
  which is recommended for newer version of NumPy.

Revision 1.16 / (download) - annotate - [select for diffs], Sat Nov 9 21:36:15 2019 UTC (3 years, 4 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2020Q1-base, pkgsrc-2020Q1, pkgsrc-2019Q4-base, pkgsrc-2019Q4
Changes since 1.15: +2 -2 lines
Diff to previous 1.15 (colored)

py-numexpr: updated to 2.7.0

Changes from 2.6.9 to 2.7.0
- The default number of 'safe' threads has been restored to the historical limit
  of 8, if the environment variable "NUMEXPR_MAX_THREADS" has not been set.
- Thanks to @eltoder who fixed a small memory leak.
- Support for Python 2.6 has been dropped, as it is no longer available via
  TravisCI.
- A typo in the test suite that had a less than rather than greater than symbol
  in the NumPy version check has been corrected thanks to dhomeier.
- The file `site.cfg` was being accidently included in the sdists on PyPi.
  It has now been excluded.

Revision 1.15 / (download) - annotate - [select for diffs], Sat Dec 22 09:38:19 2018 UTC (4 years, 3 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2019Q3-base, pkgsrc-2019Q3, pkgsrc-2019Q2-base, pkgsrc-2019Q2, pkgsrc-2019Q1-base, pkgsrc-2019Q1, pkgsrc-2018Q4-base, pkgsrc-2018Q4
Changes since 1.14: +2 -2 lines
Diff to previous 1.14 (colored)

py-numexpr: updated to 2.6.9

Changes from 2.6.8 to 2.6.9
- Thanks to Mike Toews for more robust handling of the thread-setting
  environment variables.
- With Appveyor updating to Python 3.7.1, wheels for Python 3.7 are now
  available in addition to those for other OSes.

Revision 1.14 / (download) - annotate - [select for diffs], Thu Aug 30 11:01:35 2018 UTC (4 years, 6 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2018Q3-base, pkgsrc-2018Q3
Changes since 1.13: +2 -2 lines
Diff to previous 1.13 (colored)

py-numexpr: updated to 2.6.8

Changes from 2.6.7 to 2.6.8
---------------------------
- Add check to make sure that f_locals is not actually f_globals when we
  do the f_locals clear to avoid the 310 memory leak issue.
- Compare NumPy versions using distutils.version.LooseVersion to avoid issue
  312 when working with NumPy development versions.
- As part of multibuild, wheels for Python 3.7 for Linux and MacOSX are now
  available on PyPI

Revision 1.13 / (download) - annotate - [select for diffs], Tue Aug 14 13:43:25 2018 UTC (4 years, 7 months ago) by adam
Branch: MAIN
Changes since 1.12: +2 -2 lines
Diff to previous 1.12 (colored)

py-numexpr: updated to 2.6.7

Changes from 2.6.6 to 2.6.7
* Thanks to Lehman Garrison for finding and fixing a bug that exhibited memory leak-like behavior. The use in numexpr.evaluate of sys._getframe combined with .f_locals from that frame object results an extra refcount on objects in the frame that calls numexpr.evaluate, and not evaluateãàÑÔ frame. So if the calling frame remains in scope for a long time (such as a procedural script where numexpr is called from the base frame) garbage collection would never occur.
* Imports for the numexpr.test submodule were made lazy in the numexpr module.

Revision 1.12 / (download) - annotate - [select for diffs], Thu Jul 19 08:57:48 2018 UTC (4 years, 8 months ago) by adam
Branch: MAIN
Changes since 1.11: +2 -2 lines
Diff to previous 1.11 (colored)

py-numexpr: updated to 2.6.6

Changes from 2.6.5 to 2.6.6:
Fix to the thread barrier that occassionally suffered from spurious wakeups on MacOSX.

Revision 1.11 / (download) - annotate - [select for diffs], Wed Jul 4 08:10:07 2018 UTC (4 years, 8 months ago) by adam
Branch: MAIN
Changes since 1.10: +3 -3 lines
Diff to previous 1.10 (colored)

py-numexpr: updated to 2.6.5

Changes from 2.6.4 to 2.6.5
- The maximum thread count can now be set at import-time by setting the
  environment variable 'NUMEXPR_MAX_THREADS'. The default number of
  max threads was lowered from 4096 (which was deemed excessive) to 64.
- A number of imports were removed (pkg_resources) or made lazy (cpuinfo) in
  order to speed load-times for downstream packages (such as pandas, sympy,
  and tables). Import time has dropped from about 330 ms to 90 ms. Thanks to
  Jason Sachs for pointing out the source of the slow-down.
- Thanks to Alvaro Lopez Ortega for updates to benchmarks to be compatible with
  Python 3.
- Travis and AppVeyor now fail if the test module fails or errors.
- Thanks to Mahdi Ben Jelloul for a patch that removed a bug where constants
  in where calls would raise a ValueError.
- Fixed a bug whereby all-constant power operations would lead to infinite
  recursion.

Revision 1.10 / (download) - annotate - [select for diffs], Mon Sep 18 17:03:45 2017 UTC (5 years, 6 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2018Q2-base, pkgsrc-2018Q2, pkgsrc-2018Q1-base, pkgsrc-2018Q1, pkgsrc-2017Q4-base, pkgsrc-2017Q4, pkgsrc-2017Q3-base, pkgsrc-2017Q3
Changes since 1.9: +2 -2 lines
Diff to previous 1.9 (colored)

py-numexpr: update to 2.6.4

Changes from 2.6.3 to 2.6.4
- Christoph Gohkle noticed a lack of coverage for the 2.6.3
  `floor` and `ceil` functions for MKL that caused seg-faults in
   test, so thanks to him for that.

Revision 1.9 / (download) - annotate - [select for diffs], Thu Sep 14 10:52:01 2017 UTC (5 years, 6 months ago) by adam
Branch: MAIN
Changes since 1.8: +2 -2 lines
Diff to previous 1.8 (colored)

py-numexpr: update to 2.6.3

Changes from 2.6.2 to 2.6.3
- Documentation now available at readthedocs.io_.
- Support for floor() and ceil() functions added by Caleb P. Burns.
- NumPy requirement increased from 1.6 to 1.7 due to changes in iterator
  flags.
- Sphinx autodocs support added for documentation on readthedocs.org.
- Fixed a bug where complex constants would return an error, fixing
  problems with `sympy` when using NumExpr as a backend.
- Fix for 277 whereby arrays of shape (1,...) would be reduced as
  if they were full reduction. Behavoir now matches that of NumPy.
- String literals are automatically encoded into 'ascii' bytes for
  convience.

Revision 1.8 / (download) - annotate - [select for diffs], Sun May 21 07:06:57 2017 UTC (5 years, 10 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2017Q2-base, pkgsrc-2017Q2
Changes since 1.7: +3 -5 lines
Diff to previous 1.7 (colored)

Changes 2.6.2:
Updates to keep with API changes in newer NumPy versions
Removed several warnings
Fix bugs in function stringcontains()
Detection of the POWER processor
Fix pow result casting
Fix integers to negative integer powers
Detect numpy exceptions in expression evaluation
Better handling of RC versions

Revision 1.7 / (download) - annotate - [select for diffs], Thu Nov 17 07:26:47 2016 UTC (6 years, 4 months ago) by alnsn
Branch: MAIN
CVS Tags: pkgsrc-2017Q1-base, pkgsrc-2017Q1, pkgsrc-2016Q4-base, pkgsrc-2016Q4
Changes since 1.6: +2 -2 lines
Diff to previous 1.6 (colored)

Update to 2.6.1.

Prompted by beta.repology.org.

Changes from 2.6.0 to 2.6.1

     * Fixed a performance regression in some situations as consequence of
       increasing too much the BLOCK_SIZE1 constant. After more careful
       benchmarks (both in VML and non-VML modes), the value has been set
       again to 1024 (down from 8192). The benchmarks have been made with
       a relatively new processor (Intel Xeon E3-1245 v5 @ 3.50GHz), so
       they should work well for a good range of processors again.
     * Added NetBSD support to CPU detection. Thanks to Thomas Klausner.

Revision 1.6 / (download) - annotate - [select for diffs], Fri Jul 15 07:18:45 2016 UTC (6 years, 8 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2016Q3-base, pkgsrc-2016Q3
Changes since 1.5: +6 -4 lines
Diff to previous 1.5 (colored)

Updated py-numexpr to 2.6.0.

Fix CPU detection patch while here.

Changes from 2.5.2 to 2.6.0
===========================

- Introduced a new re_evaluate() function for re-evaluating the
  previous executed array expression without any check.  This is meant
  for accelerating loops that are re-evaluating the same expression
  repeatedly without changing anything else than the operands.  If
  unsure, use evaluate() which is safer.

- The BLOCK_SIZE1 and BLOCK_SIZE2 constants have been re-checked in
  order to find a value maximizing most of the benchmarks in bench/
  directory.  The new values (8192 and 16 respectively) give somewhat
  better results (~5%) overall.  The CPU used for fine tuning is a
  relatively new Haswell processor (E3-1240 v3).

- The '--name' flag for `setup.py` returning the name of the package
  is honored now (issue #215).


Changes from 2.5.1 to 2.5.2
===========================

- conj() and abs() actually added as VML-powered functions, preventing
  the same problems than log10() before (PR #212).  Thanks to Tom Kooij
  for the fix!


Changes from 2.5 to 2.5.1
=========================

- Fix for log10() and conj() functions.  These produced wrong results
  when numexpr was compiled with Intel's MKL (which is a popular build
  since Anaconda ships it by default) and non-contiguous data (issue
  #210).  Thanks to Arne de Laat and Tom Kooij for reporting and
  providing a nice test unit.

- Fix that allows numexpr-powered apps to be profiled with pympler.
  Thanks to @nbecker.


Changes from 2.4.6 to 2.5
=========================

- Added locking for allowing the use of numexpr in multi-threaded
  callers (this does not prevent numexpr to use multiple cores
  simultaneously).  (PR #199, Antoine Pitrou, PR #200, Jenn Olsen).

- Added new min() and max() functions (PR #195, CJ Carey).


Changes from 2.4.5 to 2.4.6
===========================

- Fixed some UserWarnings in Solaris (PR #189, Graham Jones).

- Better handling of MSVC defines. (#168, Francesc Alted).


Changes from 2.4.4 to 2.4.5
===========================

- Undone a 'fix' for a harmless data race.  (#185 Benedikt Reinartz,
  Francesc Alted).

- Ignore NumPy warnings (overflow/underflow, divide by zero and
  others) that only show up in Python3.  Masking these warnings in
  tests is fine because all the results are checked to be
  valid. (#183, Francesc Alted).


Changes from 2.4.3 to 2.4.4
===========================

- Fix bad #ifdef for including stdint on Windows (PR #186, Mike Sarahan).


Changes from 2.4.3 to 2.4.4
===========================

* Honor OMP_NUM_THREADS as a fallback in case NUMEXPR_NUM_THREADS is not
  set. Fixes #161. (PR #175, Stefan Erb).

* Added support for AppVeyor (PR #178 Andrea Bedini)

* Fix to allow numexpr to be imported after eventlet.monkey_patch(),
  as suggested in #118 (PR #180 Ben Moran).

* Fix harmless data race that triggers false positives in ThreadSanitizer.
  (PR #179, Clement Courbet).

* Fixed some string tests on Python 3 (PR #182, Antonio Valentino).


Changes from 2.4.2 to 2.4.3
===========================

* Comparisons with empty strings work correctly now.  Fixes #121 and
  PyTables #184.

Changes from 2.4.1 to 2.4.2
===========================

* Improved setup.py so that pip can query the name and version without
  actually doing the installation.  Thanks to Joris Borgdorff.

Changes from 2.4 to 2.4.1
=========================

* Added more configuration examples for compiling with MKL/VML
  support.  Thanks to Davide Del Vento.

* Symbol MKL_VML changed into MKL_DOMAIN_VML because the former is
  deprecated in newer MKL.  Thanks to Nick Papior Andersen.

* Better determination of methods in `cpuinfo` module.  Thanks to Marc
  Jofre.

* Improved NumPy version determination (handy for 1.10.0).  Thanks
  to smund Hjulstad.

* Benchmarks run now with both Python 2 and Python 3.  Thanks to Zoran
  Plesivak.

Changes from 2.3.1 to 2.4
=========================

* A new `contains()` function has been added for detecting substrings
  in strings.  Only plain strings (bytes) are supported for now.  See
  PR #135 and ticket #142.  Thanks to Marcin Krol.

* New version of setup.py that allows better management of NumPy
  dependency.  See PR #133.  Thanks to Aleks Bunin.

Changes from 2.3 to 2.3.1
=========================

* Added support for shift-left (<<) and shift-right (>>) binary operators.
  See PR #131. Thanks to fish2000!

* Removed the rpath flag for the GCC linker, because it is probably
  not necessary and it chokes to clang.

Revision 1.5 / (download) - annotate - [select for diffs], Sat Jul 19 12:46:53 2014 UTC (8 years, 8 months ago) by bad
Branch: MAIN
CVS Tags: pkgsrc-2016Q2-base, pkgsrc-2016Q2, pkgsrc-2016Q1-base, pkgsrc-2016Q1, pkgsrc-2015Q4-base, pkgsrc-2015Q4, pkgsrc-2015Q3-base, pkgsrc-2015Q3, pkgsrc-2015Q2-base, pkgsrc-2015Q2, pkgsrc-2015Q1-base, pkgsrc-2015Q1, pkgsrc-2014Q4-base, pkgsrc-2014Q4, pkgsrc-2014Q3-base, pkgsrc-2014Q3
Changes since 1.4: +2 -2 lines
Diff to previous 1.4 (colored)

Fix build. This is an egg hence has an egg-info dir not a file.

Revision 1.4 / (download) - annotate - [select for diffs], Tue Jan 21 13:26:52 2014 UTC (9 years, 2 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2014Q2-base, pkgsrc-2014Q2, pkgsrc-2014Q1-base, pkgsrc-2014Q1
Changes since 1.3: +9 -8 lines
Diff to previous 1.3 (colored)

Update to 2.2.2. Set LICENSE. Update HOMEPAGE.

Changes from 2.2.1 to 2.2.2
===========================

* The `copy_args` argument of `NumExpr` function has been brought
  back.  This has been mainly necessary for compatibility with
  PyTables < 3.0, which I decided to continue to support.  Fixed #115.

* The `__nonzero__` method in `ExpressionNode` class has been
  commented out.  This is also for compatibility with PyTables < 3.0.
  See #24 for details.

* Fixed the type of some parameters in the C extension so that s390
  architecture compiles.  Fixes #116.  Thank to Antonio Valentino for
  reporting and the patch.


Changes from 2.2 to 2.2.1
=========================

* Fixes a secondary effect of "from numpy.testing import `*`", where
  division is imported now too, so only then necessary functions from
  there are imported now.  Thanks to Christoph Gohlke for the patch.

Changes from 2.1 to 2.2
=======================

* [LICENSE] Fixed a problem with the license of the
  numexpr/win32/pthread.{c,h} files emulating pthreads on Windows
  platforms.  After persmission from the original authors is granted,
  these files adopt the MIT license and can be redistributed without
  problems.  See issue #109 for details
  (https://code.google.com/p/numexpr/issues/detail?id=110).

* [ENH] Improved the algorithm to decide the initial number of threads
  to be used.  This was necessary because by default, numexpr was
  using a number of threads equal to the detected number of cores, and
  this can be just too much for moder systems where this number can be
  too high (and counterporductive for performance in many cases).
  Now, the 'NUMEXPR_NUM_THREADS' environment variable is honored, and
  in case this is not present, a maximum number of *8* threads are
  setup initially.  The new algorithm is fully described in the Users
  Guide now in the note of 'General routines' section:
  https://code.google.com/p/numexpr/wiki/UsersGuide#General_routines.
  Closes #110.

* [ENH] numexpr.test() returns `TestResult` instead of None now.
  Closes #111.

* [FIX] Modulus with zero with integers no longer crashes the
  interpreter.  It nows puts a zero in the result.  Fixes #107.

* [API CLEAN] Removed `copy_args` argument of `evaluate`.  This should
  only be used by old versions of PyTables (< 3.0).

* [DOC] Documented the `optimization` and `truediv` flags of
  `evaluate` in Users Guide
  (https://code.google.com/p/numexpr/wiki/UsersGuide).

Changes from 2.0.1 to 2.1
===========================

* Dropped compatibility with Python < 2.6.

* Improve compatibiity with Python 3:

  - switch from PyString to PyBytes API (requires Python >= 2.6).
  - fixed incompatibilities regarding the int/long API
  - use the Py_TYPE macro
  - use the PyVarObject_HEAD_INIT macro instead of PyObject_HEAD_INIT

* Fixed several issues with different platforms not supporting
  multithreading or subprocess properly (see tickets #75 and #77).

* Now, when trying to use pure Python boolean operators, 'and',
  'or' and 'not', an error is issued suggesting that '&', '|' and
  '~' should be used instead (fixes #24).

Changes from 2.0 to 2.0.1
=========================

* Added compatibility with Python 2.5 (2.4 is definitely not supported
  anymore).

* `numexpr.evaluate` is fully documented now, in particular the new
  `out`, `order` and `casting` parameters.

* Reduction operations are fully documented now.

* Negative axis in reductions are not supported (they have never been
  actually), and a `ValueError` will be raised if they are used.


Changes from 1.x series to 2.0
==============================

- Added support for the new iterator object in NumPy 1.6 and later.

  This allows for better performance with operations that implies
  broadcast operations, fortran-ordered or non-native byte orderings.
  Performance for other scenarios is preserved (except for very small
  arrays).

- Division in numexpr is consistent now with Python/NumPy.  Fixes #22
  and #58.

- Constants like "2." or "2.0" must be evaluated as float, not
  integer.  Fixes #59.

- `evaluate()` function has received a new parameter `out` for storing
  the result in already allocated arrays.  This is very useful when
  dealing with large arrays, and a allocating new space for keeping
  the result is not acceptable.  Closes #56.

- Maximum number of threads raised from 256 to 4096.  Machines with a
  higher number of cores will still be able to import numexpr, but
  limited to 4096 (which is an absurdly high number already).

Revision 1.3 / (download) - annotate - [select for diffs], Tue Sep 11 23:04:31 2012 UTC (10 years, 6 months ago) by asau
Branch: MAIN
CVS Tags: pkgsrc-2013Q4-base, pkgsrc-2013Q4, pkgsrc-2013Q3-base, pkgsrc-2013Q3, pkgsrc-2013Q2-base, pkgsrc-2013Q2, pkgsrc-2013Q1-base, pkgsrc-2013Q1, pkgsrc-2012Q4-base, pkgsrc-2012Q4, pkgsrc-2012Q3-base, pkgsrc-2012Q3
Changes since 1.2: +1 -3 lines
Diff to previous 1.2 (colored)

"user-destdir" is default these days

Revision 1.2 / (download) - annotate - [select for diffs], Tue Nov 2 19:25:04 2010 UTC (12 years, 4 months ago) by drochner
Branch: MAIN
CVS Tags: pkgsrc-2012Q2-base, pkgsrc-2012Q2, pkgsrc-2012Q1-base, pkgsrc-2012Q1, pkgsrc-2011Q4-base, pkgsrc-2011Q4, pkgsrc-2011Q3-base, pkgsrc-2011Q3, pkgsrc-2011Q2-base, pkgsrc-2011Q2, pkgsrc-2011Q1-base, pkgsrc-2011Q1, pkgsrc-2010Q4-base, pkgsrc-2010Q4
Changes since 1.1: +3 -3 lines
Diff to previous 1.1 (colored)

update to 1.4.1
changes:
-Added support for multi-threading in pure C
-refactorization of the opcode machinery, Added a couple of opcodes
-fixes
-release GIL during computations for better resource usage for
 multithreaded apps

Revision 1.1.1.1 / (download) - annotate - [select for diffs] (vendor branch), Fri Jul 16 12:12:17 2010 UTC (12 years, 8 months ago) by drochner
Branch: TNF
CVS Tags: pkgsrc_base, pkgsrc-2010Q3-base, pkgsrc-2010Q3
Changes since 1.1: +0 -0 lines
Diff to previous 1.1 (colored)

add py-numexpr-1.3.1, a numerical expression evaluator for NumPy

Revision 1.1 / (download) - annotate - [select for diffs], Fri Jul 16 12:12:17 2010 UTC (12 years, 8 months ago) by drochner
Branch: MAIN

Initial revision

This form allows you to request diff's between any two revisions of a file. You may select a symbolic revision name using the selection box or you may type in a numeric name using the type-in text box.




CVSweb <webmaster@jp.NetBSD.org>