File:  [cvs.NetBSD.org] / pkgsrc / math / py-mpmath / Makefile
Revision 1.13: download - view: text, annotated - select for diffs
Thu Jan 19 18:52:18 2017 UTC (8 years, 1 month ago) by agc
Branches: MAIN
CVS tags: pkgsrc-2017Q4-base, pkgsrc-2017Q4, pkgsrc-2017Q3-base, pkgsrc-2017Q3, pkgsrc-2017Q2-base, pkgsrc-2017Q2, pkgsrc-2017Q1-base, pkgsrc-2017Q1, HEAD
Convert all occurrences (353 by my count) of

	MASTER_SITES= 	site1 \
			site2

style continuation lines to be simple repeated

	MASTER_SITES+= site1
	MASTER_SITES+= site2

lines. As previewed on tech-pkg. With thanks to rillig for fixing pkglint
accordingly.

# $NetBSD: Makefile,v 1.13 2017/01/19 18:52:18 agc Exp $

DISTNAME=	mpmath-0.19
PKGNAME=	${PYPKGPREFIX}-${DISTNAME}
CATEGORIES=	math
MASTER_SITES=	${MASTER_SITE_PYPI:=m/mpmath/}
MASTER_SITES+=	http://mpmath.org/files/

MAINTAINER=	pkgsrc-users@NetBSD.org
HOMEPAGE=	http://mpmath.org/
COMMENT=	Python library for arbitrary-precision FP arithmetic
LICENSE=	modified-bsd

USE_LANGUAGES=	# none
PYDISTUTILSPKG=	yes

TEST_ENV+=	PYTHONPATH=${WRKSRC}/build/lib

SUBST_CLASSES+=		python
SUBST_STAGE.python=	post-patch
SUBST_FILES.python+=	mpmath/matrices/eigen.py mpmath/matrices/eigen_symmetric.py
SUBST_FILES.python+=	mpmath/tests/test_eigen.py mpmath/tests/test_eigen_symmetric.py
SUBST_FILES.python+=	mpmath/tests/test_levin.py
SUBST_MESSAGE.python=	Fixing path to Python interpreter.
SUBST_SED.python=	-e "s,/usr/bin/python,${PYTHONBIN},g"

SUBST_CLASSES+=		python2
SUBST_STAGE.python2=	post-patch
SUBST_FILES.python2+=	mpmath/tests/runtests.py
SUBST_MESSAGE.python2=	Fixing path to Python interpreter.
SUBST_SED.python2=	-e "s,/usr/bin/env python,${PYTHONBIN},g"

do-test:
	${RUN} cd ${WRKSRC}/build/lib/mpmath/tests; \
	${SETENV} ${TEST_ENV} ${PYTHONBIN} runtests.py

.include "../../lang/python/extension.mk"
# optional speedup
#.include "../../math/py-gmpy/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

CVSweb <webmaster@jp.NetBSD.org>