The NetBSD Project

CVS log for pkgsrc/math/py-ephem/Makefile

[BACK] Up to [cvs.NetBSD.org] / pkgsrc / math / py-ephem

Request diff between arbitrary revisions


Default branch: MAIN
Current tag: pkgsrc-2012Q1


Revision 1.6 / (download) - annotate - [select for diffs], Mon Sep 20 09:52:14 2010 UTC (13 years, 6 months ago) by obache
Branch: MAIN
CVS Tags: pkgsrc-2012Q2-base, pkgsrc-2012Q2, pkgsrc-2012Q1-base, pkgsrc-2012Q1, pkgsrc-2011Q4-base, pkgsrc-2011Q4, pkgsrc-2011Q3-base, pkgsrc-2011Q3, pkgsrc-2011Q2-base, pkgsrc-2011Q2, pkgsrc-2011Q1-base, pkgsrc-2011Q1, pkgsrc-2010Q4-base, pkgsrc-2010Q4, pkgsrc-2010Q3-base, pkgsrc-2010Q3
Changes since 1.5: +8 -17 lines
Diff to previous 1.5 (colored)

Update py-ephem to 3.7.3.4.
Based on PR#43737 by Kamel Derouiche.

remove RESTRICTION, because COPYING file said GPL or LGPL, nothing for others.

PyEphem CHANGELOG
=================

Version 3.7.3.4 (2009 April 30)
-------------------------------

- Added a new ``next_pass()`` method to ``Observer`` that searches for
  when a satellite next rises, culminates, and sets.

- Added a ``compute_pressure()`` method to ``Observer`` which computes
  the standard atmospheric pressure at the observer's current elevation.
  This function now gets called automatically on new ``city()`` objects
  before they are returned to the user.

- Corrected the altitude of San Francisco as returned by ``city()``.

- Improved the copyright message so that two more authors are credited.

Version 3.7.3.3 (2008 October 3)
--------------------------------

- Added ``cmsI`` and ``cmsII`` attributes to ``Jupiter`` to provide the
  central meridian longitude in both System I and System II.

- **Bugfix**: Saturn was returning the wrong values for its earthward
    and sunward angle tilt.

Version 3.7.3.2 (2008 July 2)
-----------------------------

- **Bugfix**: the rising and setting functions, if called repeatedly,
  would sometimes get hung up on a single answer which they would return
  over and over again instead of progressing to the next rising or
  setting.  They should now always progress instead of getting stuck.

Version 3.7.3.1 (2008 July 1)
-----------------------------

- **Bugfix**: the rising and setting functions were attempting to
  achieve such high precision that users sometimes found circumstances
  under which they would not complete at all!  They now stop and return
  an answer once they are withing a half-second of the real time of
  rising, transit, or setting, which solves the problem without damaging
  the quality of the results when tested against the Naval Observatory.

- Upgraded to the libastro from XEphem 3.7.3.

Version 3.7.2.4 (2008 June 12)
------------------------------

- **Incompatible Change**: After feedback from users, I have changed
  the ``Observer`` methods which find risings, settings, and transits,
  so that they do not change their Observer's ``.date`` attribute.  So
  the sequence:

  .. code-block:: python

     r1 = boston.next_rising(mars)
     r2 = boston.next_rising(mars)

  now computes the same value twice!  If you want a series of calls to
  each begin when the other left off, you can use the ``start=``
  parameter described in the next item:

  .. code-block:: python

     r1 = boston.next_rising(mars)
     r2 = boston.next_rising(mars, start=r1)

- Added an optional ``start=`` argument to the rising, setting, and
  transit ``Observer`` functions, that tells them from which date and
  time to begin their search.

- **Bugfix**: Rewrote planetary moon routines so that moons of Mars,
  Jupiter, Saturn, and Uranus now return appropriate data for years
  1999-2020.  (Each moon had been returning the unmodified position of
  its planet, because I was unsure whether I could distribute the moon
  data with PyEphem.)

- You can no longer create arbitrary attributes on an ``Observer``, to
  prevent users from accidentially saying things like
  ``here.longitude`` or ``here.lon`` when they mean ``here.long``.
  Create your own subclass of ``Observer`` if you need the power to
  set your own attributes.

- The ephem module now provides a ``__version__`` symbol.

- Added test suite that tests planet and planet moon positions
  against JPL ephemeris data (needs more work).

Version 3.7.2.3 (2008 January 8)
--------------------------------

- Three new classes ``Equatorial``, ``Ecliptic``, and ``Galactic``
  allow coordinates to be transformed between the three systems
  (ability to transform coordinates was requested by Aaron Parsons).

- Added constants for popular epochs ``B1900``, ``B1950``, and
  ``J2000``.

- Added named functions for every solstice and equinox (before, only
  the vernal equinox could be asked for specifically).

- Product tests have been moved inside of the ``ephem`` module itself,
  and can now be invoked simply by running:

  .. code-block:: bash

     $ python setup.py test

- **Bugfix**: ``Angle()`` can no longer be directly instantiated.

- **Bugfix**: San Francisco had the wrong coordinates in the cities
  database (pointed out by Randolph Bentson).

Version 3.7.2.2 (2007 December 9)
---------------------------------

- The phases of the moon can now be determined through the functions
  ``next_new_moon()``, ``next_full_moon()``, ``previous_new_moon()``,
  et cetera.

- Added a modest database of world cities; the ``city()`` function
  returns a new Observer on each call:

  .. code-block:: python

     observer = ephem.city('Boston')

- Using the old ``rise``, ``set``, and ``transit`` attributes on
  ``Body`` objects now causes a deprecation warning.

- **Bugfix**: the last release of PyEphem omitted the constants
  ``meters_per_au``, ``earth_radius``, ``moon_radius``, and
  ``sun_radius``; the constant ``c`` (the speed of light) is also now
  available.

Version 3.7.2.1 (2007 October 1)
--------------------------------

- Functions now exist to find equinoxes and solstices.

- Bodies now cleanly offer three different versions of their
  position, rather than making the user remember obscure rules for
  having each of these three values computed:

  * Astrometric geocetric right ascension and declination
  * Apparent geocentric right ascension and declination
  * Apparent topocentric right ascension and declination

- Bodies can now find their next or previous times of transit,
  anti-transit, rising, and setting.

- A ``localtime()`` function can convert PyEphem ``Date`` objects to
  local time.

- Now ``ephem.angle`` instances can survive unary ``+`` and ``-``
  without getting changed into plain floats.

- The ``elev`` Observer attribute has been renamed to ``elevation``.

- Observers now display useful information when printed.

- Added a much more extensive test suite, which, among other things,
  now compares results with the United States Naval Observatory,
  insisting upon arcsecond agreement.

- **Bugfix**: When a fixed body is repeatedly precessed to different
  dates, its original position will no longer accumulate error.

Version 3.7.2a (2007 June)
--------------------------

- Upgraded to the libastro from XEphem 3.7.2.

- Should now compile under Windows!

- **Bugfix**: rewrote date-and-time parsing to avoid the use of
  ``sscanf()``, which was breaking under Windows and requiring the
  insertion of a leading space to succeed.

- Improved the error returned when a date string cannot be parsed,
  so that it now quotes the objectionable string (so you can tell
  which of several date strings on the same line gave an error!).

This form allows you to request diff's between any two revisions of a file. You may select a symbolic revision name using the selection box or you may type in a numeric name using the type-in text box.




CVSweb <webmaster@jp.NetBSD.org>