[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / math / py-Scientific-doc

File: [cvs.NetBSD.org] / pkgsrc / math / py-Scientific-doc / Attic / Makefile (download)

Revision 1.11, Thu Jan 19 18:52:17 2017 UTC (6 years, 8 months ago) by agc
Branch: MAIN
CVS Tags: pkgsrc-2017Q2-base, pkgsrc-2017Q2, pkgsrc-2017Q1-base, pkgsrc-2017Q1
Changes since 1.10: +3 -3 lines

Convert all occurrences (353 by my count) of

	MASTER_SITES= 	site1 \
			site2

style continuation lines to be simple repeated

	MASTER_SITES+= site1
	MASTER_SITES+= site2

lines. As previewed on tech-pkg. With thanks to rillig for fixing pkglint
accordingly.

# $NetBSD: Makefile,v 1.11 2017/01/19 18:52:17 agc Exp $

DISTNAME=	ScientificPython-2.4.5
PKGNAME=	py-${DISTNAME:S/Python/-doc/}
PKGREVISION=	1
CATEGORIES=	math python
MASTER_SITES=	http://starship.python.net/crew/hinsen/ScientificPython/
MASTER_SITES+=	http://dirac.cnrs-orleans.fr/programs/ScientificPython/

MAINTAINER=	pkgsrc-users@NetBSD.org
HOMEPAGE=	http://starship.python.net/crew/hinsen/scientific.html
COMMENT=	Python modules for scientific computing

CONFLICTS+=	py-Scientific-*

NO_BUILD=	yes
USE_TOOLS+=	pax
AUTO_MKDIRS=	yes

EGDIR=		${PREFIX}/share/examples/py-Scientific
DOCDIR=		${PREFIX}/share/doc/py-Scientific
HTMLDIR=	${PREFIX}/share/doc/py-Scientific/HTML

do-install:
	cd ${WRKSRC} && ${INSTALL_DATA} README LICENSE 			\
		Doc/PDF/manual.pdf ${DESTDIR}${DOCDIR}
	cd ${WRKSRC}/Doc/HTML && pax -rw -pp -pm . ${DESTDIR}${HTMLDIR}
	cd ${WRKSRC}/Examples && pax -rw -pp -pm . ${DESTDIR}${EGDIR}

.include "../../mk/bsd.pkg.mk"