[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / math / p5-Math-Pari

File: [cvs.NetBSD.org] / pkgsrc / math / p5-Math-Pari / Makefile (download)

Revision 1.25, Sat Mar 4 21:30:06 2006 UTC (17 years, 9 months ago) by jlam
Branch: MAIN
CVS Tags: pkgsrc-2006Q4-base, pkgsrc-2006Q4, pkgsrc-2006Q3-base, pkgsrc-2006Q3, pkgsrc-2006Q2-base, pkgsrc-2006Q2, pkgsrc-2006Q1-base, pkgsrc-2006Q1
Changes since 1.24: +2 -2 lines

Point MAINTAINER to pkgsrc-users@NetBSD.org in the case where no
developer is officially maintaining the package.

The rationale for changing this from "tech-pkg" to "pkgsrc-users" is
that it implies that any user can try to maintain the package (by
submitting patches to the mailing list).  Since the folks most likely
to care about the package are the folks that want to use it or are
already using it, this would leverage the energy of users who aren't
developers.

# $NetBSD: Makefile,v 1.25 2006/03/04 21:30:06 jlam Exp $
#

DISTNAME=		Math-Pari-2.010703
PKGNAME=		p5-${DISTNAME}
SVR4_PKGNAME=		p5mpa
CATEGORIES=		math perl5
MASTER_SITES=		${MASTER_SITE_PERL_CPAN:=Math/}

MAINTAINER=		pkgsrc-users@NetBSD.org
HOMEPAGE=		http://search.cpan.org/dist/Math-Pari/
COMMENT=		Perl5 interface to the pari math library

# XXX: to use or not to use...
#DEPENDS+=		gnuplot-[0-9]*:../../graphics/gnuplot

GCC_REQD+=		2.95
MAKE_ENV+=		MP_NOGNUPLOT=1
PERL5_PACKLIST=		auto/Math/Pari/.packlist

# XXX: could be improved...
PKGSRCDIR.pari=		${.CURDIR}/../../math/pari
WRKSRC.pari_cmd=		\
	cd ${PKGSRCDIR.pari} && ${MAKE} show-var VARNAME=WRKSRC

post-extract:
	cd ${PKGSRCDIR.pari:Q} && ${MAKE} configure;		\
	${RM} -f ${WRKSRC}/pari-*
	${LN} -sf ${WRKSRC.pari_cmd:sh:Q} ${WRKSRC}

pre-clean:
	cd ${PKGSRCDIR.pari:Q} && ${MAKE} clean

.include "../../lang/perl5/module.mk"
.include "../../mk/bsd.pkg.mk"