The NetBSD Project

CVS log for pkgsrc/math/openblas/Makefile

[BACK] Up to [cvs.NetBSD.org] / pkgsrc / math / openblas

Request diff between arbitrary revisions


Keyword substitution: kv
Default branch: MAIN


Revision 1.9: download - view: text, markup, annotated - select for diffs
Sat Feb 17 10:13:19 2024 UTC (11 months, 1 week ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2024Q4-base, pkgsrc-2024Q4, pkgsrc-2024Q3-base, pkgsrc-2024Q3, pkgsrc-2024Q2-base, pkgsrc-2024Q2, pkgsrc-2024Q1-base, pkgsrc-2024Q1, HEAD
Diff to: previous 1.8: preferred, colored
Changes since revision 1.8: +1 -4 lines
openblas: updated to 0.3.26

OpenBLAS 0.3.26

general:

improved the version of openblas.pc that is created by the CMAKE build
fixed a CMAKE-specific build problems on older versions of MacOS
worked around linking problems on old versions of MacOS
corrected installation location of the lapacke_mangling header in CMAKE builds
added type declarations for complex variables to the MSVC-specific parts of the LAPACK header
significantly sped up ?GESV for small problem sizes by introducing a lower bound for multithreading
imported additions and corrections from the Reference-LAPACK project:
added new LAPACK functions for truncated QR with pivoting
handle miscalculation of minimum work array size in corner cases
fixed use of uninitialized variables in ?GEDMD and improved inline documentation
fixed use of uninitialized variables (and consequential failures) in ?BBCSD
added tests for the recently introduced Dynamic Mode Decomposition functions
fixed several memory leaks in the LAPACK testsuite
fixed counting of testsuite results by the Python script

x86-64:

fixed computation of CASUM on SkylakeX and newer targets in the special
case that AVX512 is not supported by the compiler or operating environment
fixed potential undefined behaviour in the CASUM/ZASUM kernels for AVX512 targets
worked around a problem in the pre-AVX kernel for GEMV
sped up the thread management code on MS Windows

arm64:

fixed building of the LAPACK testsuite with Xcode 15 on Apple M1 and newer
sped up the thread management code on MS Windows
sped up SGEMM and DGEMM on Neoverse V1
sped up ?DOT on SVE-capable targets
reduced the number of targets in DYNAMIC_ARCH builds by eliminating functionally equivalent ones
included support for Apple M1 and newer targets in DYNAMIC_ARCH builds

power:

improved the SGEMM kernel for POWER10
fixed compilation with (very) old versions of gcc
fixed detection of old 32bit PPC targets in CMAKE-based builds
added autodetection of the POWERPC 7400 subtype
fixed CMAKE-based compilation for PPCG4 and PPC970 targets

loongarch64:

added and improved optimized kernels for almost all BLAS functions

Revision 1.8: download - view: text, markup, annotated - select for diffs
Sun Oct 15 22:08:50 2023 UTC (15 months, 1 week ago) by thor
Branches: MAIN
CVS tags: pkgsrc-2023Q4-base, pkgsrc-2023Q4
Diff to: previous 1.7: preferred, colored
Changes since revision 1.7: +2 -2 lines
math/openblas*: more portable sed for .pc modification

The old path added \b, which is not POSIX BRE. [:space:] works better with
differing seds. It removes more than \b, but in our installs, the following
suffix variable is emtpy, anyway.

Revision 1.7: download - view: text, markup, annotated - select for diffs
Sun Oct 8 15:41:33 2023 UTC (15 months, 2 weeks ago) by thor
Branches: MAIN
Diff to: previous 1.6: preferred, colored
Changes since revision 1.6: +2 -1 lines
math/openblas: Fix pkg-config file for current version.

The last update broke the library name in the installed pkg-config file
for the openblas variants. Fixing this.

Our type of library naming should be pushed upstream, or adapted to
some other scheme.

Revision 1.6: download - view: text, markup, annotated - select for diffs
Sun Sep 17 08:56:18 2023 UTC (16 months, 1 week ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2023Q3-base, pkgsrc-2023Q3
Diff to: previous 1.5: preferred, colored
Changes since revision 1.5: +1 -2 lines
openblas*: updated to 0.3.24

OpenBLAS 0.3.24

general:

declared the arguments of cblas_xerbla as const (in accordance with the reference implementation
and others, the previous discrepancy appears to have dated back to GotoBLAS)
fixed the implementation of ?GEMMT that was added in 0.3.23
made cpu-specific SWITCH_RATIO parameters for GEMM available to DYNAMIC_ARCH builds
fixed application of SYMBOLSUFFIX in CMAKE builds
fixed missing SSYCONVF function in the shared library
fixed parallel build logic used with gmake
added support for compilation with LLVM17, in particular its new Fortran compiler
added support for CMAKE builds using the NVIDIA HPC compiler
fixed INTERFACE64 builds with CMAKE and the f95 Fortran compiler
fixed cross-build detection and management in c_check
disabled building of the tests with CMAKE when ONLY_CBLAS is defined
fixed several issues with the handling of runtime limits on the number of OPENMP threads
corrected the error code returned by SGEADD/DGEADD when LDA is too small
corrected the error code returned by IMATCOPY when LDB is too small
updated ?NRM2 to support negative increment values (as introduced in release 3.10.0
of the Reference BLAS)
updated ?ROTG to use the safe scaling algorithm introduced in release 3.10.0 of the Reference BLAS
fixed OpenMP builds with CLANG for the case where libomp is not in a standard location
fixed a potential overwrite of unrelated memory during thread initialisation on startup
fixed a potential integer overflow in the multithreading threshold for ?SYMM/?SYRK
fixed build of the LAPACKE interfaces for the LAPACK 3.11.0 ?TRSYL functions added in 0.3.22
fixed installation of .cmake files in concurrent 32 and 64bit builds with CMAKE
applied additions and corrections from the development branch of Reference-LAPACK:
fixed actual arguments passed to a number of LAPACK functions (from Reference-LAPACK PR 885)
fixed workspace query results in LAPACK ?SYTRF/?TRECV3 (from Reference-LAPACK PR 883)
fixed derivation of the UPLO parameter in LAPACKE_?larfb (from Reference-LAPACK PR 878)
fixed a crash in LAPACK ?GELSDD on NRHS=0 (from Reference-LAPACK PR 876)
added new LAPACK utility functions CRSCL and ZRSCL (from Reference-LAPACK PR 839)
corrected the order of eigenvalues for 2x2 matrices in ?STEMR (Reference-LAPACK PR 867)
removed spurious reference to OpenMP variables outside OpenMP contexts (Reference-LAPACK PR 860)
updated file comments on use of LAMBDA variable in LAPACK (Reference-LAPACK PR 852)
fixed documentation of LAPACK SLASD0/DLASD0 (Reference-LAPACK PR 855)
fixed confusing use of "minor" in LAPACK documentation (Reference-LAPACK PR 849)
added new LAPACK functions ?GEDMD for dynamic mode decomposition (Reference-LAPACK PR 736)
fixed potential stack overflows in the EIG part of the LAPACK testsuite (Reference-LAPACK PR 854)
applied small improvements to the variants of Cholesky and QR functions (Reference-LAPACK PR 847)
removed unused variables from LAPACK ?BDSQR (Reference-LAPACK PR 832)
fixed a potential crash on allocation failure in LAPACKE SGEESX/DGEESX (Reference-LAPACK PR 836)
added a quick return from SLARUV/DLARUV for N < 1 (Reference-LAPACK PR 837)
updated function descriptions in LAPACK ?GEGS/?GEGV (Reference-LAPACK PR 831)
improved algorithm description in ?GELSY (Reference-LAPACK PR 833)
fixed scaling in LAPACK STGSNA/DTGSNA (Reference-LAPACK PR 830)
fixed crash in LAPACKE_?geqrt with row-major data (Reference-LAPACK PR 768)
added LAPACKE interfaces for C/ZUNHR_COL and S/DORHR_COL (Reference-LAPACK PR 827)
added error exit tests for SYSV/SYTD2/GEHD2 to the testsuite (Reference-LAPACK PR 795)
fixed typos in LAPACK source and comments (Reference-LAPACK PRs 809,811,812,814,820)
adopt refactored ?GEBAL implementation (Reference-LAPACK PR 808)

x86_64:

added cpu model autodetection for Intel Alder Lake N
added activation of the AMX tile to the Sapphire Rapids SBGEMM kernel
worked around miscompilations of GEMV/SYMV kernels by gcc's tree-vectorizer
fixed compilation of Cooperlake and Sapphire Rapids kernels with CLANG
fixed runtime detection of Cooperlake and Sapphire Rapids in DYNAMIC_ARCH
fixed feature-based cputype fallback in DYNAMIC_ARCH
added support for building the AVX512 kernels with the NVIDIA HPC compiler
corrected ZAXPY result on old pre-AVX hardware for the INCX=0 case
fixed a potential use of uninitialized variables in ZTRSM

ARMV8:

added cpu model autodetection for Apple M2
fixed wrong results of CGEMM/CTRMM/DNRM2 under OSX (use of reserved register)
added support for building the SVE kernels with the NVIDIA HPC compiler
added support for building the SVE kernels with the Apple Clang compiler
fixed compiler option handling for building the SVE kernels with LLVM
implemented SWITCH_RATIO parameter for improved GEMM performance on Neoverse
activated SVE SGEMM and DGEMM kernels for Neoverse V1
improved performance of the SVE CGEMM and ZGEMM kernels on Neoverse V1
improved kernel selection for the ARMV8SVE target and added it to DYNAMIC_ARCH
fixed runtime check for SVE availability in DYNAMIC_ARCH builds to take OS or
container restrictions into account
fixed a potential use of uninitialized variables in ZTRSM
fix a potential misdetection of ARMV8 hardware as 32bit in CMAKE builds

LOONGARCH64:

added ABI detection
added support for cpu affinity handling
fixed compilation with early versions of the Loongson toolchain
added an optimized SGEMM kernel for 3A5000
added optimized DGEMV kernels for 3A5000
improved the performance of the DGEMM kernel for 3A5000

MIPS64:

fixed miscompilation of TRMM kernels for the MIPS64_GENERIC target

POWER:

fixed compiler warnings in the POWER10 SBGEMM kernel

RISCV:

fixed application of the INTERFACE64 option when building with CMAKE
fix a potential misdetection of RISCV hardware as 32bit in CMAKE builds
fixed IDAMAX and DOT kernels for C910V
fixed corner cases in the ROT and SWAP kernels for C910V
fixed compilation of the C910V target with recent vendor compilers

Revision 1.5: download - view: text, markup, annotated - select for diffs
Tue Jun 28 11:34:37 2022 UTC (2 years, 6 months ago) by wiz
Branches: MAIN
CVS tags: pkgsrc-2023Q2-base, pkgsrc-2023Q2, pkgsrc-2023Q1-base, pkgsrc-2023Q1, pkgsrc-2022Q4-base, pkgsrc-2022Q4, pkgsrc-2022Q3-base, pkgsrc-2022Q3
Diff to: previous 1.4: preferred, colored
Changes since revision 1.4: +2 -2 lines
*: recursive bump for perl 5.36

Revision 1.4: download - view: text, markup, annotated - select for diffs
Tue Jun 15 04:41:52 2021 UTC (3 years, 7 months ago) by thor
Branches: MAIN
CVS tags: pkgsrc-2022Q2-base, pkgsrc-2022Q2, pkgsrc-2022Q1-base, pkgsrc-2022Q1, pkgsrc-2021Q4-base, pkgsrc-2021Q4, pkgsrc-2021Q3-base, pkgsrc-2021Q3, pkgsrc-2021Q2-base, pkgsrc-2021Q2
Diff to: previous 1.3: preferred, colored
Changes since revision 1.3: +3 -2 lines
mk/blas.bl3, Netlib and OpenBLAS packages, NumPy: C fixup and 64 bits

This delivers 64 bit index BLAS libraries alongside 32 bit ones. This is often
called ILP64 in the BLAS world, as opposed to LP64 where integers are 32 bit
due to the Fortran default integer type, not to be confused with the basic
system ABI used by C. For really large vectors on modern machines, you want
an 'ILP64' BLAS and layers on top of it.

In preparation of better support for vendor BLAS libraries, I had to realize
that you better use the C interfaces supplied by them, not the netlib one
strapped on. A simple reason of practicability: The vendor blas libraries,
just like openblas, like to ship all symbols in one library, so you get them
whether you want it or not. Also implementations may skip Fortran and implement
the underlying functionality directly in C anyway, so one might skip a
layer of indirection. Future will tell if other layers will follow. We still
have the framework of individual layers from Netlib to combine with certain
implementations that miss them (Accelerate framework comes to mind, which
needs further work).

The framework of netlib reference packages for the separate libraries
is instructive and helps keeping things small when you not need all of them.
The installation location of the headers is now in a subdirectory to be able
to have 32 and 64 bit variants independently. The 32 bit ones are linked to
${PREFIX}/include to keep the old picture. We could be brave and remove
those, but there is some value in a build just trying -lcblas and
inclusion of <cblas.h> to be happy.

There is one blas.buildlink3.mk that is supposed to be used only once and
so avoids a combination of conflicting libraries (as the 64 bit index symbols
have the same names as the 32 bit ones).

Basic usage for getting LAPACK+BLAS is still the same as before. You get
CBLAS and LAPACKE by setting BLAS_C_INTERFACE=yes in the package. The 64 bit
indices are selected via BLAS_INDEX64=yes.

Due to the special nature of the Accelerate framework, a package has to
explicitly indicate support for it and it will also not appear on the
list of implementations by default. The reason is that it does provide
mainly CBLAS and CLAPACK (another version of C interface to LAPACK, f2c-based)
and BLAS/LAPACK with f2c/g77 calling conventions. A default build with
gfortran would not like that

This commit also fixes up math/py-numpy and math/py-numpy16 to follow the
new scheme, as that are the only packages directly affected by the change
in CBLAS providership.

Revision 1.3: download - view: text, markup, annotated - select for diffs
Sat May 29 19:57:21 2021 UTC (3 years, 7 months ago) by thor
Branches: MAIN
Diff to: previous 1.2: preferred, colored
Changes since revision 1.2: +1 -2 lines
math/openblas: update to version 0.3.15

This includes a rework of our patchery with the hope of upstreaming a good deal
of it.

These are the upstream changes since 0.3.10:

Version 0.3.15
  2-May-2021

common:
 - imported improvements and bugfixes from Reference-LAPACK 3.9.1
 - imported LAPACKE interface fixes from Reference-LAPACK PRs 534 + 537
 - fixed a problem in the cpu detection of 0.3.14 that prevented cross-compilation
 - fixed a sequence problem in the generation of softlinks to the library in GMAKE

RISC V:
 - fixed compilation on RISCV (missing entry in getarch)
 - fixed a potential division by zero in CROTG and ZROTG

POWER:
 - fixed LAPACK testsuite failures seen with the NVIDIA HPC compiler
 - improved CGEMM, DGEMM and ZGEMM performance on POWER10
 - added an optimized ZGEMV kernel for POWER10
 - fixed a potential division by zero in CROTG and ZROTG

x86_64:
 - added support for Intel Control-flow Enforcement Technology (CET)
 - reverted the DOMATCOPY_RT code to the generic C version
 - fixed a bug in the AVX512 SGEMM kernel introduced in 0.3.14
 - fixed misapplication of -msse flag to non-SSE cpus in DYNAMIC_ARCH
 - added support for compilation of the benchmarks on older OSX versions
 - fix propagation of the NO_AVX512 option in CMAKE builds
 - fix compilation of the AVX512 SGEMM kernel with clang-cl on Windows
 - fixed compilation of the CTESTs with INTERFACE64=1 (random faults on OSX)
 - corrected the Haswell DROT kernel to require AVX2/FMA3 rather than AVX512

ARM:
 - fixed a potential division by zero in CROTG and ZROTG
 - fixed a potential overflow in IMATCOPY/ZIMATCOPY and the CTESTs

ARM64:
 - fixed spurious reads outside the array in the SGEMM tcopy macro
 - fixed a potential division by zero in CROTG and ZROTG
 - fixed a segmentation fault in DYNAMIC_ARCH builds (reappeared in 0.3.14)

MIPS
 - fixed a potential division by zero in CROTG and ZROTG
 - fixed a potential overflow in IMATCOPY/ZIMATCOPY and the CTESTs

MIPS64:
 - fixed a potential division by zero in CROTG and ZROTG

SPARC:
 - fixed a potential division by zero in CROTG and ZROTG

====================================================================
Version 0.3.14
 17-Mar-2021

 common:
	* Fixed a race condition on thread shutdown in non-OpenMP builds
	* Fixed custom BUFFERSIZE option getting ignored in gmake builds
	* Fixed CMAKE compilation of the TRMM kernels for GENERIC platforms
	* Added CBLAS interfaces for CROTG, ZROTG, CSROT and ZDROT
	* Improved performance of OMATCOPY_RT across all platforms
	* Changed perl scripts to use env instead of a hardcoded /usr/bin/perl
	* Fixed potential misreading of the GCC compiler version in the build scripts
	* Fixed convergence problems in LAPACK complex GGEV/GGES (Reference-LAPACK #477)
	* Reduced the stacksize requirements for running the LAPACK testsuite (Reference-LAPACK #335)

 RISCV:
 	* Fixed compilation on RISCV (missing entry in getarch)

 POWER:
 	* Fixed compilation for DYNAMIC_ARCH with clang and with old gcc versions
	* Added support for compilation on FreeBSD/ppc64le
 	* Added optimized POWER10 kernels for SSCAL, DSCAL, CSCAL, ZSCAL
	* Added optimized POWER10 kernels for SROT, DROT, CDOT, SASUM, DASUM
	* Improved SSWAP, DSWAP, CSWAP, ZSWAP performance on POWER10
	* Improved SCOPY and CCOPY performance on POWER10
	* Improved SGEMM and DGEMM performance on POWER10
	* Added support for compilation with the NVIDIA HPC compiler

 x86_64:
	* Added an optimized bfloat16 GEMM kernel for Cooperlake
	* Added CPUID autodetection for Intel Rocket Lake and Tiger Lake cpus
	* Improved the performance of SASUM,DASUM,SROT,DROT on AMD Ryzen cpus
	* Added support for compilation with the NAG Fortran compiler
	* Fixed recognition of the AMD AOCC compiler
	* Fixed compilation for DYNAMIC_ARCH with clang on Windows
	* Added support for running the BLAS/CBLAS tests on Windows
	* Fixed signatures of the tls callback functions for Windows x64
	* Fixed various issues with fma intrinsics support handling

 ARM:
	* Added support for embedded Cortex M targets via a new option EMBEDDED

 ARMV8:
 	* Fixed the THUNDERX2T99 and NEOVERSEN1 DNRM2/ZNRM2 kernels for inputs with Inf
	* Added support for the DYNAMIC_LIST option
	* Added support for compilation with the NVIDIA HPC compiler
 	* Added support for compiling with the NAG Fortran compiler

====================================================================
Version 0.3.13
 12-Dec-2020

 common:
	* Added a generic bfloat16 SBGEMV kernel
	* Fixed a potentially severe memory leak after fork in OpenMP builds
	  that was introduced in 0.3.12
	* Added detection of the Fujitsu Fortran compiler
	* Added detection of the (e)gfortran compiler on OpenBSD
	* Added support for overriding the default name of the library independently
	  from symbol suffixing in the gmake builds (already supported in cmake)

RISCV:
	* Added a RISC V port optimized for C910V

POWER:
	* Added optimized POWER10 kernels for SAXPY, CAXPY, SDOT, DDOT and DGEMV_N
	* Improved DGEMM performance on POWER10
	* Improved STRSM and DTRSM performance on POWER9 and POWER10
	* Fixed segmemtation faults in DYNAMIC_ARCH builds
 	* Fixed compilation with the PGI compiler

x86:
	* Fixed compilation of kernels that require SSE2 intrinsics since 0.3.12

x86_64:
	* Added an optimized bfloat16 SBGEMV kernel for SkylakeX and Cooperlake
	* Improved the performance of SASUM and DASUM kernels through parallelization
	* Improved the performance of SROT and DROT kernels
	* Improved the performance of multithreaded xSYRK
	* Fixed OpenMP builds that use the LLVM Clang compiler together with GNU gfortran
	  (where linking of both the LLVM libomp and GNU libgomp could lead to lockups or
	  wrong results)
	* Fixed miscompilations by old gcc 4.6
	* Fixed misdetection of AVX2 capability in some Sandybridge cpus
	* Fixed lockups in builds combining DYNAMIC_ARCH with TARGET=GENERIC on OpenBSD

ARM64:
	* Fixed segmemtation faults in DYNAMIC_ARCH builds

MIPS:
	* Improved kernels for Loongson 3R3 ("3A") and 3R4 ("3B") models, including MSA
	* Fixed bugs in the MSA kernels for CGEMM, CTRMM, CGEMV and ZGEMV
	* Added handling of zero increments in the MSA kernels for SSWAP and DSWAP
	* Added DYNAMIC_ARCH support for MIPS64 (currently Loongson3R3/3R4 only)

SPARC:
	* Fixed building 32 and 64 bit SPARC kernels with the SolarisStudio compilers

====================================================================
Version 0.3.12
 24-Oct-2020

common:
	* Fixed missing BLAS/LAPACK functions (inadvertently dropped during
	  the build system restructuring)
	* Fixed argument conversion macro in LAPACKE_zgesvdq (LAPACK #458)

POWER:
	* Added optimized SCOPY/CCOPY kernels for POWER10
	* Increased and unified the default size of the GEMM BUFFER
	* Fixed building for POWER10 in DYNAMIC_ARCH mode
	* POWER10 compatibility test now checks binutils version as well
	* Cleaned up compiler warnings

x86_64:
	* corrected compiler version checks for AVX2 compatibility
	* added compiler option -mavx2 for building with flang
	* fixed direct SGEMM pathway for small matrix sizes (broken by
	  the code refactoring in 0.3.11)
	* fixed unhandled partial register clobbers in several kernels
	  for AXPY,DOT,GEMV_N and GEMV_T flagged by gcc10 tree-vectorizer

ARMV8:
	* improved Apple Vortex support to include cross-compiling

====================================================================
Version 0.3.11
 17-Oct-2020

common:
 	* API change:
	  the newly added BFLOAT16 functions were renamed to use the
	  letter "B" instead of "H" to avoid potential confusion with
	  the IEEE "half precision float" type, i.e. the 0.3.10
	  SHGEMM is now SBGEMM and the corresponding build option
	  was changed from "BUILD_HALF" to "BUILD_BFLOAT16".
	* Reduced the default BLAS3_MEM_ALLOC_THRESHOLD (used as an upper
	  limit for placing temporary arrays on the stack) to be compatible
	  with a stack size of 1mb (as imposed by the JAVA runtime library)
	* Added mixed-precision dot function SBDOT and utility functions
	  shstobf16, shdtobf16, sbf16tos and dbf16tod to convert between
	  single or double precision float arrays and bfloat16 arrays
	* Fixed prototypes of LAPACK_?ggsvp and LAPACK_?ggsvd functions
	  in lapack.h
	* Fixed underflow and rounding errors in LAPACK SLANV2 and DLANV2
	  (causing miscalculations in e.g. SHSEQR/DHSEQR, LAPACK issue #263)
	* Fixed workspace calculation in LAPACK ?GELQ (LAPACK issue #415)
	* Fixed several bugs in the LAPACK testsuite
	* Improved performance of TRMM and TRSM for certain problem sizes
	* Fixed infinite recursions and workspace miscalculations in ReLAPACK
	* CMAKE builds no longer require pkg-config for creating the .pc file
	* Makefile builds no longer misread NO_CBLAS=0 or NO_LAPACK=0 as
	  enabling these options
	* Fixed detection of gfortran when invoked through an mpi wrapper
	* Improve thread reinitialization performance with OpenMP after a fork
	* Added support for building only the subset of the library required
	  for a particular precision by specifying BUILD_SINGLE, BUILD_DOUBLE
	* Optional function name prefixes and suffixes are now correctly
	  reflected in the generated cblas.h
	* Added CMAKE build support for the LAPACK and multithreading tests

POWER:
	* Added optimized support for POWER10
	* Added support for compiling for POWER8 in 32bit mode
	* Added support for compilation with LLVM/clang
	* Added support for compilation with NVIDIA/PGI compilers
	* Fixed building on big-endian POWER8
	* Fixed miscompilation of ZDOTC by gcc10
	* Fixed alignment errors in the POWER8 SAXPY kernel
	* Improved CPU detection on AIX
	* Supported building with older compilers on POWER9

x86_64:
	* Added support for Intel Cooperlake
	* Added autodetection of AMD Renoir/Matisse/Zen3 cpus
	* Added autodetection of Intel Comet Lake cpus
	* Reimplemented ?sum, ?dot and daxpy using universal intrinsics
	* Reset the fpu state before using the fpu on Windows as a workaround
	  for a problem introduced in Windows 10 build 19041 (a.k.a. SDK 2004)
	* Fixed potentially undefined behaviour in the dot and gemv_t kernels
	* Fixed a potential segmentation fault in DYNAMIC_ARCH builds
	* Fixed building for ZEN with PGI/NVIDIA and AMD AOCC compilers

ARMV7:
	* Fixed cpu detection on BSD-like systems

ARMV8:
	* Added preliminary support for Apple Vortex cpus
	* Added support for the Cavium ThunderX3T110 cpu
	* Fixed cpu detection on BSD-like systems
	* Fixed compilation in -std=C18 mode

IBM Z:
	* Added support for compiling with the clang compiler
	* Improved GEMM performance on Z14

Revision 1.2: download - view: text, markup, annotated - select for diffs
Mon May 24 19:52:56 2021 UTC (3 years, 8 months ago) by wiz
Branches: MAIN
Diff to: previous 1.1: preferred, colored
Changes since revision 1.1: +2 -1 lines
*: recursive bump for perl 5.34

Revision 1.1: download - view: text, markup, annotated - select for diffs
Thu Nov 5 16:31:45 2020 UTC (4 years, 2 months ago) by bacon
Branches: MAIN
CVS tags: pkgsrc-2021Q1-base, pkgsrc-2021Q1, pkgsrc-2020Q4-base, pkgsrc-2020Q4
math/openblas: import openblas-0.3.7

OpenBLAS is an optimized BLAS library based on GotoBLAS2 1.13 BSD version.
OpenBLAS is an open source project supported by
Lab of Parallel Software and Computational Science, ISCAS.

This package builds the serial library.

Needs patching and testing on platforms besides Linux

Diff request

This form allows you to request diffs between any two revisions of a file. You may select a symbolic revision name using the selection box or you may type in a numeric name using the type-in text box.

Log view options

CVSweb <webmaster@jp.NetBSD.org>