[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / math / octave

Annotation of pkgsrc/math/octave/Makefile, Revision 1.150

1.150   ! adam        1: # $NetBSD: Makefile,v 1.149 2017/02/28 15:20:08 ryoon Exp $
1.1       tron        2:
1.142     maya        3: DISTNAME=      octave-4.2.0
1.150   ! adam        4: PKGREVISION=   8
1.1       tron        5: CATEGORIES=    math
1.120     rodent      6: MASTER_SITES=  ${MASTER_SITE_GNU:=octave/}
1.2       tron        7:
1.52      adam        8: MAINTAINER=    adam@NetBSD.org
1.67      wiz         9: HOMEPAGE=      http://www.octave.org/
1.52      adam       10: COMMENT=       High-level language, intended for numerical computations
1.121     rodent     11: LICENSE=       gnu-gpl-v3
1.2       tron       12:
1.132     dbj        13: # These BUILD_DEPENDS are only needed if we need to rebuild the documentation
                     14: #BUILD_DEPENDS+=       tex-latex-fonts-[0-9]*:../../fonts/tex-latex-fonts
                     15: #BUILD_DEPENDS+=       dvipsk-[0-9]*:../../print/dvipsk
                     16: #BUILD_DEPENDS+=       tex-epsf-[0-9]*:../../print/tex-epsf
                     17: #BUILD_DEPENDS+=       tex-tex-[0-9]*:../../print/tex-tex
                     18: #BUILD_DEPENDS+=       tex-pdftex-[0-9]*:../../print/tex-pdftex
                     19: #TOOL_DEPENDS+=        gtexinfo>=5.1:../../devel/gtexinfo
                     20:
1.52      adam       21: DEPENDS+=      gnuplot>=3.7:../../graphics/gnuplot
1.23      wennmach   22:
1.94      asau       23: USE_LIBTOOL=           yes
1.132     dbj        24: USE_TOOLS+=            autoconf gsed gmake:run perl pkg-config bison
1.3       tron       25: GNU_CONFIGURE=         yes
1.52      adam       26:
1.59      adam       27: GCC_REQD+=             3.0
1.87      asau       28: USE_LANGUAGES=         c c++ fortran77
1.52      adam       29:
                     30: # needed for loading of shared objects such as those in the
1.72      adam       31: # octave-forge package or user written ones compiled with mkoctfile
1.52      adam       32: CONFIGURE_ARGS+=       --enable-dl
1.72      adam       33: CONFIGURE_ARGS+=       --enable-static
1.93      drochner   34: CONFIGURE_ARGS+=       --enable-shared
1.72      adam       35:
1.132     dbj        36: #CONFIGURE_ARGS+=      --without-opengl
                     37: #CONFIGURE_ARGS+=      --with-framework-opengl=no
                     38: CONFIGURE_ARGS+=       --disable-java
                     39: # use this to bypass qt5 portability issues:
                     40: #CONFIGURE_ARGS+=      CPPFLAGS=-DQT_DISABLE_DEPRECATED_BEFORE=0
                     41:
                     42: .include "../../mk/bsd.prefs.mk"
                     43:
                     44: # When __APPLE__ is defined, fltk headers typedef an alternate version of Window
                     45: # which conflicts with the one in the X11 headers, so avoid pulling in X11.
1.133     jperkin    46: CONFIGURE_ARGS.Darwin+=        --without-x
1.132     dbj        47:
                     48: # The OpenGL framework doesn't have osmesa and the X11 one has header conflicts with the framework
1.133     jperkin    49: CONFIGURE_ARGS.Darwin+=        --without-OSMesa
1.107     prlw1      50:
1.124     dbj        51: # We use this to install .oct files so it doesn't strip them.
                     52: CONFIGURE_ENV+=                INSTALL_LIB=${INSTALL_LIB:Q}
                     53:
1.52      adam       54: .include "options.mk"
                     55:
1.70      adam       56: INFO_FILES=    yes
1.132     dbj        57: OCTAVE_DOC=    doc/interpreter/octave.pdf doc/liboctave/liboctave.pdf \
                     58:                doc/refcard/refcard-a4.pdf doc/refcard/refcard-legal.pdf \
                     59:                doc/refcard/refcard-letter.pdf
                     60: INSTALLATION_DIRS+=    share/octave/${PKGVERSION_NOREV}/doc
1.52      adam       61:
1.132     dbj        62: #CHECK_WRKREF_SKIP+=   share/octave/${PKGVERSION_NOREV}/etc/config.log
1.94      asau       63:
                     64: TEST_TARGET=   check
1.25      jtb        65:
1.94      asau       66: #pre-configure:
                     67: #      cd ${WRKSRC} && autoconf
1.82      asau       68:
1.105     asau       69: SUBST_CLASSES+=                        fix-make
1.132     dbj        70: SUBST_STAGE.fix-make=          pre-configure
1.105     asau       71: SUBST_MESSAGE.fix-make=                Fixing path to gmake.
1.132     dbj        72: SUBST_FILES.fix-make=          scripts/pkg/private/configure_make.m
1.139     prlw1      73: SUBST_SED.fix-make=            -e 's:@GMAKE@:${GMAKE}:g'
1.105     asau       74:
1.132     dbj        75: SUBST_CLASSES+=                        qt5-pkg-config
                     76: SUBST_STAGE.qt5-pkg-config=    pre-configure
                     77: SUBST_MESSAGE.qt5-pkg-config=  Updating pkg-config calls for Qt5
                     78: SUBST_FILES.qt5-pkg-config=    configure.ac configure
                     79: SUBST_SED.qt5-pkg-config=      -e 's,QtCore,Qt5Core,g'
                     80: SUBST_SED.qt5-pkg-config+=     -e 's,QtGui,Qt5Widgets,g'
                     81: SUBST_SED.qt5-pkg-config+=     -e 's,QtNetwork,Qt5Network,g'
                     82: SUBST_SED.qt5-pkg-config+=     -e 's,QtOpenGL,Qt5OpenGL,g'
                     83:
1.135     joerg      84: # Matches reduce-relocations logic in x11/qt5-qtbase
                     85: .if ${OPSYS} != "Darwin" && ${OPSYS} != "SunOS" && \
                     86:       (!empty(MACHINE_ARCH:Mi386) || !empty(MACHINE_ARCH:Mx86_64))
                     87: CFLAGS+=       -fPIC
                     88: .endif
                     89:
1.132     dbj        90: PREPEND_PATH+=                 ${QTDIR}/bin
                     91:
                     92: MAKE_ENV+=                     V=1
                     93:
                     94: #post-extract:
                     95: #      find ${WRKSRC}/doc -type f -name '*.info*' -print | xargs rm -f
                     96: #      mkdir ${WRKSRC}/src/pic
                     97:
                     98: post-install:
                     99: .for f in ${OCTAVE_DOC}
                    100:        ${INSTALL_DATA} ${WRKSRC}/${f} ${DESTDIR}${PREFIX}/share/octave/${PKGVERSION_NOREV}/doc
                    101: .endfor
1.11      agc       102:
1.52      adam      103: .include "../../audio/libsndfile/buildlink3.mk"
1.72      adam      104: .include "../../devel/ncurses/buildlink3.mk"
1.100     asau      105: .include "../../devel/pcre/buildlink3.mk"
1.52      adam      106: .include "../../devel/readline/buildlink3.mk"
1.72      adam      107: .include "../../devel/zlib/buildlink3.mk"
1.139     prlw1     108: .include "../../graphics/hicolor-icon-theme/buildlink3.mk"
1.132     dbj       109: .include "../../math/arpack/buildlink3.mk"
1.52      adam      110: .include "../../math/blas/buildlink3.mk"
                    111: .include "../../math/fftw/buildlink3.mk"
1.132     dbj       112: .include "../../math/fftwf/buildlink3.mk"
1.52      adam      113: .include "../../math/lapack/buildlink3.mk"
1.78      adam      114: .include "../../www/curl/buildlink3.mk"
1.132     dbj       115: .if ${OPSYS} != "Darwin"
1.80      asau      116: .include "../../x11/libX11/buildlink3.mk"
1.132     dbj       117: .endif
                    118: .include "../../x11/qt5-qtbase/buildlink3.mk"
                    119: BUILDLINK_DEPMETHOD.qt5-qttools?=build
                    120: .include "../../x11/qt5-qttools/buildlink3.mk"
                    121: BUILDLINK_DEPMETHOD.gperf?=build
                    122: .include "../../devel/gperf/buildlink3.mk"
                    123: .include "../../x11/fltk13/buildlink3.mk"
1.80      asau      124:
1.83      adam      125: .include "../../sysutils/desktop-file-utils/desktopdb.mk"
1.18      veego     126: .include "../../mk/bsd.pkg.mk"

CVSweb <webmaster@jp.NetBSD.org>