File:  [cvs.NetBSD.org] / pkgsrc / math / lapack / Makefile.common
Revision 1.12: download - view: text, annotated - select for diffs
Mon Oct 12 21:51:57 2020 UTC (4 years, 6 months ago) by bacon
Branches: MAIN
CVS tags: pkgsrc-2021Q1-base, pkgsrc-2021Q1, pkgsrc-2020Q4-base, pkgsrc-2020Q4, HEAD
math/blas, math/lapack: Install interchangeable BLAS system

Install the new interchangeable BLAS system created by Thomas Orgis,
currently supporting Netlib BLAS/LAPACK, OpenBLAS, cblas, lapacke, and
Apple's Accelerate.framework.  This system allows the user to select any
BLAS implementation without modifying packages or using package options, by
setting PKGSRC_BLAS_TYPES in mk.conf. See mk/blas.buildlink3.mk for details.

This commit should not alter behavior of existing packages as the system
defaults to Netlib BLAS/LAPACK, which until now has been the only supported
implementation.

Details:

Add new mk/blas.buildlink3.mk for inclusion in dependent packages
Install compatible Netlib math/blas and math/lapack packages
Update math/blas and math/lapack MAINTAINER approved by adam@
OpenBLAS, cblas, and lapacke will follow in separate commits
Update direct dependents to use mk/blas.buildlink3.mk
Perform recursive revbump

# $NetBSD: Makefile.common,v 1.12 2020/10/12 21:51:57 bacon Exp $
# used by math/blas/Makefile
# used by math/cblas/Makefile
# used by math/lapacke/Makefile
# used by math/lapack/Makefile

# Common Makefile for packages derived from the Netlib BLAS/LAPACK sources.
# Package Makefile sets LAPACK_COMPONENT and LAPACK_COMPONENT_CMAKE_ARGS to
# choose the library to install.
# LAPACK_COMPONENT can be "lapack", "lapacke", or "cblas"

DISTNAME=	lapack-${NETLIB_BLAS_VERSION}
PKGNAME=	${LAPACK_COMPONENT}-${NETLIB_BLAS_VERSION}
CATEGORIES=	math
MASTER_SITES=	${MASTER_SITE_GITHUB:=Reference-LAPACK/}
GITHUB_PROJECT=	lapack
GITHUB_TAG=	v${NETLIB_BLAS_VERSION}

HOMEPAGE=	https://www.netlib.org/lapack/
LICENSE=	modified-bsd

# All parts are in the same section
PATCHDIR=	${.CURDIR}/../../math/lapack/patches
DISTINFO_FILE=	${.CURDIR}/../../math/lapack/distinfo

USE_LANGUAGES=	c fortran
USE_CMAKE=	yes

WRKSRC=		${WRKDIR}/${DISTNAME}
CONFIGURE_DIRS=	build
CMAKE_ARG_PATH=	${WRKSRC}

# Note: We patch the build to install both static and
# shared libraries.
CMAKE_ARGS=	-DBUILD_DEPRECATED=ON \
		-DBUILD_SHARED_LIBS=ON \
		-DBUILD_STATIC_LIBS=ON \
		${LAPACK_COMPONENT_CMAKE_ARGS}

.include "../../math/lapack/version.mk"

post-extract:
	${RUN} ${MKDIR} ${WRKSRC}/build

CVSweb <webmaster@jp.NetBSD.org>