[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / math / grace

File: [cvs.NetBSD.org] / pkgsrc / math / grace / Makefile (download)

Revision 1.64, Thu Jan 19 18:52:17 2017 UTC (6 years, 8 months ago) by agc
Branch: MAIN
CVS Tags: pkgsrc-2017Q1-base, pkgsrc-2017Q1
Changes since 1.63: +5 -5 lines

Convert all occurrences (353 by my count) of

	MASTER_SITES= 	site1 \
			site2

style continuation lines to be simple repeated

	MASTER_SITES+= site1
	MASTER_SITES+= site2

lines. As previewed on tech-pkg. With thanks to rillig for fixing pkglint
accordingly.

# $NetBSD: Makefile,v 1.64 2017/01/19 18:52:17 agc Exp $

DISTNAME=	grace-5.1.25
CATEGORIES=	math graphics x11
MASTER_SITES=	ftp://plasma-gate.weizmann.ac.il/pub/grace/src/stable/
MASTER_SITES+=	ftp://ftp.fu-berlin.de/unix/graphics/grace/src/stable/
MASTER_SITES+=	ftp://ftp.ru.xemacs.org/pub/math/grace/src/stable/
MASTER_SITES+=	ftp://ftp.u-aizu.ac.jp/pub/SciEng/math/grace/src/stable/

MAINTAINER=	pkgsrc-users@NetBSD.org
HOMEPAGE=	http://plasma-gate.weizmann.ac.il/Grace/
COMMENT=	GRaphing, Advanced Computation and Exploration of data
LICENSE=	gnu-gpl-v2

USE_TOOLS+=		gmake
USE_LANGUAGES=		c fortran77
GNU_CONFIGURE=		YES
CONFIGURE_ARGS+=	--enable-grace-home=${PREFIX}/grace
CONFIGURE_ARGS+=	--without-bundled-xbae

INSTALLATION_DIRS=	bin

# test require X
#TEST_TARGET=		check

post-install:
	${RM} -f ${DESTDIR}${PREFIX}/bin/xmgrace
	${LN} -s ${DESTDIR}${PREFIX}/grace/bin/xmgrace ${DESTDIR}${PREFIX}/bin

.include "../../devel/netcdf/buildlink3.mk"
.include "../../fonts/t1lib/buildlink3.mk"
.include "../../mk/jpeg.buildlink3.mk"
.include "../../graphics/png/buildlink3.mk"
.include "../../graphics/tiff/buildlink3.mk"
.include "../../math/fftw2/buildlink3.mk"
.include "../../print/pdflib-lite/buildlink3.mk"
.include "../../x11/Xbae/buildlink3.mk"
.include "../../x11/XmHTML/buildlink3.mk"
.include "../../x11/libXpm/buildlink3.mk"
.include "../../mk/motif.buildlink3.mk"
.include "../../mk/bsd.pkg.mk"