The NetBSD Project

CVS log for pkgsrc/math/arpack-ng/Makefile

[BACK] Up to [cvs.NetBSD.org] / pkgsrc / math / arpack-ng

Request diff between arbitrary revisions


Keyword substitution: kv
Default branch: MAIN


Revision 1.11: download - view: text, markup, annotated - select for diffs
Sun Aug 25 06:18:59 2024 UTC (7 months, 3 weeks ago) by wiz
Branches: MAIN
CVS tags: pkgsrc-2025Q1-base, pkgsrc-2025Q1, pkgsrc-2024Q4-base, pkgsrc-2024Q4, pkgsrc-2024Q3-base, pkgsrc-2024Q3, HEAD
Diff to: previous 1.10: preferred, colored
Changes since revision 1.10: +4 -4 lines
*: replace CMAKE_ARGS with CMAKE_CONFIGURE_ARGS

Revision 1.10: download - view: text, markup, annotated - select for diffs
Mon Jan 22 14:13:44 2024 UTC (14 months, 3 weeks ago) by thor
Branches: MAIN
CVS tags: pkgsrc-2024Q2-base, pkgsrc-2024Q2, pkgsrc-2024Q1-base, pkgsrc-2024Q1
Diff to: previous 1.9: preferred, colored
Changes since revision 1.9: +2 -1 lines
math/arpack-ng: use pkg-config as tool

This fixes the build where there is no pkg-config in the base system
hiding the fact that we did not pull it in explicitly.

Revision 1.9: download - view: text, markup, annotated - select for diffs
Mon Nov 6 10:57:52 2023 UTC (17 months, 1 week ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2023Q4-base, pkgsrc-2023Q4
Diff to: previous 1.8: preferred, colored
Changes since revision 1.8: +2 -2 lines
arpack-ng: updated to 3.9.1

arpack-ng - 3.9.1
* pyarpack: Ensure that the matrix properties (symmetric/hermitian) fit the solver (CG/LDL) with which they are used in the tests
* [BUG FIX] Tests for PARPACK with C/C++ bindings icb_parpack_c and icb_parpack_cpp are now really parallel and split the problem across MPI processes.
* Update arpackmm test suite: enable solving non-symmetric tests with BiCG solver
* README: Add details on Windows installation.
* [BUG FIX] Ensure that LAPACK RNG state is propagated (regression in 3.9.0).
* [BUG FIX] Ensure that separate random seeds are used on different parallel thread in D and S versions of functions (issue from original ARPACK).
* ICB(arpackdef.h): distinct intel llvm compiler (icx with clang-cl) from msvc on windows
* ICB(arpackdef.h): Undef macro I if complex.h from msvc version is loaded, which is an usual name and causes issues on arpackSolver.
* [BUG FIX] Fix install: headers in /path/to/local/include/arpack for ICB samples
* [BUG FIX] Fix install: headers in /path/to/local/include/arpack
* arpackmm: allow for using LA/SA magnitudes.
* Rename icbexmm option into eigen option.
* README: document how to use ICB.
* [BUG FIX] arpackmm: fix restart.
* README: document where to find arpack user's guide.

Revision 1.8: download - view: text, markup, annotated - select for diffs
Wed May 31 21:35:31 2023 UTC (22 months, 2 weeks ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2023Q3-base, pkgsrc-2023Q3, pkgsrc-2023Q2-base, pkgsrc-2023Q2
Diff to: previous 1.7: preferred, colored
Changes since revision 1.7: +12 -18 lines
arpack-ng: updated to 3.9.0

arpack-ng - 3.9.0

[ Vikas Sharma ]
 * Improve README.

[ Fabien Péan ]
 * CI: Enable job `windows_latest_cmake` to run all tests
 * CMake: Fix BLAS and LAPACK static library order needed to consume the library on Windows with static linkage
 * Fix using ARPACK on Windows with MSVC compiler from C++17 onwards

[ Zhentao Wang ]
 * [BUG FIX] parpack.h and parpack.hpp: type of rwork should be real instead of complex.
 * Allow ritz_option {"LR", "SR", "LI", "SI"} for complex eigenvalue problems in ICB.

[ Jose E. Roman ]
 * Avoid using isnan() in tests, since is GNU-specific

[ Tom Payerle ]
 * Change the continuation line format for stat.h, debug.h

[ John Doe ]
 * Avoid calling [c|z]dotc for better portability on macOS

[ Dima Pasechnik ]
 * [BUG FIX] autotools: replace obsolete AC_TRY_COMPILE macros.
 * Support for NAG's nagfor Fortran compiler

[ Franck Houssen ]
 * Create one .cmake file per arpack-ng flavor (32-bits, 64-bits, ILP64).
 * Test autotools pkg-config (*.pc files) with/without LIBSUFFIX/ITF64SUFFIX.
 * Test CMake find_package (*.cmake files) with/without LIBSUFFIX/ITF64SUFFIX.
 * [BUG FIX] autotools: ICB must be checked first (MPI changes compilers).
 * [BUG FIX] BLAS/LAPACK: allow suffixes in case BLAS/LAPACK can not provide ICB.
 * [BUG FIX] Compile C programs with ICB.
 * arpackmm: command line bug fix.
 * arpackmm: restart bug fix.
 * pyarpack: fix compilation warning, test on macos and latest boost-python (1.79).
 * arpackSolver: fix error messages.
 * [BUG FIX] Make sure iseed is always initialized to values allowed by lapack ?larnv.
 * [BUG FIX] According to lapack doc of ?larnv, iseed(4) must be odd.
 * [BUG FIX] Use MPI ICB types (mpi_f08) instead of integer(kind=i_int).
 * parpack: no ILP64 support.

[ Haoyang Liu ]
 * CMake: minimum required version changed to 3.0
 * CMake: add C99 standard checking
 * CI: Support for centos7 added.
 * CI: Add `scripts/travis_centos.sh` for centos builds

[ Robert Schütz ]
 * use CMAKE_INSTALL_FULL_<dir> in arpack.pc

[ Markus Mützel ]
 * CMake: Handle libraries without "lib" prefix.
 * CMake: Don't override BLAS/LAPACK/MPI flags. Directly use results from the Find* modules instead.

[ Juan José García-Ripoll ]
 * Adapt the C/C++ interface to accept also MSVC's non-standard complex types.
 * Propagate dependencies to CMake targets that use arpack-ng:
   - Create CMake-generated targets and configuration files that keep track of
     arpack's dependencies (libraries, directories) and expose them to users.
   - Install those files under ${prefix}/lib/cmake/arpackng* so that arpack can be
     found using 'find_package(arpackng)' from CMake files.
   - Add code to the arpackng-config.cmake to find required dependencies when this
     module is loaded by find_package(arpackng).

Revision 1.7: download - view: text, markup, annotated - select for diffs
Thu Jul 7 13:39:48 2022 UTC (2 years, 9 months ago) by thor
Branches: MAIN
CVS tags: pkgsrc-2023Q1-base, pkgsrc-2023Q1, pkgsrc-2022Q4-base, pkgsrc-2022Q4, pkgsrc-2022Q3-base, pkgsrc-2022Q3
Diff to: previous 1.6: preferred, colored
Changes since revision 1.6: +5 -8 lines
math/arpack-ng: update BLAS support for all choices and add mpi option

Revision 1.6: download - view: text, markup, annotated - select for diffs
Wed Jun 23 18:10:19 2021 UTC (3 years, 9 months ago) by thor
Branches: MAIN
CVS tags: pkgsrc-2022Q2-base, pkgsrc-2022Q2, pkgsrc-2022Q1-base, pkgsrc-2022Q1, pkgsrc-2021Q4-base, pkgsrc-2021Q4, pkgsrc-2021Q3-base, pkgsrc-2021Q3
Diff to: previous 1.5: preferred, colored
Changes since revision 1.5: +10 -2 lines
*** empty log message ***

Revision 1.5: download - view: text, markup, annotated - select for diffs
Tue May 11 10:18:37 2021 UTC (3 years, 11 months ago) by prlw1
Branches: MAIN
CVS tags: pkgsrc-2021Q2-base, pkgsrc-2021Q2
Diff to: previous 1.4: preferred, colored
Changes since revision 1.4: +2 -9 lines
Update arpack-ng to 3.8.0

Fixes build errors of the form

/tmp/pkgsrc/math/arpack-ng/work.x86_64/arpack-ng-3.7.0/SRC/cnaitr.f:666:35:

  383 |             call svout (logfil, 1, rnorm, ndigit,
      |                                   2
......
  666 |             call svout (logfil, 2, rtemp, ndigit,
      |                                   1
Error: Rank mismatch between actual argument at (1) and actual argument at (2) (scalar and rank-1)

seen in arpack-ng-3.7.0nb1

Revision 1.4: download - view: text, markup, annotated - select for diffs
Mon Nov 30 13:23:55 2020 UTC (4 years, 4 months ago) by nia
Branches: MAIN
CVS tags: pkgsrc-2021Q1-base, pkgsrc-2021Q1, pkgsrc-2020Q4-base, pkgsrc-2020Q4
Diff to: previous 1.3: preferred, colored
Changes since revision 1.3: +3 -1 lines
arpack-ng: Hack around build failure with gcc<10.

Revision 1.3: download - view: text, markup, annotated - select for diffs
Thu Nov 19 19:58:27 2020 UTC (4 years, 5 months ago) by mcf
Branches: MAIN
Diff to: previous 1.2: preferred, colored
Changes since revision 1.2: +5 -1 lines
arpack-ng: fix build with gfortran 10

gfortran 10 rejects certain argument mismatches, causing build
errors. This issue is fixed upstream[0], but the commit modifies
40 files, so until the next release use -fallow-argument-mismatch
to downgrade these to warnings, as suggested by the gcc 10 porting
guide[1].

[0] https://github.com/opencollab/arpack-ng/commit/9418632214acf6d387896ab29a8f5bdff2d4e38a
[1] https://gcc.gnu.org/gcc-10/porting_to.html#argument-mismatch

Revision 1.2: download - view: text, markup, annotated - select for diffs
Mon Oct 12 21:52:02 2020 UTC (4 years, 6 months ago) by bacon
Branches: MAIN
Diff to: previous 1.1: preferred, colored
Changes since revision 1.1: +3 -3 lines
math/blas, math/lapack: Install interchangeable BLAS system

Install the new interchangeable BLAS system created by Thomas Orgis,
currently supporting Netlib BLAS/LAPACK, OpenBLAS, cblas, lapacke, and
Apple's Accelerate.framework.  This system allows the user to select any
BLAS implementation without modifying packages or using package options, by
setting PKGSRC_BLAS_TYPES in mk.conf. See mk/blas.buildlink3.mk for details.

This commit should not alter behavior of existing packages as the system
defaults to Netlib BLAS/LAPACK, which until now has been the only supported
implementation.

Details:

Add new mk/blas.buildlink3.mk for inclusion in dependent packages
Install compatible Netlib math/blas and math/lapack packages
Update math/blas and math/lapack MAINTAINER approved by adam@
OpenBLAS, cblas, and lapacke will follow in separate commits
Update direct dependents to use mk/blas.buildlink3.mk
Perform recursive revbump

Revision 1.1: download - view: text, markup, annotated - select for diffs
Fri Feb 28 21:51:40 2020 UTC (5 years, 1 month ago) by plunky
Branches: MAIN
CVS tags: pkgsrc-2020Q3-base, pkgsrc-2020Q3, pkgsrc-2020Q2-base, pkgsrc-2020Q2, pkgsrc-2020Q1-base, pkgsrc-2020Q1
Add arpack-ng 3.7.0

This project started as a joint project between Debian, Octave and
Scilab in order to provide a common and maintained version of arpack,
as no single release has been published by Rice university for the
last few years and many software (Octave, Scilab, R, Matlab...) forked
it and implemented their own modifications.

Diff request

This form allows you to request diffs between any two revisions of a file. You may select a symbolic revision name using the selection box or you may type in a numeric name using the type-in text box.

Log view options

CVSweb <webmaster@jp.NetBSD.org>