[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / math / R

Annotation of pkgsrc/math/R/Makefile, Revision 1.230

1.230   ! wen         1: # $NetBSD: Makefile,v 1.229 2021/12/08 16:05:31 adam Exp $
1.1       frueauf     2:
1.228     jperkin     3: #
                      4: # If updating this package, please try to ensure PLIST.Darwin is kept in sync
                      5: # to avoid unnecessarily breaking macOS users.
                      6: #
1.230   ! wen         7: DISTNAME=      R-4.1.3
1.177     adam        8: CATEGORIES=    math
1.215     markd       9: MASTER_SITES=  ${MASTER_SITE_R_CRAN:=base/R-4/}
1.177     adam       10:
1.205     markd      11: MAINTAINER=    pkgsrc-users@NetBSD.org
1.209     rillig     12: HOMEPAGE=      https://www.R-project.org/
1.177     adam       13: COMMENT=       Statistical language for data analysis and graphics
                     14: LICENSE=       gnu-gpl-v2
1.35      dmcmahil   15:
1.146     jperkin    16: USE_GCC_RUNTIME=       yes
                     17:
1.136     markd      18: BUILD_TARGET=          all info
                     19: INSTALL_TARGET=                install install-info
1.45      markd      20: TEST_TARGET=           check
1.119     markd      21: USE_LANGUAGES=         c c++ fortran
1.75      joerg      22: USE_LIBTOOL=           yes
1.197     jperkin    23: USE_TOOLS+=            aclocal autoconf autoreconf automake gmake gzip:run
                     24: USE_TOOLS+=            makeinfo perl:run pkg-config sed unzip:run
1.156     ryoon      25: TEXINFO_REQD=          5.1
1.136     markd      26: INFO_FILES=            yes
1.12      jlam       27:
1.114     jruoho     28: PTHREAD_AUTO_VARS=     yes
                     29:
1.74      rillig     30: GNU_CONFIGURE=         yes
1.207     rillig     31: GNU_CONFIGURE_ICONV=   no
1.41      markd      32: CONFIGURE_ARGS+=       --enable-R-shlib
1.13      jlam       33: CONFIGURE_ARGS+=       --with-readline
1.25      jlam       34: CONFIGURE_ARGS+=       --with-tcltk
1.37      markd      35: CONFIGURE_ARGS+=       --with-tcl-config=${BUILDLINK_PREFIX.tcl}/lib/tclConfig.sh
                     36: CONFIGURE_ARGS+=       --with-tk-config=${BUILDLINK_PREFIX.tk}/lib/tkConfig.sh
1.25      jlam       37:
1.147     markd      38: .include "../../mk/bsd.prefs.mk"
                     39: .if ${OPSYS} == "NetBSD" || ${OPSYS} == "FreeBSD"
                     40: CONFIGURE_ARGS+=       --enable-long-double=no
                     41: .endif
                     42:
1.148     markd      43: .if ${OPSYS} != "Linux"
                     44: USE_GNU_ICONV=         yes             # latin1 support, iconvlist
                     45: .endif
                     46:
1.177     adam       47: PLIST_VARS+=           x11
                     48:
1.98      dbj        49: # Disable Mac OS specific support used by R.app
1.177     adam       50: .if ${OPSYS} == "Darwin"
1.98      dbj        51: CONFIGURE_ARGS+=       --disable-R-framework
1.177     adam       52: CONFIGURE_ARGS+=       --with-aqua
                     53: CONFIGURE_ARGS+=       --without-x
                     54: .else
                     55: USE_TOOLS+=            xmkmf
                     56: CONFIGURE_ARGS+=       --with-x
                     57: PLIST.x11=             yes
                     58: .endif
1.98      dbj        59:
1.224     thor       60: # Think about making this consistent with Numpy, using a full
                     61: # BLAS/LAPACK by default and only on request accelerate. Just
                     62: # BLAS_ACCEPTED=       ${_BLAS_TYPES} accelerate.framework
                     63: # (here and in buildlink3.mk) and deleting the first conditional
                     64: # branch might work, given that R knows what todo with
                     65: # -framework Accelerate. Someone on Darwin really needs to test.
1.181     minskim    66: .if exists(/System/Library/Frameworks/Accelerate.framework)
                     67: CONFIGURE_ARGS+=       --with-blas="-framework Accelerate"
1.224     thor       68: CONFIGURE_ARGS+=       --with-lapack # contained in the above
1.181     minskim    69: .else
1.224     thor       70: # Could be two distinct libraries. Note that, at least int the past,
                     71: # R folks were not fond of linking external lapack.
1.104     adam       72: CONFIGURE_ARGS+=       --disable-BLAS-shlib
1.224     thor       73: CONFIGURE_ARGS+=       --with-blas=${BLAS_LIBS:Q}
                     74: CONFIGURE_ARGS+=       --with-lapack=${LAPACK_LIBS:Q}
1.181     minskim    75: .endif
1.13      jlam       76:
1.25      jlam       77: # Work around missing MAIN__() definition used in -lF77 by AC_CHECK_LIB.
1.100     markd      78: # and other failures due to not linking to support libs during testing
1.25      jlam       79: CONFIGURE_ENV+=                ac_cv_lib_blas_dgemm=yes
                     80: CONFIGURE_ENV+=                ac_cv_lib_blas_dgemm_=yes
1.100     markd      81: CONFIGURE_ENV+=                r_cv_complete_blas=yes
1.13      jlam       82:
1.97      markd      83: # Broken test for bzlib >= 1.0.5 in R 2.7.0
                     84: CONFIGURE_ENV+=                r_cv_have_bzlib=yes
1.168     joerg      85: # Override zlib 1.2.5 requirement
                     86: CONFIGURE_ENV+=                r_cv_header_zlib_h=yes
1.97      markd      87:
1.104     adam       88: CONFIGURE_ENV+=                GETWD=${TOOLS_PWD_CMD}
1.69      markd      89: CONFIGURE_ENV+=                lt_cv_path_LD=${LD:Q}
1.104     adam       90: CONFIGURE_ENV+=                lt_cv_path_SED=${TOOLS_SED}
                     91: CONFIGURE_ENV+=                ac_cv_path_R_GZIPCMD=${TOOLS_GZIP_CMD}
1.92      rillig     92: CONFIGURE_ENV+=                ac_cv_path_R_UNZIPCMD=${TOOLS_PATH.unzip}
1.107     adam       93: CONFIGURE_ENV+=                r_cv_prog_f77_flag_mieee=no
1.144     markd      94: CONFIGURE_ENV+=                ac_cv_path_PDFLATEX=""
1.69      markd      95:
1.116     alnsn      96: # We don't want "lib64"
                     97: CONFIGURE_ENV+=                LIBnn=lib
                     98:
1.53      markd      99: # Package assumes it can append to files (specifically DESCRIPTION) that have
                    100: # been installed SHAREMODE
                    101: SHAREMODE=             644
                    102:
1.164     jperkin   103: CONFIGURE_ARGS.Darwin+=        --disable-openmp
1.145     jperkin   104:
1.1       frueauf   105: # R_PAPERSIZE can be: A4, Letter, Legal, Executive
                    106: .if defined(PAPERSIZE)
1.12      jlam      107: R_PAPERSIZE?=          ${PAPERSIZE}
1.7       hubertf   108: .else
1.12      jlam      109: R_PAPERSIZE?=          A4
1.6       jlam      110: .endif
1.1       frueauf   111: .if (${R_PAPERSIZE} == "Letterdj")
1.12      jlam      112: R_PAPERSIZE=           Letter
1.1       frueauf   113: .endif
1.76      rillig    114: CONFIGURE_ENV+=                R_PAPERSIZE=${R_PAPERSIZE:Q}
1.6       jlam      115:
1.13      jlam      116: # These macros are used during the build, so strip off the -o,-g flags.
                    117: INSTALL_DATA=          ${INSTALL} ${COPY} -m ${SHAREMODE}
                    118: INSTALL_SCRIPT=                ${INSTALL} ${COPY} -m ${BINMODE}
1.12      jlam      119:
1.144     markd     120: ## to build NEWS.pdf
                    121: #BUILD_DEPENDS+=               tex-latex-bin-[0-9]*:../../print/tex-latex-bin
                    122: #BUILD_DEPENDS+=               tex-metafont-[0-9]*:../../fonts/tex-metafont
                    123: #BUILD_DEPENDS+=               tex-ae-[0-9]*:../../fonts/tex-ae
                    124: #BUILD_DEPENDS+=               tex-ec-[0-9]*:../../fonts/tex-ec
                    125: #BUILD_DEPENDS+=               tex-tools-[0-9]*:../../print/tex-tools
                    126: #BUILD_DEPENDS+=               tex-url-[0-9]*:../../print/tex-url
                    127: #BUILD_DEPENDS+=               tex-oberdiek-[0-9]*:../../print/tex-oberdiek
                    128: #BUILD_DEPENDS+=               tex-amsfonts-[0-9]*:../../fonts/tex-amsfonts
                    129: #BUILD_DEPENDS+=               tex-cm-[0-9]*:../../fonts/tex-cm
                    130: #BUILD_DEPENDS+=               tex-cm-super-[0-9]*:../../fonts/tex-cm-super
                    131: #BUILD_DEPENDS+=               tex-fontname-[0-9]*:../../fonts/tex-fontname
                    132: #BUILD_DEPENDS+=               tex-graphics-[0-9]*:../../print/tex-graphics
                    133: #BUILD_DEPENDS+=               tex-hyperref-[0-9]*:../../print/tex-hyperref
1.212     markd     134: #BUILD_DEPENDS+=               tex-iftex>=1.0d:../../print/tex-iftex
1.144     markd     135: #BUILD_DEPENDS+=               tex-latex-[0-9]*:../../print/tex-latex
                    136: #BUILD_DEPENDS+=               tex-latexconfig-[0-9]*:../../print/tex-latexconfig
                    137: #BUILD_DEPENDS+=               tex-mptopdf-[0-9]*:../../graphics/tex-mptopdf
                    138: #BUILD_DEPENDS+=               tex-pdftex-def-[0-9]*:../../print/tex-pdftex
1.123     dholland  139:
1.152     jperkin   140: SUBST_CLASSES+=                fixwrap
                    141: SUBST_STAGE.fixwrap=   post-build
                    142: SUBST_FILES.fixwrap=   libtool
1.158     jperkin   143: SUBST_SED.fixwrap=     -e "s,${WRAPPER_BINDIR}/libtool,${PKG_LIBTOOL},g"
1.121     markd     144:
1.167     wen       145: BUILDLINK_API_DEPENDS.bzip2+=  bzip2>=1.0.5
1.62      jlam      146:
1.191     jperkin   147: # failed to convert strong functions and variables: Invalid type identifier
                    148: CTF_FILES_SKIP+=       lib/R/library/mgcv/libs/mgcv.so
                    149:
1.198     jperkin   150: # Exposes PKG_CONFIG_LIBDIR buildlink paths in a comment.
                    151: CHECK_WRKREF_SKIP+=    lib/R/etc/Makeconf
                    152:
1.176     rumko     153: pre-configure:
1.220     mef       154:        ${RUN} cd ${WRKSRC} && autoreconf -fvi || echo Ignore the warnings from autoreconf
1.176     rumko     155:
1.162     jperkin   156: # Fix library names.  Relies on build system using -headerpad_max_install_names.
                    157: .if ${OPSYS} == "Darwin"
                    158: .PHONY: fix-darwin-install-name
                    159: post-install: fix-darwin-install-name
                    160: fix-darwin-install-name:
                    161:        ${FIND} ${DESTDIR}${PREFIX} -name "*.so" | while read lib; do   \
                    162:                libname=`basename $${lib}`;                             \
                    163:                libdir=`dirname $${lib} | sed -e 's,${DESTDIR},,'`;     \
1.163     jperkin   164:                install_name_tool -id $${libdir}/$${libname} $${lib};   \
1.162     jperkin   165:        done
                    166: .endif
                    167:
1.62      jlam      168: .include "../../archivers/bzip2/buildlink3.mk"
1.104     adam      169: .include "../../archivers/xz/buildlink3.mk"
1.73      dmcmahil  170: .include "../../converters/libiconv/buildlink3.mk"
1.75      joerg     171: .include "../../devel/gettext-lib/buildlink3.mk"
1.179     wen       172: .include "../../devel/glib2/buildlink3.mk"
1.177     adam      173: .include "../../devel/pango/buildlink3.mk"
1.215     markd     174: .include "../../devel/pcre2/buildlink3.mk"
1.141     ryoon     175: # uses callback interface
1.62      jlam      176: .include "../../devel/readline/buildlink3.mk"
                    177: .include "../../devel/zlib/buildlink3.mk"
1.104     adam      178: .include "../../graphics/cairo/buildlink3.mk"
1.112     dsainty   179: .include "../../mk/jpeg.buildlink3.mk"
1.62      jlam      180: .include "../../graphics/png/buildlink3.mk"
1.97      markd     181: .include "../../graphics/tiff/buildlink3.mk"
1.181     minskim   182: .if !exists(/System/Library/Frameworks/Accelerate.framework)
1.219     bacon     183: .include "../../mk/blas.buildlink3.mk"
1.181     minskim   184: .endif
1.167     wen       185: .include "../../www/curl/buildlink3.mk"
1.177     adam      186: .include "../../x11/tk/buildlink3.mk"
                    187:
                    188: .if ${OPSYS} != "Darwin"
1.87      joerg     189: .include "../../x11/libXt/buildlink3.mk"
1.177     adam      190: .endif
1.62      jlam      191:
1.88      markd     192: INSTALL_TEMPLATES+=    ../../math/R/files/pkg-index.tmpl
                    193: DEINSTALL_TEMPLATES+=  ../../math/R/files/pkg-index.tmpl
                    194: PRINT_PLIST_AWK+=      /^lib\/R\/doc\/html\/packages.html$$/ { next; }
                    195:
1.97      markd     196: .include "../../mk/pthread.buildlink3.mk"
1.1       frueauf   197: .include "../../mk/bsd.pkg.mk"

CVSweb <webmaster@jp.NetBSD.org>