[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / math / R-zoo

File: [cvs.NetBSD.org] / pkgsrc / math / R-zoo / Makefile (download)

Revision 1.16, Sun Jun 6 15:08:56 2021 UTC (2 years, 10 months ago) by mef
Branch: MAIN
CVS Tags: pkgsrc-2022Q1-base, pkgsrc-2022Q1, pkgsrc-2021Q4-base, pkgsrc-2021Q4, pkgsrc-2021Q3-base, pkgsrc-2021Q3, pkgsrc-2021Q2-base, pkgsrc-2021Q2
Changes since 1.15: +11 -2 lines

(math/R-zoo) Updated 1.8.6 to 1.8.9

Changes in Version 1.8-9

  o Added a basic boxplot(x, ...) method for zoo objects that simply calls
    boxplot(coredata(x), ...).

  o Bug fix in [.zoo and [<-.zoo where indexing with matrices did not
    work correctly anymore in R 4.x.y because "matrix" objects now additionally
    inherit from "array" objects. (Reported by Bill Cunliffe.)

  o Improved internal functionality in na.spline.default() in the same way
    na.approx.default() was enhanced in zoo 1.7-14 and 1.7-13. One difference
    is that while na.approx() requires at least two non-NA observations,
    na.spline() just needs one non-NA observation (using a constant to
    interpolate in that case).

  o If the FUN in rollapply() returns a matrix or data.frame with more than
    one row per element/time point, then this is flattened now so that the
    result is again a matrix with one row per element/time point.

  o merge.zoo() now handles the case of all indexes being integer or numeric
    by coercing the integer indexes to numeric (reported by Simone Giannerini).

  o zooreg(x) now allows to create an integer index if start (and end, if any)
    are integer and the implied deltat is not numerically different from an
    integer value.


Changes in Version 1.8-8

  o diff.zoo(x, arithmetic = FALSE) now also works if x contains negative
    data.

  o merge.zoo() now handles the combination of Date and numeric indexes
    explicitly to work around the new behavior of c.Date() in R >= 4.1.0.


Changes in Version 1.8-7

  o Added scale_type() methods for yearmon/yearqtr to facilitate ggplot2
    visualizations of zoo series with yearmon/yearqtr time index (suggested
    by Brian Diggs). This requires at least ggplot2 3.0.0.

  o In merge.zoo() "character" columns are now processed in the same way
    as "logical" columns.

  o Replaced the "fruitohms" example in the "zoo" vignette because the
    corresponding "DAAG" package is not actively maintained on CRAN anymore.
    Instead the "Journals" data from the "AER" package is used.

# $NetBSD: Makefile,v 1.16 2021/06/06 15:08:56 mef Exp $

R_PKGNAME=	zoo
R_PKGVER=	1.8-9
CATEGORIES=	math

MAINTAINER=	pkgsrc-users@NetBSD.org
COMMENT=	S3 infrastructure for regular and irregular time series
LICENSE=	gnu-gpl-v2 OR gnu-gpl-v3

#Packages suggested but not available:
#  'AER', 'coda', 'chron', 'fts', 'ggplot2', 'mondate', 'scales',
#  'stinepack', 'strucchange', 'timeDate', 'timeSeries', 'tis',
#  'tseries', 'xts'
TEST_DEPENDS+=	R-xts-[0-9]*:../../math/R-xts
TEST_DEPENDS+=	R-scales-[0-9]*:../../graphics/R-scales
TEST_DEPENDS+=	R-timeDate-[0-9]*:../../time/R-timeDate
TEST_DEPENDS+=	R-timeSeries-[0-9]*:../../finance/R-timeSeries

USE_LANGUAGES=	c

.include "../../math/R/Makefile.extension"
.include "../../mk/bsd.pkg.mk"