The NetBSD Project

CVS log for pkgsrc/math/R-gtools/Makefile

[BACK] Up to [cvs.NetBSD.org] / pkgsrc / math / R-gtools

Request diff between arbitrary revisions


Default branch: MAIN
Current tag: pkgsrc-2018Q1-base


Revision 1.6 / (download) - annotate - [select for diffs], Sun Dec 18 02:51:34 2016 UTC (7 years, 3 months ago) by wen
Branch: MAIN
CVS Tags: pkgsrc-2018Q2-base, pkgsrc-2018Q2, pkgsrc-2018Q1-base, pkgsrc-2018Q1, pkgsrc-2017Q4-base, pkgsrc-2017Q4, pkgsrc-2017Q3-base, pkgsrc-2017Q3, pkgsrc-2017Q2-base, pkgsrc-2017Q2, pkgsrc-2017Q1-base, pkgsrc-2017Q1, pkgsrc-2016Q4-base, pkgsrc-2016Q4
Changes since 1.5: +2 -2 lines
Diff to previous 1.5 (colored)

Update to 3.5.0

Upstream changes:
gtools 3.5.0 - 2015-04-28
-------------------------

New Functions:

- New roman2int() functon to convert roman numerals to integers
  without the range restriction of utils::as.roman().

- New asc() and chr() functions to convert between ASCII codes and
  characters. (Based on the 'Data Debrief' blog entry for 2011-03-09
  at http://datadebrief.blogspot.com/2011/03/ascii-code-table-in-r.html).

- New unByteCode() and unByteCodeAssign() functions to convert a
  byte-code functon to an interpeted code function.

- New assignEdgewise() function for making assignments into locked
  environments. (Used by unByteCodeAssign().)

Enhacements:

- mixedsort() and mixedorder() now have arguments 'decreasing',
  'na.last', and 'blank.last' arguments to control sort ordering.

- mixedsort() and mixedirdeR() now support Roman numerals via the
  arguments 'numeric.type', and 'roman.case'.  (Request by David
  Winsemius, suggested code changes by Henrik Bengtsson.)

- speed up mixedorder() (and hence mixedsort()) by moving
  suppressWarnings() outside of lapply loops. (Suggestion by Henrik
  Bengtsson.)

- The 'q' argument to quantcut() now accept an integer
  indicating the number of equally spaced quantile groups to
  create. (Suggestion and patch submitted by Ryan C. Thompson.)

Bug fixes:

- Removed stray browser() call in smartbind().

- ddirichlet(x, alpha) was incorrectly returning NA when for any i,
  x[i]=0 and alpha[i]=1.  (Bug report by John Nolan.)

Other changes:

- Correct typographical errors in package description.


gtools 3.4.2 - 2015-04-06
-------------------------

New features:

- New function loadedPackages() to display name, version, and path of
  loaded packages (package namespaces).

- New function: na.replace() to replace missing values within a
  vector with a specified value.`

Bug fixes:

- Modify keywords() to work properly in R 3.4.X and later.


gtools 3.4.1 - 2014-05-27
-------------------------

Bug fixes:

- smartbind() now converts all non-atomic type columns (except factor)
  to type character instead of generating an opaque error message.

Other changes:

- the argument to ASCIIfy() is now named 'x' instead of 'string'.

- minor formatting changes to ASCIIfy() man page.

gtools 3.4.0 - 2014-04-14
-------------------------

New features:

- New ASCIIfy() function to converts character vectors to ASCII
  representation by escaping them as \x00 or \u0000 codes.
  Contributed by Arni Magnusson.


gtools 3.3.1 - 2014-03-01
-------------------------

Bug fixes:

- 'mixedorder' (and hence 'mixedsort') not properly handling
  single-character strings between numbers, so that '1a2' was being
  handled as a single string rather than being properly handled as
  c('1', 'a', '2').



gtools 3.3.0 - 2014-02-11
-------------------------

New features:

- Add the getDependencies() function to return a list of dependencies
  for the specified package(s).  Includes arguments to control whether
  these dependencies should be constructed using information from
  locally installed packages ('installed', default is TRUE), avilable
  CRAN packages ('available', default is TRUE) and whether to include
  base ('base', default=FALSE) and recommended ('recommended', default
  is FALSE) packages.

Bug fixes:

- binsearch() was returning the wrong endpoint & value when the found
  value was at the upper endpoint.

gtools 3.2.1 - 2014-01-13
-------------------------

Bug fixes:

- Resolve circular dependency with gdata


gtools 3.2.0 - 2014-01-11
-------------------------

New features:

- The keywords() function now accepts a function or function name as
  an argument and will return the list of keywords associated with the
  named function.

- New function stars.pval() which will generate p-value significance
  symbols ('***', '**', etc.)

Bug fixes:

- R/mixedsort.R: mixedorder() was failing to correctly handle numbers
  including decimals due to a faulty regular expression.

Other changes:

- capture() and sprint() are now defunct.


gtools 3.1.1 - 2013-11-06
-------------------------

Bug fixes:

- Fix problem with mixedorder/mixedsort when there is zero or one
  elements in the argument vector.


gtools 3.1.0 - 2013-09-22
-------------------------

Major changes:

- The function 'addLast()' (deprecated since gtools 3.0.0) is no
  longer available, and has been marked defunct.

Bug fixes:

- Modified 'mixedorder()' to use Use 'suppressWarnings() instead of
  'options(warn=-1)'.  This will avoid egregious warning messages when
  called from within a nested environment, such as when run from
  within 'knitr'


gtools 3.0.0 - 2013-07-06
-------------------------

Major changes:

- The function 'addLast()' has been deprecated because it directly
  manipulates the global environment, which is expressly prohibited by
  the CRAN policies.

- A new function, 'lastAdd()' has been created to replace 'addLast()'.
  The name has been changed because the two functions require
  different syntax. 'addLast()' was used like this:

    byeWorld <- function() cat("\nGoodbye World!\n")
    addLast(byeWorld)

  The new 'lastAdd()' function is used like this:

    byeWorld <- function() cat("\nGoodbye World!\n")
    .Last <- lastAdd(byeWorld)

Bug fixes:

- Update checkRVersion() to work with R version 3.0.0 and later.

Other changes:

- Remove cross-reference to (obsolete?) moc package

- The function 'assert()' (deprecated since gtools 2.5.0) is no longer
  available and has been marked defunct.

gtools 2.7.1 - 2013-03-17
-------------------------

Bug fixes:

- smartbind() was not properly handling factor columns when the first
  data frame did not include the relevant column.

gtools 2.7.0 - 2012-06-19
-------------------------

New features:

- smartbind() has a new 'sep' argument to allow specification of the
  character(s) used to separate components of constructed column names

- smartbind() has a new 'verbose' argument to provide details on how
  coluumns are being processed

Bug fixes:

- smartbind() has been enhanced to improve handling of factor and
  ordered factor columns.

This form allows you to request diff's between any two revisions of a file. You may select a symbolic revision name using the selection box or you may type in a numeric name using the type-in text box.




CVSweb <webmaster@jp.NetBSD.org>