[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / mail / sylpheed

File: [cvs.NetBSD.org] / pkgsrc / mail / sylpheed / Makefile (download)

Revision 1.90, Wed Mar 1 17:38:38 2006 UTC (18 years, 1 month ago) by drochner
Branch: MAIN
Changes since 1.89: +2 -2 lines

update to 2.2.1
relevant changes:
-The bug that account names with filename-unsafe characters couldn't be
 used was fixed
-The crash bug that occurred if non-ascii newsgroup names appeared while
 getting newsgroup list was fixed
-The performance problem of the quick search while the summary was sorted
 by thread date with descending order was fixed

# $NetBSD: Makefile,v 1.90 2006/03/01 17:38:38 drochner Exp $

DISTNAME=	sylpheed-2.2.1
CATEGORIES=	mail news x11
#MASTER_SITES=	${MASTER_SITE_SOURCEFORGE:=sylpheed-claws/}
MASTER_SITES=	http://sylpheed.good-day.net/sylpheed/v2.2/
EXTRACT_SUFX=	.tar.bz2

MAINTAINER=	chris@NetBSD.org
HOMEPAGE=	http://sylpheed.good-day.net/index.cgi.en
COMMENT=	X based e-mail and netnews client

BUILD_USES_MSGFMT=	yes
DEPENDS+=		metamail>=2.7:../../mail/metamail

CONFLICTS=		sylpheed-claws-[0-9]* sylpheed-gtk2-[0-9]*

USE_PKGLOCALEDIR=	yes
USE_LIBTOOL=            yes
USE_TOOLS+=		gmake pkg-config

GNU_CONFIGURE=		yes
CONFIGURE_ARGS+=	--enable-nls
CONFIGURE_ARGS+=	--enable-ssl
CONFIGURE_ARGS+=	--enable-compface

PKG_SYSCONFSUBDIR=	sylpheed
CONFIGURE_ARGS+=	--sysconfdir=${PKG_SYSCONFDIR:Q}

EGDIR=		${PREFIX}/share/examples/sylpheed
CONF_FILES=	${EGDIR}/mime.types ${PKG_SYSCONFDIR}/mime.types

post-install:
	${INSTALL_DATA_DIR} ${EGDIR}
	${INSTALL_DATA} ${FILESDIR}/mime.types ${EGDIR}

.include "options.mk"
.include "../../converters/libiconv/buildlink3.mk"
.include "../../devel/gettext-lib/buildlink3.mk"
.include "../../security/openssl/buildlink3.mk"
.include "../../devel/glib2/buildlink3.mk"
.include "../../x11/gtk2/buildlink3.mk"

.include "../../mk/bsd.pkg.mk"