[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / mail / sylpheed

File: [cvs.NetBSD.org] / pkgsrc / mail / sylpheed / Makefile (download)

Revision 1.123, Mon Mar 1 10:26:50 2010 UTC (14 years, 1 month ago) by tnn
Branch: MAIN
CVS Tags: pkgsrc-2010Q1-base, pkgsrc-2010Q1
Changes since 1.122: +3 -4 lines

Update to sylpheed-3.0.0.
Many bugfixes. New features include:
* multi-threading was introduced
* add new recipients to address book automatically on sending was added.
* The new filter match type 'is in addressbook' was added.
* Address book is now sortable by each column.
* Address book search feature was added.
* The setup dialog on the first run became user-friendly.
* The new account setup dialog was implemented. Easy Gmail setup.
* SHA1/MD5 fingerprint and validity period of certificate is now displayed
* menu item to request disposition notification was added
* The feature to customize the color label text was added.
* The option to set only mail address of recipients when replying was added.

# $NetBSD: Makefile,v 1.123 2010/03/01 10:26:50 tnn Exp $

DISTNAME=	sylpheed-3.0.0
CATEGORIES=	mail news x11
MASTER_SITES=	http://sylpheed.sraoss.jp/sylpheed/v3.0/
EXTRACT_SUFX=	.tar.bz2

MAINTAINER=	ahoka@NetBSD.org
HOMEPAGE=	http://sylpheed.sraoss.jp/en/
COMMENT=	Gtk based e-mail and netnews client

PKG_DESTDIR_SUPPORT=	user-destdir
CONFLICTS=		sylpheed-claws-[0-9]*

USE_PKGLOCALEDIR=	yes
USE_LIBTOOL=		yes
USE_TOOLS+=		gmake msgfmt pkg-config

GNU_CONFIGURE=		yes
CONFIGURE_ARGS+=	--enable-nls
CONFIGURE_ARGS+=	--enable-ssl
CONFIGURE_ARGS+=	--enable-compface

PKG_SYSCONFSUBDIR=	sylpheed
CONFIGURE_ARGS+=	--sysconfdir=${PKG_SYSCONFDIR:Q}

EGDIR=		${PREFIX}/share/examples/sylpheed
CONF_FILES=	${EGDIR}/mime.types ${PKG_SYSCONFDIR}/mime.types

post-install:
	${INSTALL_DATA_DIR} ${DESTDIR}${EGDIR}
	${INSTALL_DATA} ${FILESDIR}/mime.types ${DESTDIR}${EGDIR}

.include "options.mk"
.include "../../converters/libiconv/buildlink3.mk"
.include "../../devel/gettext-lib/buildlink3.mk"
.include "../../security/openssl/buildlink3.mk"
.include "../../devel/glib2/buildlink3.mk"
.include "../../x11/gtk2/buildlink3.mk"
.include "../../sysutils/desktop-file-utils/desktopdb.mk"

.include "../../mk/bsd.pkg.mk"