[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / mail / sylpheed-claws

File: [cvs.NetBSD.org] / pkgsrc / mail / sylpheed-claws / Attic / Makefile (download)

Revision 1.35, Sun Jul 18 09:56:47 2004 UTC (19 years, 9 months ago) by recht
Branch: MAIN
CVS Tags: pkgsrc-2004Q3-base, pkgsrc-2004Q3
Changes since 1.34: +3 -3 lines

update to sylpheed-claws 0.9.12

This release of Sylpheed-Claws is based on version 0.9.12cvs1 of the
main Sylpheed branch.

Notes for this release:
~~~~~~~~~~~~~~~~~~~~~~~

* Previous users of the included plugins will need to reload them on
starting this version. The directory where they are stored has
changed.
They are now in $PREFIX/lib/sylpheed-claws/plugins
(previously: $PREFIX/lib/sylpheed/plugins)

New in this release:
~~~~~~~~~~~~~~~~~~~~

* A session timeout for POP3/SMTP has been implemented,
(synchronised from main Sylpheed)

* A paperclip icon is no longer displayed in the Status column for
mail that does not contain a real attachment (like HTML mail)

* the SSL certificate check has been re-enabled

* tools/nautilus2sylpheed.sh
the whitespace limitation in file names has been
fixed

* updated translations: French, German, Slovak, and Spanish.

* Bug fixes, including the following:
o bug 393 'Bad inerpretation of "Pop Before SMTP"'
o bug 396 'Zombie process when spamassassin is called'
o bug 503 'fix compilation with older OpenSSL'
o bug 511 'Folder-Renaming not reflected immediately'
o detect library providing 'encrypt' function

For further details of the numbered bugs listed above consult
http://www.thewildbeast.co.uk/sylpheed-claws/bugzilla/index.cgi

* and other code reorganisation, cleanups, and more.

# $NetBSD: Makefile,v 1.35 2004/07/18 09:56:47 recht Exp $
#

.include "Makefile.common"

#PKGNAME=	sylpheed-claws-${SYLPHEED_VERSION}

MAINTAINER=	chris@NetBSD.org
COMMENT=	X based e-mail and netnews client

CONFLICTS=		sylpheed-[0-9]* sylpheed-gtk2-[0-9]*

BUILD_USES_MSGFMT=	YES
USE_PKGINSTALL=		YES
PKGCONFIG_OVERRIDE+=	sylpheed-claws.pc.in

CONFIGURE_ARGS+=        --enable-aspell
CONFIGURE_ARGS+=	--enable-nls
CONFIGURE_ARGS+=	--enable-openssl
CONFIGURE_ARGS+=	--enable-gpgme
CONFIGURE_ARGS+=	--enable-compface
CONFIGURE_ARGS+=	--disable-trayicon-plugin
CONFIGURE_ARGS+=	--disable-image-viewer-plugin
CONFIGURE_ARGS+=	--disable-clamav-plugin
CONFIGURE_ARGS+=	--disable-dillo-viewer-plugin
CONFIGURE_ARGS+=	--disable-spamassassin-plugin
CONFIGURE_ARGS+=	--disable-mathml-viewer-plugin

PKG_SYSCONFSUBDIR=	sylpheed
CONFIGURE_ARGS+=	--sysconfdir=${PKG_SYSCONFDIR}

.include "../../mk/bsd.prefs.mk"
BUILD_DEFS+=		USE_INET6 USE_OPENLDAP

.if defined(USE_INET6) && !empty(USE_INET6:M[Yy][Ee][Ss])
CONFIGURE_ARGS+=	--enable-ipv6
.else
CONFIGURE_ARGS+=	--disable-ipv6
.endif

FACES_IS_INSTALLED!=	${PKG_INFO} -e faces || ${ECHO}
.if empty(FACES_IS_INSTALLED)
.  include "../../graphics/compface/buildlink3.mk"
.else
.  include "../../mail/faces/buildlink3.mk"
.endif

.if defined(USE_OPENLDAP) && ${USE_OPENLDAP} == YES
CONFIGURE_ARGS+=	--enable-ldap
.include "../../databases/openldap/buildlink3.mk"
.endif

EGDIR=		${PREFIX}/share/examples/sylpheed
CONF_FILES=	${EGDIR}/mime.types ${PKG_SYSCONFDIR}/mime.types

post-install:
	${INSTALL_DATA_DIR} ${EGDIR}
	${INSTALL_DATA} ${FILESDIR}/mime.types ${EGDIR}
	${INSTALL_DATA} ${WRKSRC}/sylpheed*.png ${PREFIX}/share/sylpheed-claws

.include "../../converters/libiconv/buildlink3.mk"
.include "../../security/gpgme03/buildlink3.mk"
.include "../../security/openssl/buildlink3.mk"
.include "../../textproc/aspell/buildlink3.mk"
.include "../../x11/gtk/buildlink3.mk"

.include "../../mk/bsd.pkg.mk"