[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / mail / sendymail

File: [cvs.NetBSD.org] / pkgsrc / mail / sendymail / Makefile (download)

Revision 1.4, Mon Oct 8 12:19:31 2012 UTC (11 years, 1 month ago) by asau
Branch: MAIN
Changes since 1.3: +1 -3 lines

Drop PKG_DESTDIR_SUPPORT setting, "user-destdir" is default these days.

# $NetBSD: Makefile,v 1.4 2012/10/08 12:19:31 asau Exp $
#

DISTNAME=		sendymail-0.5.8
PKGREVISION=		1
CATEGORIES=		mail
MASTER_SITES=		${MASTER_SITE_SOURCEFORGE:=sendymail/}

MAINTAINER=		pkgsrc-users@NetBSD.org
HOMEPAGE=		http://sendymail.sourceforge.net/
COMMENT=		Send emails through Yahoo using your favorite email client

DEPENDS+=		p5-Crypt-SSLeay-[0-9]*:../../security/p5-Crypt-SSLeay
DEPENDS+=		p5-Digest-MD5-[0-9]*:../../security/p5-Digest-MD5
DEPENDS+=		p5-Getopt-Long-[0-9]*:../../devel/p5-Getopt-Long
DEPENDS+=		p5-libwww-[0-9]*:../../www/p5-libwww
DEPENDS+=		p5-MailTools-[0-9]*:../../mail/p5-MailTools
DEPENDS+=		p5-MIME-tools-[0-9]*:../../mail/p5-MIME-tools

USE_TOOLS+=		perl:run
REPLACE_PERL=		sendymail.pl

NO_BUILD=		yes

EGDIR=			${PREFIX}/share/examples/sendymail
DOCDIR=			${PREFIX}/share/doc/sendymail

SUBST_CLASSES+=		sa2
SUBST_STAGE.sa2=	pre-configure
SUBST_FILES.sa2=	ChangeLog INSTALL
SUBST_SED.sa2=		-e s!sendymail.pl!sendymail!g

INSTALLATION_DIRS=	bin

do-install:
	${INSTALL_SCRIPT} ${WRKSRC}/sendymail.pl \
		${DESTDIR}${PREFIX}/bin/sendymail
	${INSTALL_DATA_DIR} ${DESTDIR}${DOCDIR}
	${INSTALL_DATA_DIR} ${DESTDIR}${EGDIR}
.for i in BUGS COPYING ChangeLog INSTALL README TODO
		${INSTALL_DATA} ${WRKSRC}/${i} ${DESTDIR}${DOCDIR}
.endfor
	${INSTALL_DATA} ${WRKSRC}/sendymailrc.sample ${DESTDIR}${EGDIR}

.include "../../mk/bsd.pkg.mk"