The NetBSD Project

CVS log for pkgsrc/mail/qpopper/Makefile

[BACK] Up to [cvs.NetBSD.org] / pkgsrc / mail / qpopper

Request diff between arbitrary revisions


Default branch: MAIN


Revision 1.71 / (download) - annotate - [select for diffs], Sat Jan 18 21:49:53 2020 UTC (3 years ago) by jperkin
Branch: MAIN
CVS Tags: pkgsrc-2022Q4-base, pkgsrc-2022Q4, pkgsrc-2022Q3-base, pkgsrc-2022Q3, pkgsrc-2022Q2-base, pkgsrc-2022Q2, pkgsrc-2022Q1-base, pkgsrc-2022Q1, pkgsrc-2021Q4-base, pkgsrc-2021Q4, pkgsrc-2021Q3-base, pkgsrc-2021Q3, pkgsrc-2021Q2-base, pkgsrc-2021Q2, pkgsrc-2021Q1-base, pkgsrc-2021Q1, pkgsrc-2020Q4-base, pkgsrc-2020Q4, pkgsrc-2020Q3-base, pkgsrc-2020Q3, pkgsrc-2020Q2-base, pkgsrc-2020Q2, pkgsrc-2020Q1-base, pkgsrc-2020Q1, HEAD
Changes since 1.70: +2 -2 lines
Diff to previous 1.70 (colored)

*: Recursive revision bump for openssl 1.1.1.

Revision 1.70 / (download) - annotate - [select for diffs], Thu May 23 19:23:07 2019 UTC (3 years, 8 months ago) by rillig
Branch: MAIN
CVS Tags: pkgsrc-2019Q4-base, pkgsrc-2019Q4, pkgsrc-2019Q3-base, pkgsrc-2019Q3, pkgsrc-2019Q2-base, pkgsrc-2019Q2
Changes since 1.69: +3 -3 lines
Diff to previous 1.69 (colored)

all: replace SUBST_SED with the simpler SUBST_VARS

pkglint -Wall -r --only "substitution command" -F

With manual review and indentation fixes since pkglint doesn't get that
part correct in every case.

Revision 1.69 / (download) - annotate - [select for diffs], Sat Mar 26 23:52:37 2016 UTC (6 years, 10 months ago) by joerg
Branch: MAIN
CVS Tags: pkgsrc-2019Q1-base, pkgsrc-2019Q1, pkgsrc-2018Q4-base, pkgsrc-2018Q4, pkgsrc-2018Q3-base, pkgsrc-2018Q3, pkgsrc-2018Q2-base, pkgsrc-2018Q2, pkgsrc-2018Q1-base, pkgsrc-2018Q1, pkgsrc-2017Q4-base, pkgsrc-2017Q4, pkgsrc-2017Q3-base, pkgsrc-2017Q3, pkgsrc-2017Q2-base, pkgsrc-2017Q2, pkgsrc-2017Q1-base, pkgsrc-2017Q1, pkgsrc-2016Q4-base, pkgsrc-2016Q4, pkgsrc-2016Q3-base, pkgsrc-2016Q3, pkgsrc-2016Q2-base, pkgsrc-2016Q2, pkgsrc-2016Q1-base, pkgsrc-2016Q1
Changes since 1.68: +2 -2 lines
Diff to previous 1.68 (colored)

Drop support for SSLv2. Bump revision.

Revision 1.68 / (download) - annotate - [select for diffs], Sat Mar 5 11:28:50 2016 UTC (6 years, 10 months ago) by jperkin
Branch: MAIN
Changes since 1.67: +2 -2 lines
Diff to previous 1.67 (colored)

Bump PKGREVISION for security/openssl ABI bump.

Revision 1.67 / (download) - annotate - [select for diffs], Wed Feb 12 23:18:09 2014 UTC (8 years, 11 months ago) by tron
Branch: MAIN
CVS Tags: pkgsrc-2015Q4-base, pkgsrc-2015Q4, pkgsrc-2015Q3-base, pkgsrc-2015Q3, pkgsrc-2015Q2-base, pkgsrc-2015Q2, pkgsrc-2015Q1-base, pkgsrc-2015Q1, pkgsrc-2014Q4-base, pkgsrc-2014Q4, pkgsrc-2014Q3-base, pkgsrc-2014Q3, pkgsrc-2014Q2-base, pkgsrc-2014Q2, pkgsrc-2014Q1-base, pkgsrc-2014Q1
Changes since 1.66: +2 -2 lines
Diff to previous 1.66 (colored)

Recursive PKGREVISION bump for OpenSSL API version bump.

Revision 1.66 / (download) - annotate - [select for diffs], Fri Jul 12 10:44:57 2013 UTC (9 years, 6 months ago) by jperkin
Branch: MAIN
CVS Tags: pkgsrc-2013Q4-base, pkgsrc-2013Q4, pkgsrc-2013Q3-base, pkgsrc-2013Q3
Changes since 1.65: +2 -2 lines
Diff to previous 1.65 (colored)

Bump PKGREVISION of all packages which create users, to pick up change of
sysutils/user_* packages.

Revision 1.65 / (download) - annotate - [select for diffs], Wed Feb 6 23:22:48 2013 UTC (9 years, 11 months ago) by jperkin
Branch: MAIN
CVS Tags: pkgsrc-2013Q2-base, pkgsrc-2013Q2, pkgsrc-2013Q1-base, pkgsrc-2013Q1
Changes since 1.64: +2 -1 lines
Diff to previous 1.64 (colored)

PKGREVISION bumps for the security/openssl 1.0.1d update.

Revision 1.64 / (download) - annotate - [select for diffs], Mon Oct 8 12:19:29 2012 UTC (10 years, 3 months ago) by asau
Branch: MAIN
CVS Tags: pkgsrc-2012Q4-base, pkgsrc-2012Q4
Changes since 1.63: +1 -3 lines
Diff to previous 1.63 (colored)

Drop PKG_DESTDIR_SUPPORT setting, "user-destdir" is default these days.

Revision 1.63 / (download) - annotate - [select for diffs], Thu Mar 22 14:13:28 2012 UTC (10 years, 10 months ago) by taca
Branch: MAIN
CVS Tags: pkgsrc-2012Q3-base, pkgsrc-2012Q3, pkgsrc-2012Q2-base, pkgsrc-2012Q2, pkgsrc-2012Q1-base, pkgsrc-2012Q1
Changes since 1.62: +10 -6 lines
Diff to previous 1.62 (colored)

Update qpopper to 4.1.0.

4.1

* IPv6 support
* Significantly improved performance
* Cygwin compatibility (for use under Windows)
* Ability to execute arbitrary programs when users log in
* And lots more

Revision 1.62 / (download) - annotate - [select for diffs], Sun Dec 27 14:17:37 2009 UTC (13 years, 1 month ago) by obache
Branch: MAIN
CVS Tags: pkgsrc-2011Q4-base, pkgsrc-2011Q4, pkgsrc-2011Q3-base, pkgsrc-2011Q3, pkgsrc-2011Q2-base, pkgsrc-2011Q2, pkgsrc-2011Q1-base, pkgsrc-2011Q1, pkgsrc-2010Q4-base, pkgsrc-2010Q4, pkgsrc-2010Q3-base, pkgsrc-2010Q3, pkgsrc-2010Q2-base, pkgsrc-2010Q2, pkgsrc-2010Q1-base, pkgsrc-2010Q1, pkgsrc-2009Q4-base, pkgsrc-2009Q4
Changes since 1.61: +17 -14 lines
Diff to previous 1.61 (colored)

some improvement and fixes for qpopper and poppassd.
qpopper:
* add user-destdir support
* add ${QPOPPER_USER}:${QPOPPER_GROUP} to PKG_USERS, fixes PR#28807.
* honor VARBASE.
common:
* update ipv6 patch to appropriate one for base version.
* some pkglint cleanup.

Bump PKGREVISION.

Revision 1.61 / (download) - annotate - [select for diffs], Fri Jan 18 05:08:30 2008 UTC (15 years ago) by tnn
Branch: MAIN
CVS Tags: pkgsrc-2009Q3-base, pkgsrc-2009Q3, pkgsrc-2009Q2-base, pkgsrc-2009Q2, pkgsrc-2009Q1-base, pkgsrc-2009Q1, pkgsrc-2008Q4-base, pkgsrc-2008Q4, pkgsrc-2008Q3-base, pkgsrc-2008Q3, pkgsrc-2008Q2-base, pkgsrc-2008Q2, pkgsrc-2008Q1-base, pkgsrc-2008Q1, cwrapper, cube-native-xorg-base, cube-native-xorg
Changes since 1.60: +2 -1 lines
Diff to previous 1.60 (colored)

Per the process outlined in revbump(1), perform a recursive revbump
on packages that are affected by the switch from the openssl 0.9.7
branch to the 0.9.8 branch. ok jlam@

Revision 1.60 / (download) - annotate - [select for diffs], Mon Sep 10 06:02:11 2007 UTC (15 years, 4 months ago) by hira
Branch: MAIN
CVS Tags: pkgsrc-2007Q4-base, pkgsrc-2007Q4, pkgsrc-2007Q3-base, pkgsrc-2007Q3
Changes since 1.59: +2 -2 lines
Diff to previous 1.59 (colored)

Fix typo (exmaples -> examples).

Revision 1.59 / (download) - annotate - [select for diffs], Wed Jul 4 20:54:46 2007 UTC (15 years, 7 months ago) by jlam
Branch: MAIN
Changes since 1.58: +3 -2 lines
Diff to previous 1.58 (colored)

Make it easier to build and install packages "unprivileged", where
the owner of all installed files is a non-root user.  This change
affects most packages that require special users or groups by making
them use the specified unprivileged user and group instead.

(1) Add two new variables PKG_GROUPS_VARS and PKG_USERS_VARS to
    unprivileged.mk.  These two variables are lists of other bmake
    variables that define package-specific users and groups.  Packages
    that have user-settable variables for users and groups, e.g. apache
    and APACHE_{USER,GROUP}, courier-mta and COURIER_{USER,GROUP},
    etc., should list these variables in PKG_USERS_VARS and PKG_GROUPS_VARS
    so that unprivileged.mk can know to set them to ${UNPRIVILEGED_USER}
    and ${UNPRIVILEGED_GROUP}.

(2) Modify packages to use PKG_GROUPS_VARS and PKG_USERS_VARS.

Revision 1.58 / (download) - annotate - [select for diffs], Sat Mar 24 19:21:27 2007 UTC (15 years, 10 months ago) by joerg
Branch: MAIN
CVS Tags: pkgsrc-2007Q2-base, pkgsrc-2007Q2, pkgsrc-2007Q1-base, pkgsrc-2007Q1
Changes since 1.57: +3 -1 lines
Diff to previous 1.57 (colored)

Prepare for switching to NO_MTREE=yes.

Revision 1.57 / (download) - annotate - [select for diffs], Mon Oct 23 08:14:02 2006 UTC (16 years, 3 months ago) by rillig
Branch: MAIN
CVS Tags: pkgsrc-2006Q4-base, pkgsrc-2006Q4
Changes since 1.56: +13 -6 lines
Diff to previous 1.56 (colored)

Fixed pkglint warnings and made the package work for unprivileged users.

Revision 1.56 / (download) - annotate - [select for diffs], Fri May 5 02:51:35 2006 UTC (16 years, 9 months ago) by taca
Branch: MAIN
CVS Tags: pkgsrc-2006Q3-base, pkgsrc-2006Q3, pkgsrc-2006Q2-base, pkgsrc-2006Q2
Changes since 1.55: +1 -2 lines
Diff to previous 1.55 (colored)

Update qpopper package to 4.0.9.

Changes from 4.0.8 to 4.0.9:
-----------------------------
 1.  Fix crash if too many MDEF commands entered.

Revision 1.55 / (download) - annotate - [select for diffs], Tue May 2 08:39:37 2006 UTC (16 years, 9 months ago) by joerg
Branch: MAIN
Changes since 1.54: +2 -1 lines
Diff to previous 1.54 (colored)

Don't run qpopauth -init -safe during installation, it destroys the
symmetry between installation from source and from binary package.
Annoate MESSAGE accordingly, so that those using apop can do it
themselves.  Bump revision

Revision 1.54 / (download) - annotate - [select for diffs], Thu Dec 29 06:21:53 2005 UTC (17 years, 1 month ago) by jlam
Branch: MAIN
CVS Tags: pkgsrc-2006Q1-base, pkgsrc-2006Q1
Changes since 1.53: +1 -2 lines
Diff to previous 1.53 (colored)

Remove USE_PKGINSTALL from pkgsrc now that mk/install/pkginstall.mk
automatically detects whether we want the pkginstall machinery to be
used by the package Makefile.

Revision 1.53 / (download) - annotate - [select for diffs], Mon Dec 5 23:55:11 2005 UTC (17 years, 2 months ago) by rillig
Branch: MAIN
CVS Tags: pkgsrc-2005Q4-base, pkgsrc-2005Q4
Changes since 1.52: +4 -4 lines
Diff to previous 1.52 (colored)

Ran "pkglint --autofix", which corrected some of the quoting issues in
CONFIGURE_ARGS.

Revision 1.52 / (download) - annotate - [select for diffs], Mon Dec 5 14:13:05 2005 UTC (17 years, 2 months ago) by taca
Branch: MAIN
Changes since 1.51: +2 -2 lines
Diff to previous 1.51 (colored)

Quiet pkglint; changing make macro in double quotation into :Q modifier.

Revision 1.51 / (download) - annotate - [select for diffs], Mon Jun 13 16:53:47 2005 UTC (17 years, 7 months ago) by taca
Branch: MAIN
CVS Tags: pkgsrc-2005Q3-base, pkgsrc-2005Q3, pkgsrc-2005Q2-base, pkgsrc-2005Q2
Changes since 1.50: +20 -2 lines
Diff to previous 1.50 (colored)

Move qpopper specific definition from Makefile.common to Makefile
to avoid accidently sharing options.mk between poppassd and qpopper.

No functional change to qpopper pkgsrc itself.

Revision 1.47.2.1 / (download) - annotate - [select for diffs], Sun Jun 5 18:35:25 2005 UTC (17 years, 8 months ago) by salo
Branch: pkgsrc-2005Q1
Changes since 1.47: +3 -8 lines
Diff to previous 1.47 (colored) next main 1.48 (colored)

Pullup ticket 539 - requested by Adrian Portelli
security update for qpopper

Revisions pulled up:
- pkgsrc/mail/qpopper/Makefile		1.49-1.50
- pkgsrc/mail/qpopper/Makefile.common	1.14-1.15
- pkgsrc/mail/qpopper/PLIST		1.4
- pkgsrc/mail/qpopper/distinfo		1.12
- pkgsrc/mail/qpopper/options.mk	patched by hand (parts of 1.5-1.6)
- pkgsrc/mail/qpopper/patches/patch-am	1.4
- pkgsrc/mail/qpopper/patches/patch-ao	removed
- pkgsrc/mail/qpopper/patches/patch-ap	1.3

   Module Name:		pkgsrc
   Committed By:	taca
   Date:		Sat May 28 02:55:43 UTC 2005

   Modified Files:
   	pkgsrc/mail/qpopper: Makefile Makefile.common PLIST

   Log Message:
   - Sort PLIST.
   - Share MASTER_SITES and HOMEPAGE with poppassd package with introducing
     QPOPPER_MASTER_SITES and QPOPPER_HOMEPAGE in Makefile.common.

   No functional change.
---
   Module Name:		pkgsrc
   Committed By:	adrianp
   Date:		Wed Jun  1 20:55:16 UTC 2005

   Modified Files:
   	pkgsrc/mail/qpopper: Makefile Makefile.common distinfo options.mk
   	pkgsrc/mail/qpopper/patches: patch-am patch-ap
   Removed Files:
   	pkgsrc/mail/qpopper/patches: patch-ao

   Log Message:
   - Update qpopper to 4.0.8
   - Thanks to taca@ and gavan@ for feedback and patch review
   - This also enables experimental PAM support (on platforms that support it)
   - Security fixes included
   - From the ChangeLog:
   > Changes from 4.0.7 to 4.0.8:
   > ---------------------------
   >  1.  Fix compilation error on HPUX.
   >  2.  Fix some compilation warnings.
   >  3.  Update man page with '-x' option.
   >  4.  Fix problems with 'make install'
   >
   >
   > Changes from 4.0.6 to 4.0.7:
   > ---------------------------
   >  1.  Fix '-V' for standalone.
   >  2.  Include 'man' directory in tarball.
   >
   >
   > Changes from 4.0.5 to 4.0.6:
   > ----------------------------
   >  1.  Minor fixes for true64.
   >  2.  Patch from Uli Zappe to fix SCRAM compilation bugs.
   >  3.  Minor fixes for true64.
   >  4.  poppassd now runs smbpasswd as user, not root, to avoid exploit
   >  5.  Remove -traditional-cpp from the compiler options for Darwin
   >      builds (otherwise build fails)
   >  6.  Open stdout and stderr as O_WRONLY instead of O_RDONLY so that
   >      should anything actually be written to them it will show up
   >  7.  When configured as --with-pam and required,
   >      include <pam/pam_appl.h> instead of <security/pam_appl.h>
   >      (otherwise build fails)
   >  8.  strdup the pw.pw_name field from getpwnam so that it's still
   >      valid by the time genpath is called; also added corresponding
   >      free (without this fix when the bug manifests, clients are
   >      erroneously told there are 0 messages in the mail drop
   >      regardless of the actual number)
   >  9.  Add a pam bug workaround at the beginning of main to do a
   >      pam_start and pam_end immediately when the program starts up
   >      in order to avoid bogus authentication failed messages from
   >      pam_authenticate later (only when configured as --with-pam)
   >      [ Thanks to Kyle McKay for changes 5-9 ]
   > 10.  Fixed error in configure script for Mac OS / Darwin.
   > 11.  Support chained certs for OpenSSL [from Daniel Senie].
   > 12.  Fixes to compile better on Linux [from Daniel Senie].
   > 13.  X-UIDL header no longer written when Update_status_hdrs is false
   >      [thanks to Helge Oldach]
   > 14.  Now calling SSL_shutdown() again if it fails the first time.
   > 15.  Now logging TLS errors when compiled with debugging and debug is
   >      enabled (instead of either) [thanks to Maks N. Polunin].
   > 16.  Config file now always closed (not just on error).
   > 17.  When using pam, Kerberos tickets are now destroyed.
   >      Otherwise dead tickets accumulate in cache directory which runs
   >      out of space quickly on busy server.  Problem noted by Rodney
   >      McDuff ITS UQ.   (Directory permissions on ticket cache dir need
   >      to be 1777).
   > 18.  Always log "Servicing request" (instead of just when debugging is
   >      on).   This allows start of pop sessions to be logged always which
   >      is useful for diagnosis of problems.
   > 19.  Worked around problem on some systems causing SIGALRM to be masked,
   >      leaving hung pop processes which should have timed out waiting
   >      for a command from the client.
   >      [ Thanks to David Shrimpton for changes 16-19 ]
   > 20.  Now defaulting to "EXPIRE NEVER" instead of "EXPIRE 0".
   > 21.  Fix core dump on 64-bit Solaris 2.8 [thanks to Kenny Nguyen]
   > 22.  Log facility set on command line now applies to daemon as well.
   >      [Thanks to Helge Oldach]
   > 23.  '-y' to set log facility on command line now works again.
   > 24.  Allow '-V' as synonym for '-v' (to see version).
   > 25.  Process user and spool config files as user, not as root (fix
   >      security hole reported by Jens Steube)
   > 26.  Added "xtnd_xmit" as a boolean option to permit/deny XTND XMIT
   >      and 'x' as a command-line option to disable it.  You should
   >      disable it unless you really need it, and even then it is better
   >      to move to SMTP AUTH.
   > 27.  popauth now opens trace file as user, not root (fix security
   >      hole reported by Jens Steube); also umask now set.
   > 28.  Fix race crash on FreeBSD (thanks to Martin Haller).
   > 29.  Resolve some compiler warnings.
   > 30.  Fix check for libcrypt on FreeBSD.
   > 31.  Added sample pam configuration file (also installed by 'make
   >      install')
   > 32.  Use generic error msg and sleep in more auth failure cases.
   > 33.  Added code to use mkstemp() instead of our perfectly safe usage
   >      of tempnam() because some compilers issue overly broad warnings
   >      implying that all uses of tempnam() are unsafe.  To bypass,
   >      use '--enable-tempnam' with ./configure.
---
   Module Name:		pkgsrc
   Committed By:	adrianp
   Date:		Wed Jun  1 21:09:02 UTC 2005

   Modified Files:
   	pkgsrc/mail/qpopper: options.mk

   Log Message:
   - Add a note for PAM

Revision 1.50 / (download) - annotate - [select for diffs], Wed Jun 1 20:55:16 2005 UTC (17 years, 8 months ago) by adrianp
Branch: MAIN
Changes since 1.49: +1 -6 lines
Diff to previous 1.49 (colored)

- Update qpopper to 4.0.8
- Thanks to taca@ and gavan@ for feedback and patch review
- This also enables experimental PAM support (on platforms that support it)
- Security fixes included
- From the ChangeLog:
> Changes from 4.0.7 to 4.0.8:
> ---------------------------
>  1.  Fix compilation error on HPUX.
>  2.  Fix some compilation warnings.
>  3.  Update man page with '-x' option.
>  4.  Fix problems with 'make install'
>
>
> Changes from 4.0.6 to 4.0.7:
> ---------------------------
>  1.  Fix '-V' for standalone.
>  2.  Include 'man' directory in tarball.
>
>
> Changes from 4.0.5 to 4.0.6:
> ----------------------------
>  1.  Minor fixes for true64.
>  2.  Patch from Uli Zappe to fix SCRAM compilation bugs.
>  3.  Minor fixes for true64.
>  4.  poppassd now runs smbpasswd as user, not root, to avoid exploit
>  5.  Remove -traditional-cpp from the compiler options for Darwin
>      builds (otherwise build fails)
>  6.  Open stdout and stderr as O_WRONLY instead of O_RDONLY so that
>      should anything actually be written to them it will show up
>  7.  When configured as --with-pam and required,
>      include <pam/pam_appl.h> instead of <security/pam_appl.h>
>      (otherwise build fails)
>  8.  strdup the pw.pw_name field from getpwnam so that it's still
>      valid by the time genpath is called; also added corresponding
>      free (without this fix when the bug manifests, clients are
>      erroneously told there are 0 messages in the mail drop
>      regardless of the actual number)
>  9.  Add a pam bug workaround at the beginning of main to do a
>      pam_start and pam_end immediately when the program starts up
>      in order to avoid bogus authentication failed messages from
>      pam_authenticate later (only when configured as --with-pam)
>      [ Thanks to Kyle McKay for changes 5-9 ]
> 10.  Fixed error in configure script for Mac OS / Darwin.
> 11.  Support chained certs for OpenSSL [from Daniel Senie].
> 12.  Fixes to compile better on Linux [from Daniel Senie].
> 13.  X-UIDL header no longer written when Update_status_hdrs is false
>      [thanks to Helge Oldach]
> 14.  Now calling SSL_shutdown() again if it fails the first time.
> 15.  Now logging TLS errors when compiled with debugging and debug is
>      enabled (instead of either) [thanks to Maks N. Polunin].
> 16.  Config file now always closed (not just on error).
> 17.  When using pam, Kerberos tickets are now destroyed.
>      Otherwise dead tickets accumulate in cache directory which runs
>      out of space quickly on busy server.  Problem noted by Rodney
>      McDuff ITS UQ.   (Directory permissions on ticket cache dir need
>      to be 1777).
> 18.  Always log "Servicing request" (instead of just when debugging is
>      on).   This allows start of pop sessions to be logged always which
>      is useful for diagnosis of problems.
> 19.  Worked around problem on some systems causing SIGALRM to be masked,
>      leaving hung pop processes which should have timed out waiting
>      for a command from the client.
>      [ Thanks to David Shrimpton for changes 16-19 ]
> 20.  Now defaulting to "EXPIRE NEVER" instead of "EXPIRE 0".
> 21.  Fix core dump on 64-bit Solaris 2.8 [thanks to Kenny Nguyen]
> 22.  Log facility set on command line now applies to daemon as well.
>      [Thanks to Helge Oldach]
> 23.  '-y' to set log facility on command line now works again.
> 24.  Allow '-V' as synonym for '-v' (to see version).
> 25.  Process user and spool config files as user, not as root (fix
>      security hole reported by Jens Steube)
> 26.  Added "xtnd_xmit" as a boolean option to permit/deny XTND XMIT
>      and 'x' as a command-line option to disable it.  You should
>      disable it unless you really need it, and even then it is better
>      to move to SMTP AUTH.
> 27.  popauth now opens trace file as user, not root (fix security
>      hole reported by Jens Steube); also umask now set.
> 28.  Fix race crash on FreeBSD (thanks to Martin Haller).
> 29.  Resolve some compiler warnings.
> 30.  Fix check for libcrypt on FreeBSD.
> 31.  Added sample pam configuration file (also installed by 'make
>      install')
> 32.  Use generic error msg and sleep in more auth failure cases.
> 33.  Added code to use mkstemp() instead of our perfectly safe usage
>      of tempnam() because some compilers issue overly broad warnings
>      implying that all uses of tempnam() are unsafe.  To bypass,
>      use '--enable-tempnam' with ./configure.

Revision 1.49 / (download) - annotate - [select for diffs], Sat May 28 02:55:43 2005 UTC (17 years, 8 months ago) by taca
Branch: MAIN
Changes since 1.48: +3 -3 lines
Diff to previous 1.48 (colored)

- Update HOMEPAGE.
- Sort PLIST.
- Share MASTER_SITES and HOMEPAGE with poppassd package with introducing
  QPOPPER_MASTER_SITES and QPOPPER_HOMEPAGE in Makefile.common.

Revision 1.48 / (download) - annotate - [select for diffs], Mon Apr 11 21:46:26 2005 UTC (17 years, 9 months ago) by tv
Branch: MAIN
Changes since 1.47: +1 -2 lines
Diff to previous 1.47 (colored)

Remove USE_BUILDLINK3 and NO_BUILDLINK; these are no longer used.

Revision 1.47 / (download) - annotate - [select for diffs], Sun Jan 30 04:41:16 2005 UTC (18 years ago) by taca
Branch: MAIN
CVS Tags: pkgsrc-2005Q1-base
Branch point for: pkgsrc-2005Q1
Changes since 1.46: +2 -2 lines
Diff to previous 1.46 (colored)

Update qpopper package to 4.0.5nb7.

- Explicitly add "--disable-ipv6" when inet6 is disabled.
- Fix compile error when inet6 is disabled.  This should fix PR pkg/28805.

Revision 1.46 / (download) - annotate - [select for diffs], Tue Dec 28 02:47:45 2004 UTC (18 years, 1 month ago) by reed
Branch: MAIN
Changes since 1.45: +2 -2 lines
Diff to previous 1.45 (colored)

The default location of the pkgsrc-installed rc.d scripts is now
under share/examples/rc.d. The variable name already was named
RCD_SCRIPTS_EXAMPLEDIR.

This is from ideas from Greg Woods and others.

Also bumped PKGREVISION for all packages using RCD_SCRIPTS mechanism
(as requested by wiz).

Revision 1.45 / (download) - annotate - [select for diffs], Sat Dec 18 03:59:30 2004 UTC (18 years, 1 month ago) by grant
Branch: MAIN
CVS Tags: pkgsrc-2004Q4-base, pkgsrc-2004Q4
Changes since 1.44: +2 -3 lines
Diff to previous 1.44 (colored)

move ssl and ipv6 options to new options.mk framework (no change to
existing defaults) and while here, add QPOPPER_SPOOL_DIR to define spool
directory (no change to existing default).

Revision 1.44 / (download) - annotate - [select for diffs], Fri Dec 17 07:35:56 2004 UTC (18 years, 1 month ago) by taca
Branch: MAIN
Changes since 1.43: +2 -2 lines
Diff to previous 1.43 (colored)

Correct set PKG_USERS with QPOPPER_USER and newly QPOPPER_GROUP.
Should be fix pkg/28687.

Revision 1.43 / (download) - annotate - [select for diffs], Sun Oct 3 00:12:54 2004 UTC (18 years, 4 months ago) by tv
Branch: MAIN
Changes since 1.42: +2 -2 lines
Diff to previous 1.42 (colored)

Libtool fix for PR pkg/26633, and other issues.  Update libtool to 1.5.10
in the process.  (More information on tech-pkg.)

Bump PKGREVISION and BUILDLINK_DEPENDS of all packages using libtool and
installing .la files.

Bump PKGREVISION (only) of all packages depending directly on the above
via a buildlink3 include.

Revision 1.42 / (download) - annotate - [select for diffs], Tue Jun 22 23:53:52 2004 UTC (18 years, 7 months ago) by xtraeme
Branch: MAIN
CVS Tags: pkgsrc-2004Q3-base, pkgsrc-2004Q3
Changes since 1.41: +2 -2 lines
Diff to previous 1.41 (colored)

Enable drac support in mail/qpopper package, patch was supplied
by John Nemeth in PR pkg/22925.

The new option to use is "QPOPPER_USE_DRAC" and by default is not
defined.

Bump PKGREVISION.

Revision 1.41 / (download) - annotate - [select for diffs], Thu May 6 13:46:23 2004 UTC (18 years, 9 months ago) by taca
Branch: MAIN
CVS Tags: pkgsrc-2004Q2-base, pkgsrc-2004Q2
Changes since 1.40: +5 -2 lines
Diff to previous 1.40 (colored)

Install stand-alone qpopper to ${PREFIX}/sbin.
Bump PKGREVISION.

TODO: support libwrap(tcpwrappers) in stand-alone qpopper.

Revision 1.40 / (download) - annotate - [select for diffs], Sun Apr 18 05:15:26 2004 UTC (18 years, 9 months ago) by snj
Branch: MAIN
Changes since 1.39: +3 -3 lines
Diff to previous 1.39 (colored)

Convert to buildlink3.

Revision 1.39 / (download) - annotate - [select for diffs], Fri Mar 26 02:27:44 2004 UTC (18 years, 10 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2004Q1-base, pkgsrc-2004Q1
Changes since 1.38: +2 -2 lines
Diff to previous 1.38 (colored)

PKGREVISION bump after openssl-security-fix-update to 0.9.6m.
Buildlink files: RECOMMENDED version changed to current version.

Revision 1.38 / (download) - annotate - [select for diffs], Wed Nov 12 03:39:41 2003 UTC (19 years, 2 months ago) by jschauma
Branch: MAIN
CVS Tags: pkgsrc-2003Q4-base, pkgsrc-2003Q4
Changes since 1.37: +2 -1 lines
Diff to previous 1.37 (colored)

PKGREVISION++ after openssl update.

Revision 1.37 / (download) - annotate - [select for diffs], Thu Mar 13 07:23:25 2003 UTC (19 years, 10 months ago) by itojun
Branch: MAIN
Changes since 1.36: +3 -4 lines
Diff to previous 1.36 (colored)

upgrade to 4.0.5.  includes security fix.

Changes from 4.0.4 to 4.0.5:

Revision 1.36 / (download) - annotate - [select for diffs], Tue Jan 28 22:03:38 2003 UTC (20 years ago) by jlam
Branch: MAIN
CVS Tags: netbsd-1-6-1-base, netbsd-1-6-1
Changes since 1.35: +3 -4 lines
Diff to previous 1.35 (colored)

Instead of including bsd.pkg.install.mk directly in a package Makefile,
have it be automatically included by bsd.pkg.mk if USE_PKGINSTALL is set
to "YES".  This enforces the requirement that bsd.pkg.install.mk be
included at the end of a package Makefile.  Idea suggested by Julio M.
Merino Vidal <jmmv at menta.net>.

Revision 1.35 / (download) - annotate - [select for diffs], Sat Nov 23 17:01:20 2002 UTC (20 years, 2 months ago) by taca
Branch: MAIN
Changes since 1.34: +2 -1 lines
Diff to previous 1.34 (colored)

Make qpopper build on Solaris.

- Remove extra rule line in install target.  (It tried to do make on
  password directory.)
- Solaris's /usr/ucb/install dosen't accept number with -g option.

Revision 1.34 / (download) - annotate - [select for diffs], Mon Sep 9 19:25:30 2002 UTC (20 years, 4 months ago) by jlam
Branch: MAIN
Changes since 1.33: +12 -9 lines
Diff to previous 1.33 (colored)

* buildlink1 --> buildlink2.
* Pass the LDFLAGS through to the build process so that the final binaries
  are built with the appropriate -Wl,-R flags.  This should fix pkg/18054.
* Use ROOT_{USER,GROUP} instead of hardcoding "root" and "wheel" when
  installing poppassd.

Revision 1.33 / (download) - annotate - [select for diffs], Sat May 4 05:59:04 2002 UTC (20 years, 9 months ago) by taca
Branch: MAIN
CVS Tags: pkgviews-base, pkgviews, netbsd-1-6-RELEASE-base, netbsd-1-6, buildlink2-base, buildlink2
Changes since 1.32: +2 -1 lines
Diff to previous 1.32 (colored)

- add a patch for fixing bulldir vulnerability with "-u" option.
- update PKGREVISION to 1.

Revision 1.32 / (download) - annotate - [select for diffs], Fri May 3 15:09:51 2002 UTC (20 years, 9 months ago) by taca
Branch: MAIN
Changes since 1.31: +4 -31 lines
Diff to previous 1.31 (colored)

Qpoper package update.  There is no functional change.

- Utilize bsd.pkg.install.mk.
- Honor PKG_SYSCONFDIR.

Revision 1.31 / (download) - annotate - [select for diffs], Thu May 2 16:16:50 2002 UTC (20 years, 9 months ago) by martti
Branch: MAIN
Changes since 1.30: +3 -3 lines
Diff to previous 1.30 (colored)

Updated qpopper to 4.0.4

* Fixed DOS attack seen on some systems.
* Fixed "noop has null function" log entry.
* Allow '-p' to be used when APOP not defined (noted by Daniel Senie).
* Enforce ClearTextPassword even without APOP (noted by Daniel Senie).
* Restrict clear-text-password=never to APOP.
* Restrict clear-text-password=tls to QPOP_SSL.
* Fixed qpopper hanging on I/O error on some platforms.

Revision 1.30 / (download) - annotate - [select for diffs], Sun Sep 9 03:37:02 2001 UTC (21 years, 4 months ago) by jlam
Branch: MAIN
CVS Tags: netbsd-1-5-PATCH003
Changes since 1.29: +2 -1 lines
Diff to previous 1.29 (colored)

Move USE_BUILDLINK_ONLY definition out of Makefile.common and into the
individual package Makefiles.

Revision 1.29 / (download) - annotate - [select for diffs], Thu Jul 26 15:43:28 2001 UTC (21 years, 6 months ago) by taca
Branch: MAIN
Changes since 1.28: +25 -14 lines
Diff to previous 1.28 (colored)

- Utilize bulidlink frame work for openssl dependency.
- Use INSTALL/DEINSTALL script rather than post-intall/pre-install work.

Revision 1.28 / (download) - annotate - [select for diffs], Sun Jun 10 15:08:40 2001 UTC (21 years, 7 months ago) by taca
Branch: MAIN
Changes since 1.27: +33 -34 lines
Diff to previous 1.27 (colored)

Update qpopper to 4.0.3 from 3.1.2.  Here is brief new feature from
Release note.

4.0
           Supports TLS/SSL security.
           '-p' option now has value '4' to permit plain-text passwords
        under TLS/SSL.
           Now uses a cache file to retain spool index across sessions.
        This dramatically speeds up session start when no new mail has
        arrived.

           '-l' option added to specify TLS/SSL support.
           Lots of TLS/SSL options added.  See the Administrator's Guide
        for details.
           '-v' option added to report current version and exit.
           'make install' added.
           Lots of compile-time options now available at run-time.  See
        the Administrator's Guide for details.
           Integrated poppassd into build.

And here is changes from 4.0.

Changes from 4.0.2 to 4.0.3:

Revision 1.27 / (download) - annotate - [select for diffs], Sun Mar 4 03:26:51 2001 UTC (21 years, 11 months ago) by assar
Branch: MAIN
CVS Tags: netbsd-1-5-PATCH001
Changes since 1.26: +6 -1 lines
Diff to previous 1.26 (colored)

turn KERBEROS into a binary switch

Revision 1.26 / (download) - annotate - [select for diffs], Sat Feb 17 18:25:03 2001 UTC (21 years, 11 months ago) by wiz
Branch: MAIN
Changes since 1.25: +2 -1 lines
Diff to previous 1.25 (colored)

Update to new COMMENT style: COMMENT var in Makefile instead of pkg/COMMENT.

Revision 1.25 / (download) - annotate - [select for diffs], Thu Dec 14 19:46:03 2000 UTC (22 years, 1 month ago) by itojun
Branch: MAIN
Changes since 1.24: +2 -2 lines
Diff to previous 1.24 (colored)

upgrade to more recent IPv6 patch.  now standalone mode supports IPv6.

Revision 1.24 / (download) - annotate - [select for diffs], Mon Dec 11 17:23:01 2000 UTC (22 years, 1 month ago) by itojun
Branch: MAIN
Changes since 1.23: +12 -14 lines
Diff to previous 1.23 (colored)

upgrde to 3.1.2, as 2.x had security issues and there's no support given
any longer to 2.x.

NOTE: kerberos support is dropped, kerberos guru please re-do it...


from ftp://ftp.qualcomm.com/eudora/servers/unix/popper/Release.Notes

Release Notes:

3.1
           Can now set server mode and kerberos service name using
        run-time options.
           Can now specify plain-text password handling when APOP is
        available using '-p 0|1|2|3' run-time option. 0 is default;
        1 means clear text passwords are never permitted for any user;
        2 means they are always permitted (even if an APOP entry exists),
        which allows them to be used as a fallback when clients don't
        support APOP); 3 means they are permitted on the local interface
        (127.*.*.*) only.
           Added '-D drac-host' run-time option to specify the drac host.
        Only valid if compiled with --enable-drac.  The default is
        localhost.
           Added '-f config-file' run-time option.  Additional run-time
        options are read from the specified file.  All current run-time
        options can now be set this way.  See INSTALL file for option
        names and syntax.
           Added '-u' run-time option to read '.qpopper-options' file in
        user's home directory.
           Added Kerberos V support.
           BULLDB access now uses usleep(3C) if available, resulting in
        many more access attempts with a shorter maximum delay.
           Added run-time options 'bulldb-nonfatal' (-B) and
        'bulldb-max-retries' to allow fine control over BULLDB access
        behavior.  'bulldb-nonfatal' allows a session to continue if
        the bulletin database can't be locked.  'bulldb-max-retries'
        sets the maximum number of attempts to lock the database.  This
        value should only be changed if you know if your system has
        usleep(3C) or not.  On systems with usleep(3C), this can be a
        large value (the default is 75).  On systems without usleep(3C),
        this should remain small (the default is 10).
           Added new ./configure flags (see INSTALL for more details):
              --enable-timing to write log records with elapsed time for
                   authentication, initialization, and cleanup.
              --enable-old-uidl to generates UIDs using old (pre-3.x)
                   style encoding.  This is only useful if you also set
                   NO_STATUS and have existing users with old (pre-3.x)
                   spool files and you want to keep the UIDs the same.
              --disable-status to prevent Qpopper from writing 'Status'
                   or 'X-UIDL' headers (sets NO_STATUS).  This forces
                   UIDs for each message to be recalculated in each
                   session.
              --enable-keep-temp-drop to prevents Qpopper from deleting
                   the temp drop files.
              --disable-check-pw-max to prevent Qpopper from checking
                   for expired passwords.
              --disable-old-spool-loc to not check for old .user.pop
                   files in old locations when HASH_SPOOL or HOMEDIRMAIL
                   used.
              --disable-check-hash-dir to not check for or create hash
                   spool directories.  Use this if you pre-create the
                   directories.
              --enable-server-mode-group-include=group to set server
                   mode for users in the specified group.
              --enable-server-mode-group-exclude=group to set server
                   mode OFF for users in the specified group.
              --enable-secure-nis-plus for use with secure NIS+.
              --disable-optimizations to turn off compiler optimizations.
              --with-kerberos5 for Kerberos V support (using patch from
                   Ken Hornstein).
              --enable-any-kerberos-principal to accept any principal in
                   the client request.
              --enable-kuserok to use kuserok() to vet users.
              --enable-ksockinst to use getsockinst() for Kerberos
                   instance.
              --enable-standalone to create standalone POP daemon instead
                   of being run out of inetd.  Can specify IP address
                   and/or port number to bind to as parameter 1, e.g.,
                   'popper 199.46.50.7:8110 -S' or 'popper 8110 -S -T600'.
                   If not specified, IP address defaults to all available.
                   The default port is 110 except when _DEBUG (not simply
                   DEBUG) is defined, then it is 8765.
              --enable-auth-file=path to permit access only to users listed
                   in the specified file.  Format is one user per line.
              --enable-nonauth-file=path to deny access to users listed in
                   the specified file.  Format is one user per line.
              --disable-update-abort to avoid the default behavior of going
                    into update mode if the session aborts (the default
                    behavior violates of RFC 1939, but was found to be
                    needed when noisy dialup lines otherwise prevented users
                    from ever deleting messages).
                                            ([RCG])

3.0
           Both dot-locking and flock() now used on all platforms.  (On some
        systems we emulate flock() using fcntl).
           Added POP3 extensions(CAPA). The extensions added so far are
        X-MANGLE, LOGIN-DELAY and EXPIRE.
           X-MANGLE condenses Mime messages into a single part for ease of
        use by lightweight clients. The transformations supported through
        X-MANGLE are to and from text/plain, format=flowed, and text/html.
           As a way to enable MIME-mangling with clients that do not
        support XMANGLE, add "-no-mime" to the user name.  For example,
        if the userid is"mary", enter it in the client as "mary-no-mime".
           The optional LOGIN-DELAY and EXPIRE values are only announced
        through the CAPA command.  The values to announce are passed as
        command line switches.  Actual enforcement of minimum login delay
        and message expiration is up to the site by some other means.
        (For example, a simple script run from crontab could be used for
        message expiration.)  Qpopper does support automatic deletion of
        downloaded messages through the --enable-auto-delete configure
        flag.  This can be used to effect EXPIRE 0 (no retention).
           Added new run-time options: -R to disable reverse-lookups on client
        IP addresses; -c to downcase user name.
           A failure at some point in a transaction now releases all locks
        explicitly. Certain paths do not release locks where SysV .lock files
        are created.
           Fixed bugs with Bulletin Services and Server mode.
           DEBUGn macros for debug and trace messages.
           Added new ./configure flags (see INSTALL for more details):
              --with-warnings for extra compiler warnings.
              --enable-shy to hide qpopper's version number in the
                    banner and CAPA IMPLEMENTATION tag.
              --enable-auto-delete to automatically mark for deletion
                    all messages downloaded with RETR.
              --enable-hash-spool=1|2 to use hashed spool directories.
              --enable-home-dir-mail=file to use a spool file in the
                   user's home directory.
              --enable-bulldb=path to enable bulletins and set the path
                   for the bulletin directory.
              --with-new-bulls=number to specify the maximum number
                   of bulletins for new users (default is 10).
              --enable-popbulldir=path to specify an alternate location
                    for users' popbull files.
              --enable-log-login to log successful user logins.  This
                   can be used, for example, to validate subsequent
                   SMTP sessions from the same IP address within a
                   short time period, in the absence of SMTP AUTH
                   support by client and server. (Suggested by Andy
                   Harper et al).
              --with-pam=service-name to authenticate using PAM (based
                    on patch contributed by German Poo).
              --with-log-facility=name to specify the log facility.
                    Default is LOG_LOCAL1 or LOG_MAIL, depending on the
                    OS.
              --enable-uw-kludge to check for and hide a UW IMAP status
                    message.
              --enable-group-bulls to show bulletins by groups (group
                    name is second element in bulletin name).  Based on
                    patch by Mikolaj Rydzewski.
              --enable-timing to report timing information in the log.
              --enable-drac to use DRAC.  Based on patches by Mike
                    McHenry, Forrest Aldrich, Steven Champeon, and others.
           Added file popper/banner.h -- modify this file to add a custom
        banner and CAPA IMPLEMENTATION tag suffix.  Note that if you modify
        qpopper you should indicate this using banner.h.
           Improved error messages and warnings: warning "Unable to get
        canonical name of client" now includes IP address of client; logging
        added for I/O errors and discarded input (line too long); added errno
        to POP EOF -ERR message; "Possible probe of account" warning now logged
        as WARNING, not CRITICAL.

Revision 1.23 / (download) - annotate - [select for diffs], Sat Sep 9 19:40:19 2000 UTC (22 years, 4 months ago) by fredb
Branch: MAIN
CVS Tags: netbsd-1-5-RELEASE, netbsd-1-4-PATCH003
Changes since 1.22: +2 -2 lines
Diff to previous 1.22 (colored)

Reorganize crypto handling, as discussed on tech-pkg. Remove all
RESTRICTED= variables that were predicated on former U.S. export
regulations. Add CRYPTO=, as necessary, so it's still possible to
exclude all crypto packages from a build by setting MKCRYPTO=no
(but "lintpkgsrc -R" will no longer catch them).

Specifically,

- - All packages which set USE_SSL just lose their RESTRICTED
    variable, since MKCRYPTO responds to USE_SSL directly.
- - realplayer7 and ns-flash keep their RESTRICTED, which is based
    on license terms, but also gain the CRYPTO variable.
- - srp-client is now marked broken, since the distfile is evidently
    no longer available. On this, we're no worse off than before.
    [We haven't been mirroring the distfile, or testing the build!]
- - isakmpd gets CRYPTO for RESTRICTED, but remains broken.
- - crack loses all restrictions, as it does not evidently empower
    a user to utilize strong encryption (working definition: ability
    to encode a message that requires a secret key plus big number
    arithmetic to decode).

Revision 1.22 / (download) - annotate - [select for diffs], Thu Aug 24 00:57:32 2000 UTC (22 years, 5 months ago) by wiz
Branch: MAIN
Changes since 1.21: +3 -1 lines
Diff to previous 1.21 (colored)

Re-add installation of qpopauth, lost in last commit.

Revision 1.21 / (download) - annotate - [select for diffs], Fri Aug 18 20:37:28 2000 UTC (22 years, 5 months ago) by hubertf
Branch: MAIN
Changes since 1.20: +6 -11 lines
Diff to previous 1.20 (colored)

Install 'license' file, so that we can distribute binaries
(which require the license to be included)

Revision 1.20 / (download) - annotate - [select for diffs], Sun Jan 9 01:28:34 2000 UTC (23 years ago) by wiz
Branch: MAIN
CVS Tags: netbsd-1-4-PATCH002
Changes since 1.19: +1 -2 lines
Diff to previous 1.19 (colored)

whitespace cleanup

Revision 1.19 / (download) - annotate - [select for diffs], Tue Sep 7 17:58:00 1999 UTC (23 years, 5 months ago) by bad
Branch: MAIN
CVS Tags: comdex-fall-1999
Changes since 1.18: +9 -1 lines
Diff to previous 1.18 (colored)

Make this DTRT wrt. Kerberos4 support.

Revision 1.18 / (download) - annotate - [select for diffs], Fri Sep 3 22:00:52 1999 UTC (23 years, 5 months ago) by tron
Branch: MAIN
Changes since 1.17: +2 -2 lines
Diff to previous 1.17 (colored)

Compare "${USE_INET6}" explicitly with "YES" so that you can override
settings at the command line.

Revision 1.17 / (download) - annotate - [select for diffs], Wed Aug 18 09:01:49 1999 UTC (23 years, 5 months ago) by agc
Branch: MAIN
Changes since 1.16: +3 -1 lines
Diff to previous 1.16 (colored)

Record build options in the BuildInfo file via BUILD_DEFS. These can be
displayed using the -B option to pkg_info(1).

Revision 1.16 / (download) - annotate - [select for diffs], Fri Jul 9 15:58:34 1999 UTC (23 years, 6 months ago) by itojun
Branch: MAIN
CVS Tags: netbsd-1-4-PATCH001
Changes since 1.15: +1 -7 lines
Diff to previous 1.15 (colored)

integrate USE_INET6 build better.  uses the same set of NetBSD patches,
and switch INET6/non-INET6 build by "#ifdef INET6".

Revision 1.15 / (download) - annotate - [select for diffs], Thu Jul 8 17:11:56 1999 UTC (23 years, 7 months ago) by itojun
Branch: MAIN
Changes since 1.14: +10 -1 lines
Diff to previous 1.14 (colored)

enable IPV6 build (USE_INET6)

Revision 1.14 / (download) - annotate - [select for diffs], Tue Jun 8 11:54:08 1999 UTC (23 years, 8 months ago) by bad
Branch: MAIN
Changes since 1.13: +7 -1 lines
Diff to previous 1.13 (colored)

Enable server mode if QPOPPER_SERVERMODE is defined in /etc/mk.conf.

Revision 1.13 / (download) - annotate - [select for diffs], Sat Feb 20 22:48:34 1999 UTC (23 years, 11 months ago) by hubertf
Branch: MAIN
CVS Tags: netbsd-1-4-RELEASE
Changes since 1.12: +1 -3 lines
Diff to previous 1.12 (colored)

Fix CONFLICTS (remove redundancy, mostly)

Revision 1.12 / (download) - annotate - [select for diffs], Tue Sep 8 22:15:21 1998 UTC (24 years, 4 months ago) by tron
Branch: MAIN
CVS Tags: netbsd-1-3-PATCH003
Changes since 1.11: +2 -4 lines
Diff to previous 1.11 (colored)

Don't install formatted manual page because it isn't patched.

Revision 1.11 / (download) - annotate - [select for diffs], Thu Aug 20 15:17:10 1998 UTC (24 years, 5 months ago) by tsarna
Branch: MAIN
Changes since 1.10: +2 -1 lines
Diff to previous 1.10 (colored)

The Grand Homepagification:
	- New, optional Makefile variable HOMEPAGE, specifies a URL for
	  the home page of the software if it has one.
	- The value of HOMEPAGE is used to add a link from the
	  README.html files.
	- pkglint updated to know about it.  The "correct" location for
	  HOMEPAGE in the Makefile is after MAINTAINER, in that same
	  section.

Revision 1.10 / (download) - annotate - [select for diffs], Sat Jul 18 13:18:51 1998 UTC (24 years, 6 months ago) by frueauf
Branch: MAIN
Changes since 1.9: +12 -11 lines
Diff to previous 1.9 (colored)

Update qpopper to 2.53.

Revision 1.9 / (download) - annotate - [select for diffs], Thu Jul 2 07:09:03 1998 UTC (24 years, 7 months ago) by hubertf
Branch: MAIN
Changes since 1.8: +4 -4 lines
Diff to previous 1.8 (colored)

Update to V2.52

Revision 1.8 / (download) - annotate - [select for diffs], Tue Jun 30 18:11:28 1998 UTC (24 years, 7 months ago) by tron
Branch: MAIN
Changes since 1.7: +3 -1 lines
Diff to previous 1.7 (colored)

Add "${CONFLICTS}".

Revision 1.7 / (download) - annotate - [select for diffs], Tue Jun 30 06:55:46 1998 UTC (24 years, 7 months ago) by hubertf
Branch: MAIN
Changes since 1.6: +3 -3 lines
Diff to previous 1.6 (colored)

update to V2.5

Revision 1.6 / (download) - annotate - [select for diffs], Sun Jun 21 03:10:15 1998 UTC (24 years, 7 months ago) by tv
Branch: MAIN
Changes since 1.5: +2 -1 lines
Diff to previous 1.5 (colored)

Rename the qpopper pkg to qpopper-2.41b1, to make it more in line with the
rest of the pkg versioning conventions.

Revision 1.5 / (download) - annotate - [select for diffs], Thu Jun 18 15:25:25 1998 UTC (24 years, 7 months ago) by agc
Branch: MAIN
Changes since 1.4: +1 -4 lines
Diff to previous 1.4 (colored)

Remove MAN<sect> and CAT<sect> definitions from package Makefiles - these
are unnecessary with automatic manual page handling.

Revision 1.4 / (download) - annotate - [select for diffs], Wed Apr 15 10:38:32 1998 UTC (24 years, 9 months ago) by agc
Branch: MAIN
CVS Tags: netbsd-1-3-PATCH002
Changes since 1.3: +2 -7 lines
Diff to previous 1.3 (colored)

Use the bsd.pkg.mk and bsd.pkg.subdir.mk files in the pkgsrc tree.
Remove redundant (and sometimes erroneous) comments.

Revision 1.3 / (download) - annotate - [select for diffs], Sun Feb 15 22:25:12 1998 UTC (24 years, 11 months ago) by frueauf
Branch: MAIN
Changes since 1.2: +5 -4 lines
Diff to previous 1.2 (colored)

portlint: fix URL (qpopper->popper ; end with /), remove MASTER_SITE_BACKUPS,
	  set MIRROR_DISTFILE=no instead, reorder EXTRACT_SUFX.

Revision 1.2 / (download) - annotate - [select for diffs], Fri Feb 13 15:06:24 1998 UTC (24 years, 11 months ago) by agc
Branch: MAIN
Changes since 1.1: +4 -1 lines
Diff to previous 1.1 (colored)

Add manual page targets, so that any MANZ compression is done.

Revision 1.1 / (download) - annotate - [select for diffs], Fri Feb 13 02:26:03 1998 UTC (24 years, 11 months ago) by mellon
Branch: MAIN

Build popper package

This form allows you to request diff's between any two revisions of a file. You may select a symbolic revision name using the selection box or you may type in a numeric name using the type-in text box.




CVSweb <webmaster@jp.NetBSD.org>