[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / mail / proxsmtp

File: [cvs.NetBSD.org] / pkgsrc / mail / proxsmtp / Makefile (download)

Revision 1.10, Mon Sep 12 16:30:30 2011 UTC (12 years, 7 months ago) by taca
Branch: MAIN
CVS Tags: pkgsrc-2012Q3-base, pkgsrc-2012Q3, pkgsrc-2012Q2-base, pkgsrc-2012Q2, pkgsrc-2012Q1-base, pkgsrc-2012Q1, pkgsrc-2011Q4-base, pkgsrc-2011Q4, pkgsrc-2011Q3-base, pkgsrc-2011Q3
Changes since 1.9: +3 -3 lines

Update proxsmtp to 1.9.

1.9 [2011-01-23]
 - Fix build warnings.
 - Fix problem on linux not detecting netfilter headers.
 - Add true transparent proxying, where both client and server have no
   knowledge of the proxy. Documented at the proxsmtp web page.
 - Use capabilities to have transparent proxying without running as root.
 - Implement a simple reject filter, so no scripts need to be run.
 - Allow skipping of filtering for authenticated connections.
 - Bump up the top number of simultaneous connections.
 - Add client IP addresses to the log line.

1.8 [2008-06-30]
 - Make the XFOWARD HELO available as a environment variable in scripts. [Glenn Matthys]
 - Send an RSET to the server after filter fails an email.
 - Fix an uninitialized pid variable.

1.7 [2007-05-28]
 - Use my real name 'Stef Walter'
   See: http://memberwebs.com/nielsen/

1.6 [2006-11-13]
  - On FreeBSD fix problem where stderr wasn't processed when filter
    didn't read stdin.
  - Add strcasestr which is missing on Solaris.
  - Add back 'Header' option which was accidentally removed in 1.5. Blush!

1.5 [2006-09-05]
  - Added support for setting the REMOTE variable when an XFORWARD
    command is seen.

1.4 [2006-08-10]
  - Fix crasher after connection closes unexpectedly.
  - Fix problem with waiting for processes [Jeff Fisher]
  - Better message for 'busy' [Akihiro Sagawa]

1.3 [2005-10-21]
  - Handle condition of server refusing data transfers more gracefully.
  - Less chatty when setting timeouts fail
  - Drop privileges after binding to port. Allows listening on ports < 1024
  - Ported to Solaris
  - Fix problem with binding to certain 'long' addresses
  - Support embedded NULLs in email data.
  - Fix problems with empty addresses in logs.
  - Don't let exchange send it's strange binary data through the proxy
  - Don't reject emails when server is overloaded or errors.
  - Don't reject emails when starting the filter command fails.

1.2.1 [2005-04-15]
  - Fixed bug (introduced in 1.2) when 'Header' option is not present.

1.2  [2005-03-24]
  - Don't leak file descriptors when clamsmtpd can't connect to outgoing
        SMTP server [Chris Mason]
  - 'Header' configuration option with special format arguments [Olivier Beyssac]
  - Supress weird warnings when looking up names of local unix connections.

1.1  [2005-01-27]
  - Fixed crasher when outgoing connection couldn't be established
  - Removed erroneous chown line from clamsmtpd.sh

# $NetBSD: Makefile,v 1.10 2011/09/12 16:30:30 taca Exp $

DISTNAME=	proxsmtp-1.9
CATEGORIES=	mail
MASTER_SITES=	http://memberwebs.com/stef/software/proxsmtp/

MAINTAINER=	pkgsrc-users@NetBSD.org
HOMEPAGE=	http://memberwebs.com/stef/software/proxsmtp/
COMMENT=	SMTP proxy content filter
LICENSE=	modified-bsd

PKG_DESTDIR_SUPPORT=	user-destdir

GNU_CONFIGURE=	yes

EGDIR=		${PREFIX}/share/examples/${PKGBASE}
CONF_FILES=	${EGDIR}/proxsmtpd.conf ${PKG_SYSCONFDIR}/proxsmtpd.conf
RCD_SCRIPTS=	proxsmtpd

INSTALLATION_DIRS=	${EGDIR}

.include "../../mk/pthread.buildlink3.mk"

post-install:
	for file in							\
		doc/proxsmtpd.conf					\
		scripts/add_header.sh					\
		scripts/spamassassin.sh;				\
	do								\
		${INSTALL_DATA} ${WRKSRC}/$$file ${DESTDIR}${EGDIR};	\
	done

.include "../../mk/bsd.pkg.mk"