[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / mail / postfix

Annotation of pkgsrc/mail/postfix/Makefile, Revision 1.333

1.333   ! adam        1: # $NetBSD: Makefile,v 1.332 2021/12/08 16:05:29 adam Exp $
1.1       christos    2:
1.332     adam        3: PKGREVISION= 1
1.286     fhajny      4: .include "../../mail/postfix/Makefile.common"
1.132     martti      5:
1.312     triaxx      6: COMMENT=       Fast, easy to administer, and secure mail transfer agent
1.1       christos    7:
1.181     jlam        8: CONFLICTS+=    courier-mta-[0-9]* fastforward>=0.51nb2 sendmail-[0-9]*
1.253     cheusov     9: CONFLICTS+=    esmtp>=1.2 nullmailer-[0-9]*
1.122     grant      10:
1.323     nia        11: USE_TOOLS+=    perl pkg-config m4
1.69      wiz        12:
1.293     jperkin    13: SPECIAL_PERMS+=        sbin/postdrop ${POSTFIX_USER} ${MAILDROP_GROUP} 2555
                     14: SPECIAL_PERMS+=        sbin/postqueue ${POSTFIX_USER} ${MAILDROP_GROUP} 2555
1.227     martti     15:
1.177     martti     16: REPLACE_PERL+= auxiliary/qshape/qshape.pl
                     17:
1.147     jlam       18: # options.mk appends to CCARGS and AUXLIBS the options needed to build
                     19: # Postfix with support for various add-on modules.
1.140     jlam       20: #
1.147     jlam       21: .include "options.mk"
1.28      hubertf    22:
1.217     martti     23: FILES_SUBST+=          EXAMPLEDIR=${EXAMPLEDIR}
1.140     jlam       24: MESSAGE_SUBST+=                EXAMPLEDIR=${EXAMPLEDIR}
1.142     jlam       25: MESSAGE_SUBST+=                DOCDIR=${DOCDIR}
1.86      jlam       26:
1.140     jlam       27: MESSAGE_SRC+=          ${PKGDIR}/MESSAGE
                     28: .if exists(${PKGDIR}/MESSAGE.${OPSYS})
                     29: MESSAGE_SRC+=          ${PKGDIR}/MESSAGE.${OPSYS}
1.95      martti     30: .endif
1.140     jlam       31: PLIST_SRC+=            ${PKGDIR}/PLIST
1.50      kent       32:
1.140     jlam       33: RCD_SCRIPTS=           postfix
1.173     martti     34: OWN_DIRS+=             ${POSTFIX_QUEUE_DIR} ${POSTFIX_QUEUE_DIR}/etc
1.293     jperkin    35: OWN_DIRS_PERMS+=       ${POSTFIX_DATA_DIR} ${POSTFIX_USER} ${POSTFIX_GROUP} 0700
1.286     fhajny     36: MAKE_DIRS+=            ${METADIR}/dynamicmaps.cf.d ${METADIR}/postfix-files.d
1.140     jlam       37:
1.293     jperkin    38: PKG_GROUPS?=           ${POSTFIX_GROUP} ${MAILDROP_GROUP}
                     39: PKG_USERS?=            ${POSTFIX_USER}:${POSTFIX_GROUP}
                     40:
                     41: PKG_GECOS.${POSTFIX_USER}=     Postfix User
                     42: PKG_HOME.${POSTFIX_USER}=      ${POSTFIX_QUEUE_DIR}
1.140     jlam       43:
1.141     jlam       44: CONF_FILES=            # empty
1.224     martti     45: .for i in main.cf master.cf
1.192     martti     46: CONF_FILES+=           ${EXAMPLEDIR}/${i} ${PKG_SYSCONFDIR}/${i}
1.141     jlam       47: .endfor
                     48: CONF_FILES_PERMS=      # empty
1.93      jmmv       49:
1.176     joerg      50: SUBST_CLASSES+=                paths
                     51: SUBST_FILES.paths=     ${WRKDIR}/mailer.conf
1.310     rillig     52: SUBST_VARS.paths=      PREFIX
1.303     jperkin    53: SUBST_STAGE.paths=     pre-configure
1.176     joerg      54:
1.286     fhajny     55: INSTALLATION_DIRS+=    ${LIBEXECDIR} ${METADIR} ${SHLIBDIR} ${EXAMPLEDIR} ${DOCDIR}
1.229     heinz      56:
1.176     joerg      57: post-extract:
1.325     adam       58:        ${CP} ${FILESDIR}/mailer.conf ${WRKDIR}/mailer.conf
                     59:        ${RM} -f ${WRKSRC}/auxiliary/MacOSX/Postfix.StartupItem/Postfix
1.176     joerg      60:
1.5       tron       61: post-build:
1.145     jlam       62: .if !empty(PKG_OPTIONS:Msasl)
1.140     jlam       63:        ${ECHO} "pwcheck_method: ${PWCHECK_METHOD}" > ${WRKDIR}/smtpd.conf
                     64: .endif
1.5       tron       65:
1.140     jlam       66: do-install:
1.325     adam       67:        ${RM} -f ${WRKSRC}/conf/*.orig
1.145     jlam       68: .if !empty(PKG_OPTIONS:Msasl)
1.229     heinz      69:        ${INSTALL_DATA} ${WRKDIR}/smtpd.conf ${DESTDIR}${EXAMPLEDIR}
1.50      kent       70: .endif
1.333   ! adam       71:        cd ${WRKSRC} && ${SETENV} LD_LIBRARY_PATH=${WRKSRC}/lib \
        !            72:                DYLD_LIBRARY_PATH=${WRKSRC}/lib \
        !            73:                ${SH} ./postfix-install -non-interactive \
1.229     heinz      74:                ${DESTDIR_INSTALLOPTIONS} config_directory="${EXAMPLEDIR}"
                     75:        ${INSTALL_DATA} ${WRKDIR}/mailer.conf \
                     76:                ${DESTDIR}${EXAMPLEDIR}/mailer.conf
1.177     martti     77:        ${INSTALL_SCRIPT} ${WRKSRC}/auxiliary/qshape/qshape.pl \
1.229     heinz      78:                ${DESTDIR}${PREFIX}/sbin/qshape
1.204     martti     79:        ${INSTALL_MAN} ${WRKSRC}/man/man1/qshape.1 \
1.229     heinz      80:                ${DESTDIR}${PREFIX}/${PKGMANDIR}/man1
1.316     triaxx     81: .for dir in ${POSTFIX_QUEUE_SUBDIR}
                     82:        ${RMDIR} ${DESTDIR}${POSTFIX_QUEUE_DIR}/${dir}
                     83: .endfor
1.325     adam       84: .if ${OPSYS} == "Darwin"
                     85:        for f in ${DESTDIR}${PREFIX}/lib/postfix/lib*.dylib; do \
                     86:                install_name_tool -id `${ECHO} $$f | ${SED} -e 's,${DESTDIR},,g'` $$f; \
                     87:        done
                     88:        for f in ${DESTDIR}${PREFIX}/libexec/postfix/* ${DESTDIR}${PREFIX}/sbin/*; do \
                     89:                install_name_tool \
                     90:                        -change @rpath/libpostfix-dns.dylib ${PREFIX}/lib/postfix/libpostfix-dns.dylib \
                     91:                        -change @rpath/libpostfix-global.dylib ${PREFIX}/lib/postfix/libpostfix-global.dylib \
                     92:                        -change @rpath/libpostfix-master.dylib ${PREFIX}/lib/postfix/libpostfix-master.dylib \
                     93:                        -change @rpath/libpostfix-tls.dylib ${PREFIX}/lib/postfix/libpostfix-tls.dylib \
                     94:                        -change @rpath/libpostfix-util.dylib ${PREFIX}/lib/postfix/libpostfix-util.dylib \
                     95:                        $$f; \
                     96:        done
                     97: .endif
1.1       christos   98:
                     99: .include "../../mk/bsd.pkg.mk"

CVSweb <webmaster@jp.NetBSD.org>