[BACK]Return to Makefile.module CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / mail / postfix

File: [cvs.NetBSD.org] / pkgsrc / mail / postfix / Makefile.module (download)

Revision 1.2, Sun Nov 22 11:14:44 2020 UTC (3 years, 4 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2023Q4-base, pkgsrc-2023Q4, pkgsrc-2023Q3-base, pkgsrc-2023Q3, pkgsrc-2023Q2-base, pkgsrc-2023Q2, pkgsrc-2023Q1-base, pkgsrc-2023Q1, pkgsrc-2022Q4-base, pkgsrc-2022Q4, pkgsrc-2022Q3-base, pkgsrc-2022Q3, pkgsrc-2022Q2-base, pkgsrc-2022Q2, pkgsrc-2022Q1-base, pkgsrc-2022Q1, pkgsrc-2021Q4-base, pkgsrc-2021Q4, pkgsrc-2021Q3-base, pkgsrc-2021Q3, pkgsrc-2021Q2-base, pkgsrc-2021Q2, pkgsrc-2021Q1-base, pkgsrc-2021Q1, pkgsrc-2020Q4-base, pkgsrc-2020Q4, HEAD
Changes since 1.1: +5 -1 lines

postfix: updated to 3.5.8

Fixed in Postfix version 3.5.8:

[Postfix 3.5 and later] The Postfix SMTP client inserted <CR><LF> into message headers with lines longer than $line_length_limit (default: 2048), causing all subsequent header content to become message body content. Reported by Andreas Weigel.

Fixed in Postfix versions 3.5.8, 3.4.18, 3.3.15, 3.2.20:

[Postfix 2.8 and later] The postscreen daemon did not save a copy of the postscreen_dnsbl_reply_map lookup result. This has no effect when the recommended texthash: lookup table is used, but it could result in stale data with other lookup tables.

[Postfix 2.3 and later] After deleting a recipient with a Milter, the Postfix recipient duplicate filter was not updated; the filter suppressed requests to add the recipient back. Reported by Mehmet Avcioglu.

[Postfix 2.3 and later] Memory leak: the static: maps did not free their casefolding buffer.

[Postfix 2.2 and later] With "smtpd_tls_wrappermode = yes", the smtps service was waiting for a TLS handshake, after processing an XCLIENT command. Reported by Aki Tuomi.

[Postfix 2.0 and later] The smtp_sasl_mechanism_filter implementation ignored table lookup errors, treating them as 'not found'.

[Postfix alpha and later] The code that looks for Delivered-To: headers ignored headers longer than $line_length_limit (default: 2048).

# $NetBSD: Makefile.module,v 1.2 2020/11/22 11:14:44 adam Exp $
# used by mail/postfix-cdb/Makefile
# used by mail/postfix-ldap/Makefile
# used by mail/postfix-lmdb/Makefile
# used by mail/postfix-mysql/Makefile
# used by mail/postfix-pcre/Makefile
# used by mail/postfix-pgsql/Makefile
# used by mail/postfix-sqlite/Makefile

PKGNAME=	${DISTNAME:S/postfix/postfix-${POSTFIX_LIB}/}

.include "../../mail/postfix/Makefile.common"

DEPENDS+=	postfix-${PKGVERSION_NOREV}{,nb[0-9]*}:../../mail/postfix

CCARGS+=	-DHAS_${POSTFIX_LIB:tu}
MAKE_ENV+=	AUXLIBS_${POSTFIX_LIB:tu}=${AUXLIBS_MODULE:Q}

# Define functionality to populate dynamicmaps.cf
.if ${OPSYS} == "Darwin"
POSTFIX_LIBFILE=	postfix-${POSTFIX_LIB}.dylib
.else
POSTFIX_LIBFILE=	postfix-${POSTFIX_LIB}.so
.endif
.if !empty(POSTFIX_LIB_DICT:Myes)
POSTFIX_LIB_FUNCS+=	dict_${POSTFIX_LIB}_open
.endif
.if !empty(POSTFIX_LIB_MKMAP:Myes)
POSTFIX_LIB_FUNCS+=	mkmap_${POSTFIX_LIB}_open
.endif

INSTALLATION_DIRS+=	${SHLIBDIR}
INSTALLATION_DIRS+=	${METADIR}/dynamicmaps.cf.d ${METADIR}/postfix-files.d

GENERATE_PLIST+=	${ECHO} "${SHLIBDIR}/${POSTFIX_LIBFILE}";
GENERATE_PLIST+=	${ECHO} "${METADIR}/dynamicmaps.cf.d/${POSTFIX_LIB}.cf";
GENERATE_PLIST+=	${ECHO} "${METADIR}/postfix-files.d/${POSTFIX_LIB}.cf";

do-build:
	cd ${WRKSRC}/src/util && ${BUILD_MAKE_CMD} update
	cd ${WRKSRC}/${POSTFIX_LIBDIR} && ${BUILD_MAKE_CMD} ${POSTFIX_LIBFILE}

do-install:
	${INSTALL_LIB} ${WRKSRC}/${POSTFIX_LIBDIR}/${POSTFIX_LIBFILE} 			\
		${DESTDIR}${PREFIX}/${SHLIBDIR}
	${ECHO} "${POSTFIX_LIB} ${POSTFIX_LIBFILE} ${POSTFIX_LIB_FUNCS}" >		\
		${DESTDIR}${PREFIX}/${METADIR}/dynamicmaps.cf.d/${POSTFIX_LIB}.cf
	( ${ECHO} "\$$shlib_directory/${POSTFIX_LIBFILE}:f:root:-:755";			\
	  ${ECHO} "\$$meta_directory/dynamicmaps.cf.d/${POSTFIX_LIB}.cf:f:root:-:644";	\
	  ${ECHO} "\$$meta_directory/postfix-files.d/${POSTFIX_LIB}.cf:f:root:-:644"; )	\
		> ${DESTDIR}${PREFIX}/${METADIR}/postfix-files.d/${POSTFIX_LIB}.cf