[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / mail / php-imap

File: [cvs.NetBSD.org] / pkgsrc / mail / php-imap / Makefile (download)

Revision 1.23, Mon Oct 8 12:19:26 2012 UTC (11 years, 1 month ago) by asau
Branch: MAIN
CVS Tags: pkgsrc-2012Q4-base, pkgsrc-2012Q4
Changes since 1.22: +1 -3 lines

Drop PKG_DESTDIR_SUPPORT setting, "user-destdir" is default these days.

# $NetBSD: Makefile,v 1.23 2012/10/08 12:19:26 asau Exp $

MODNAME=		imap
CATEGORIES+=		mail
COMMENT=		PHP extension for IMAP (Internet Mailbox Access Protocol)

CONFLICTS=	php-imap-[0-9]*

USE_PHP_EXT_PATCHES=	yes

.include "../../mk/bsd.prefs.mk"

CONFIGURE_ARGS+=	--with-${MODNAME}=shared,${BUILDLINK_PREFIX.imap-uw}
CONFIGURE_ARGS+=	--with-${MODNAME}-linkage

.if ${OPSYS} == "SunOS"
CONFIGURE_ARGS+=	--with-${MODNAME}-ssl=yes
.else
CONFIGURE_ARGS+=	--with-${MODNAME}-ssl=${SSLBASE}
.endif

CONFIGURE_ENV+=		ac_cv_lib_pam_pam_start=no

# Imap extension's config.m4 calls m4 macro PHP_SETUP_OPENSSL() which
# expects PHP_ARG_WITH(openssl, ...) being called beforehand so that
# PHP_OPENSSL is set. For a self contained extension build like for
# this package this is not the case of course.

.if ${OPSYS} == "SunOS"
CONFIGURE_ENV+=		PHP_OPENSSL=yes
.else
CONFIGURE_ENV+=		PHP_OPENSSL=${SSLBASE:Q}
.endif

.include "../../mail/imap-uw/buildlink3.mk"
.include "../../security/openssl/buildlink3.mk"
.include "../../lang/php/ext.mk"
.include "../../mk/bsd.pkg.mk"