[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / mail / mutt

Annotation of pkgsrc/mail/mutt/Makefile, Revision 1.116

1.116   ! bouyer      1: # $NetBSD: Makefile,v 1.115 2004/03/10 18:42:18 wiz Exp $
1.1       tron        2:
1.115     wiz         3: DISTNAME=              mutt-1.4.2.1i
1.93      jschauma    4: PKGNAME=                ${DISTNAME:C/i$//}
1.73      jlam        5: CATEGORIES=            mail
1.93      jschauma    6: MASTER_SITES=          ftp://ftp.mutt.org/mutt/ \
1.79      tron        7:                        ftp://ftp.stealth.net/pub/mirrors/ftp.mutt.org/pub/mutt/ \
                      8:                        ftp://gd.tuwien.ac.at/infosys/mail/mutt/ \
1.100     tron        9:                        ftp://ftp.fu-berlin.de/unix/mail/mutt/
1.1       tron       10:
1.98      grant      11: MAINTAINER=            tron@NetBSD.org
1.73      jlam       12: HOMEPAGE=              http://www.mutt.org/
1.99      martti     13: COMMENT=               Text-based MIME mail client with PGP support
1.1       tron       14:
1.91      jlam       15: BUILD_USES_MSGFMT=     yes
1.72      jlam       16:
1.109     agc        17: WRKSRC=                        ${WRKDIR}/${DISTNAME:C/i$$//}
1.113     tron       18: USE_BUILDLINK3=                yes
1.91      jlam       19: USE_PKGINSTALL=                yes
                     20: GNU_CONFIGURE=         yes
                     21: USE_PKGLOCALEDIR=      yes
1.77      jlam       22: CONFIGURE_ARGS+=       --sysconfdir=${PKG_SYSCONFDIR} \
                     23:                        --with-docdir=${PREFIX}/share/doc/mutt \
                     24:                        --without-included-gettext \
                     25:                        --enable-pop --enable-imap
1.45      kim        26:
1.78      yyamano    27: LDFLAGS+=              ${_STRIPFLAG_CC}
1.106     tron       28: PLIST_SRC=             ${WRKDIR}/PLIST
1.46      kim        29:
                     30: .include "../../mk/bsd.prefs.mk"
                     31:
1.116   ! bouyer     32: .if (${OPSYS} == "SunOS")
        !            33: CONFIGURE_ARGS+=       --without-wc-funcs
        !            34: .endif
        !            35:
1.80      fredb      36: .if ${MUTT_USE_SLANG} == YES
1.113     tron       37: . include "../../devel/libslang/buildlink3.mk"
1.82      jlam       38: CONFIGURE_ARGS+=       --with-slang=${BUILDLINK_PREFIX.libslang}
1.79      tron       39: .else
1.80      fredb      40: . if ${MUTT_USE_NCURSES} == YES
1.91      jlam       41: USE_NCURSES=           yes
1.80      fredb      42: . endif
1.113     tron       43: . include "../../devel/ncurses/buildlink3.mk"
1.82      jlam       44: CONFIGURE_ARGS+=       --with-curses=${BUILDLINK_PREFIX.ncurses}
1.79      tron       45: .endif
                     46:
1.114     tron       47: # There is a problem using NetBSD's /bin/sh under old NetBSD releases,
                     48: # so use /bin/ksh there.
                     49: .if !empty(MACHINE_PLATFORM:MNetBSD-1.[0-5]*-*)
1.72      jlam       50: CONFIGURE_ARGS+=       --with-exec-shell=/bin/ksh
1.57      wiz        51: .endif
                     52:
1.80      fredb      53: .if ${MUTT_USE_SSL} == YES
1.113     tron       54: .include "../../security/openssl/buildlink3.mk"
1.82      jlam       55: CONFIGURE_ARGS+=       --with-ssl=${SSLBASE}
1.46      kim        56: .else
1.72      jlam       57: CONFIGURE_ARGS+=       --without-ssl
1.45      kim        58: .endif
                     59:
1.86      elric      60: .if defined(USE_SASL) && ${USE_SASL} == "YES"
1.113     tron       61: .include "../../security/cyrus-sasl/buildlink3.mk"
1.86      elric      62: CONFIGURE_ARGS+=       --with-sasl=${BUILDLINK_PREFIX.cyrus-sasl}
                     63: .endif
                     64:
                     65: BUILD_DEFS+=           MUTT_USE_NCURSES MUTT_USE_SLANG MUTT_USE_SSL USE_SASL
1.72      jlam       66:
1.87      jmmv       67: EGDIR=                 ${PREFIX}/share/examples/mutt
1.77      jlam       68: CONF_FILES=            ${EGDIR}/Muttrc ${PKG_SYSCONFDIR}/Muttrc
                     69: SUPPORT_FILES=         ${EGDIR}/mime.types ${PKG_SYSCONFDIR}/mime.types
1.90      jmmv       70:
                     71: post-extract:
                     72:        ${MV} ${WRKSRC}/doc/mutt.man ${WRKSRC}/doc/mutt.man.in
                     73:
                     74: pre-build:
                     75:        ${SED} -e "s|@PREFIX@|${PREFIX}|g" \
                     76:               -e "s|@PKG_SYSCONFDIR@|${PKG_SYSCONFDIR}|g" \
                     77:               < ${WRKSRC}/doc/mutt.man.in > ${WRKSRC}/doc/mutt.man
1.83      tron       78:
1.72      jlam       79: post-install:
1.108     grant      80:        ${RM} -f ${PREFIX}/share/doc/mutt/samples
1.107     grant      81:        ${LN} -f -s ${EGDIR} ${PREFIX}/share/doc/mutt/samples
1.106     tron       82:        ${CP} ${PKGDIR}/PLIST ${PLIST_SRC}
1.102     grant      83:        @if [ -f ${PREFIX}/bin/mutt_dotlock ]; then \
1.106     tron       84:                ${ECHO} "bin/mutt_dotlock" >> ${PLIST_SRC}; \
1.102     grant      85:        fi
1.39      agc        86:
1.113     tron       87: .include "../../converters/libiconv/buildlink3.mk"
                     88: .include "../../devel/gettext-lib/buildlink3.mk"
1.54      wiz        89: .include "../../mk/bsd.pkg.mk"

CVSweb <webmaster@jp.NetBSD.org>