[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / mail / mutt-devel

File: [cvs.NetBSD.org] / pkgsrc / mail / mutt-devel / Attic / Makefile (download)

Revision 1.71, Mon Jan 26 22:35:02 2009 UTC (15 years, 2 months ago) by tonio
Branch: MAIN
Changes since 1.70: +3 -4 lines

Update mail/mutt-devel to 1.5.19

User destdir mode instead of user-destdir: this make sure the package is
correctly created when mutt_dotlock is needed.

Mostly bugfixes in changelog, among them:
- Only install mutt_dotlock(1) if binary is installed.
- Allow for mail addresses longer than 256 characters.
- Make multipart decoding a little more forgiving.
- Make $move default to no instead of ask-no.
- Show more information about problematic SMIME signatures under gpgme.
- Improve gpgme SMIME uid display.
- Support displaying application/pgp-keys with GPGME.
- Verify hostname in (Open)SSL certificate validation.
- Make text/enriched handler multibyte aware.
- translation updates.

UPDATING:
+ support for SSL certificate chains
+ <what-key> function works in pager, too
+ support for tokyocabinet (qdbm successor)
! $move now defaults to "no" instead of "ask-no"
+ $imap_pipeline_depth controls the number of commands that mutt can issue
  to an IMAP server before it must collect the responses
+ $ssl_client_cert available with gnutls as well as openssl
+ 'mime_lookup application/octet-stream' added to system Muttrc

# $NetBSD: Makefile,v 1.71 2009/01/26 22:35:02 tonio Exp $

DISTNAME=		mutt-1.5.19
CATEGORIES=		mail
MUTT_SITES=		ftp://ftp.mutt.org/mutt/ \
			ftp://ftp.stealth.net/pub/mirrors/ftp.mutt.org/pub/mutt/ \
			ftp://gd.tuwien.ac.at/infosys/mail/mutt/ \
			ftp://ftp.fu-berlin.de/unix/mail/mutt/
MASTER_SITES=		${MUTT_SITES:=devel/}

MAINTAINER=		tonio@NetBSD.org
HOMEPAGE=		http://www.mutt.org/
COMMENT=		Text-based MIME mail client with PGP & S/MIME support

PKG_INSTALLATION_TYPES=	overwrite pkgviews
PKG_DESTDIR_SUPPORT=	destdir # avoid user-destdir to handle mutt_dotlock

.include "../../mk/bsd.prefs.mk"

USE_PKGLOCALEDIR=	yes
USE_TOOLS+=		msgfmt

GNU_CONFIGURE=		yes
CONFIGURE_ARGS+=	--sysconfdir=${PKG_SYSCONFDIR:Q}		\
			--with-docdir=${PREFIX}/share/doc/mutt		\
			--without-included-gettext			\
			--enable-pop					\
			--enable-imap
MAKE_ENV+=		CHGRP=${CHGRP:Q} CHMOD=${CHMOD:Q}

.if ${OPSYS} == "NetBSD" || ${OPSYS} == "DragonFly" || ${OPSYS} == "FreeBSD" || ${OPSYS} == "OpenBSD"
# Force sendmail to /usr/sbin to avoid postfix's
# ${LOCALBASE}/sbin/sendmail.  Should be enabled on all platforms which
# support mailwrapper.
CONFIGURE_ENV+=		SENDMAIL=/usr/sbin/sendmail
.endif

.if (${OPSYS} == "SunOS")
CONFIGURE_ARGS+=	--without-wc-funcs
.endif

# There is a problem using /bin/sh on old NetBSD releases, so use /bin/ksh
# there.
#
.if !empty(MACHINE_PLATFORM:MNetBSD-1.[0-5]*-*)
CONFIGURE_ARGS+=	--with-exec-shell=/bin/ksh
.endif

.include "options.mk"

LDFLAGS+=		${_STRIPFLAG_CC}

DOCDIR=			${PREFIX}/share/doc/mutt
EGDIR=			${PREFIX}/share/examples/mutt
CONF_FILES=		${EGDIR}/Muttrc ${PKG_SYSCONFDIR}/Muttrc
CONF_FILES+=		${EGDIR}/mime.types ${PKG_SYSCONFDIR}/mime.types
FILES_SUBST+=		DOCDIR=${DOCDIR}
INSTALLATION_DIRS+=	${DOCDIR} ${EGDIR}

SUBST_CLASSES+=		paths
SUBST_FILES.paths=	doc/Muttrc
SUBST_VARS.paths+=	DOCDIR PREFIX
SUBST_STAGE.paths+=	pre-configure

# Define WRKSRC explicitly so we can use its value below.
WRKSRC=			${WRKDIR}/${DISTNAME}
PLIST_VARS+=		dotlock
.if exists(${WRKSRC}/mutt_dotlock)
PLIST.dotlock=		yes
.endif
INSTALL_MAKE_FLAGS=	${MAKE_FLAGS} sysconfdir=${EGDIR}

.include "../../converters/libiconv/buildlink3.mk"
.include "../../devel/gettext-lib/buildlink3.mk"

.include "../../mk/bsd.pkg.mk"