[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / mail / mutt-devel

Annotation of pkgsrc/mail/mutt-devel/Makefile, Revision 1.29

1.29    ! tv          1: # $NetBSD: Makefile,v 1.28 2004/08/05 03:04:33 jlam Exp $
1.1       tron        2:
1.26      jlam        3: DISTNAME=              mutt-1.5.6i
1.14      tron        4: PKGNAME=               ${DISTNAME:C/i$//}
1.29    ! tv          5: PKGREVISION=   1
1.1       tron        6: CATEGORIES=            mail
1.26      jlam        7: MUTT_SITES=            ftp://ftp.mutt.org/mutt/ \
                      8:                        ftp://ftp.stealth.net/pub/mirrors/ftp.mutt.org/pub/mutt/ \
                      9:                        ftp://gd.tuwien.ac.at/infosys/mail/mutt/ \
                     10:                        ftp://ftp.fu-berlin.de/unix/mail/mutt/
                     11: MASTER_SITES=          ${MUTT_SITES:=devel/}
1.1       tron       12:
1.26      jlam       13: MAINTAINER=            jlam@NetBSD.org
1.1       tron       14: HOMEPAGE=              http://www.mutt.org/
1.26      jlam       15: COMMENT=               Text-based MIME mail client with PGP & S/MIME support
1.1       tron       16:
1.26      jlam       17: PKG_INSTALLATION_TYPES=        overwrite pkgviews
1.5       jlam       18:
1.26      jlam       19: .include "../../mk/bsd.prefs.mk"
1.5       jlam       20:
1.1       tron       21: WRKSRC=                        ${WRKDIR}/${DISTNAME:C/i$$//}
1.26      jlam       22: BUILD_USES_MSGFMT=     yes
                     23: USE_BUILDLINK3=                yes
                     24: USE_PKGLOCALEDIR=      yes
                     25: USE_PERL5=             yes
                     26: REPLACE_PERL=          smime_keys */*.pl
                     27:
                     28: GNU_CONFIGURE=         yes
                     29: CONFIGURE_ARGS+=       --sysconfdir=${PKG_SYSCONFDIR}                  \
                     30:                        --with-docdir=${PREFIX}/share/doc/mutt          \
                     31:                        --without-included-gettext                      \
                     32:                        --enable-pop                                    \
                     33:                        --enable-imap
1.1       tron       34:
1.26      jlam       35: .if (${OPSYS} == "SunOS")
                     36: CONFIGURE_ARGS+=       --without-wc-funcs
1.16      tron       37: .endif
                     38:
1.26      jlam       39: # There is a problem using /bin/sh on old NetBSD releases, so use /bin/ksh
                     40: # there.
                     41: #
                     42: .if !empty(MACHINE_PLATFORM:MNetBSD-1.[0-5]*-*)
1.5       jlam       43: CONFIGURE_ARGS+=       --with-exec-shell=/bin/ksh
1.1       tron       44: .endif
                     45:
1.28      jlam       46: .include "options.mk"
1.1       tron       47:
1.26      jlam       48: LDFLAGS+=              ${_STRIPFLAG_CC}
                     49:
                     50: USE_PKGINSTALL=                yes
                     51: DEINSTALL_EXTRA_TMPL=  ${.CURDIR}/INSTALL
                     52: INSTALL_EXTRA_TMPL=    ${.CURDIR}/INSTALL
                     53: DOCDIR=                        ${PREFIX}/share/doc/mutt
                     54: EGDIR=                 ${PREFIX}/share/examples/mutt
                     55: CONF_FILES=            ${EGDIR}/Muttrc ${PKG_SYSCONFDIR}/Muttrc
                     56: SUPPORT_FILES=         ${EGDIR}/mime.types ${PKG_SYSCONFDIR}/mime.types
                     57: FILES_SUBST+=          DOCDIR=${DOCDIR}
                     58:
                     59: .if exists(${WRKSRC}/mutt_dotlock)
                     60: PLIST_SUBST+=          MUTT_DOTLOCK=
1.1       tron       61: .else
1.26      jlam       62: PLIST_SUBST+=          MUTT_DOTLOCK="@comment "
1.1       tron       63: .endif
1.26      jlam       64: INSTALL_MAKE_FLAGS=    ${MAKE_FLAGS} sysconfdir=${EGDIR}
1.1       tron       65:
1.26      jlam       66: .include "../../converters/libiconv/buildlink3.mk"
                     67: .include "../../devel/gettext-lib/buildlink3.mk"
1.5       jlam       68:
1.26      jlam       69: # Fix some absolute paths in installed files.
                     70: post-build:
                     71:        for file in ${WRKSRC}/contrib/gpg.rc; do                        \
                     72:                ${MV} -f $$file $$file.save;                            \
                     73:                ${SED}  -e "s,/usr/bin/gpg,gpg,g"                       \
                     74:                        $$file.save > $$file;                           \
                     75:        done
                     76:        for file in ${WRKSRC}/doc/mutt.man; do                          \
                     77:                ${MV} -f $$file $$file.save;                            \
                     78:                ${SED}  -e "s,/etc/,${PKG_SYSCONFDIR}/,g"               \
                     79:                        -e "s,/usr/local/doc/mutt/,${DOCDIR}/,g"        \
                     80:                        -e "s,/usr/local/,${PREFIX}/,g"                 \
                     81:                        $$file.save > $$file;                           \
                     82:        done
                     83:
                     84: # Pre-create some directories and symlinks used during the installation
                     85: # process.
                     86: #
                     87: pre-install:
                     88:        ${INSTALL_DATA_DIR} ${EGDIR}
                     89:        ${INSTALL_DATA_DIR} ${DOCDIR}
                     90:        ${RM} -f ${DOCDIR}/samples
                     91:        ${LN} -sf ${EGDIR} ${DOCDIR}/samples
1.5       jlam       92:
1.1       tron       93: .include "../../mk/bsd.pkg.mk"

CVSweb <webmaster@jp.NetBSD.org>