[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / mail / mutt-devel

Annotation of pkgsrc/mail/mutt-devel/Makefile, Revision 1.28

1.28    ! jlam        1: # $NetBSD: Makefile,v 1.27 2004/07/23 15:00:12 jlam Exp $
1.1       tron        2:
1.26      jlam        3: DISTNAME=              mutt-1.5.6i
1.14      tron        4: PKGNAME=               ${DISTNAME:C/i$//}
1.1       tron        5: CATEGORIES=            mail
1.26      jlam        6: MUTT_SITES=            ftp://ftp.mutt.org/mutt/ \
                      7:                        ftp://ftp.stealth.net/pub/mirrors/ftp.mutt.org/pub/mutt/ \
                      8:                        ftp://gd.tuwien.ac.at/infosys/mail/mutt/ \
                      9:                        ftp://ftp.fu-berlin.de/unix/mail/mutt/
                     10: MASTER_SITES=          ${MUTT_SITES:=devel/}
1.1       tron       11:
1.26      jlam       12: MAINTAINER=            jlam@NetBSD.org
1.1       tron       13: HOMEPAGE=              http://www.mutt.org/
1.26      jlam       14: COMMENT=               Text-based MIME mail client with PGP & S/MIME support
1.1       tron       15:
1.26      jlam       16: PKG_INSTALLATION_TYPES=        overwrite pkgviews
1.5       jlam       17:
1.26      jlam       18: .include "../../mk/bsd.prefs.mk"
1.5       jlam       19:
1.1       tron       20: WRKSRC=                        ${WRKDIR}/${DISTNAME:C/i$$//}
1.26      jlam       21: BUILD_USES_MSGFMT=     yes
                     22: USE_BUILDLINK3=                yes
                     23: USE_PKGLOCALEDIR=      yes
                     24: USE_PERL5=             yes
                     25: REPLACE_PERL=          smime_keys */*.pl
                     26:
                     27: GNU_CONFIGURE=         yes
                     28: CONFIGURE_ARGS+=       --sysconfdir=${PKG_SYSCONFDIR}                  \
                     29:                        --with-docdir=${PREFIX}/share/doc/mutt          \
                     30:                        --without-included-gettext                      \
                     31:                        --enable-pop                                    \
                     32:                        --enable-imap
1.1       tron       33:
1.26      jlam       34: .if (${OPSYS} == "SunOS")
                     35: CONFIGURE_ARGS+=       --without-wc-funcs
1.16      tron       36: .endif
                     37:
1.26      jlam       38: # There is a problem using /bin/sh on old NetBSD releases, so use /bin/ksh
                     39: # there.
                     40: #
                     41: .if !empty(MACHINE_PLATFORM:MNetBSD-1.[0-5]*-*)
1.5       jlam       42: CONFIGURE_ARGS+=       --with-exec-shell=/bin/ksh
1.1       tron       43: .endif
                     44:
1.28    ! jlam       45: .include "options.mk"
1.1       tron       46:
1.26      jlam       47: LDFLAGS+=              ${_STRIPFLAG_CC}
                     48:
                     49: USE_PKGINSTALL=                yes
                     50: DEINSTALL_EXTRA_TMPL=  ${.CURDIR}/INSTALL
                     51: INSTALL_EXTRA_TMPL=    ${.CURDIR}/INSTALL
                     52: DOCDIR=                        ${PREFIX}/share/doc/mutt
                     53: EGDIR=                 ${PREFIX}/share/examples/mutt
                     54: CONF_FILES=            ${EGDIR}/Muttrc ${PKG_SYSCONFDIR}/Muttrc
                     55: SUPPORT_FILES=         ${EGDIR}/mime.types ${PKG_SYSCONFDIR}/mime.types
                     56: FILES_SUBST+=          DOCDIR=${DOCDIR}
                     57:
                     58: .if exists(${WRKSRC}/mutt_dotlock)
                     59: PLIST_SUBST+=          MUTT_DOTLOCK=
1.1       tron       60: .else
1.26      jlam       61: PLIST_SUBST+=          MUTT_DOTLOCK="@comment "
1.1       tron       62: .endif
1.26      jlam       63: INSTALL_MAKE_FLAGS=    ${MAKE_FLAGS} sysconfdir=${EGDIR}
1.1       tron       64:
1.26      jlam       65: .include "../../converters/libiconv/buildlink3.mk"
                     66: .include "../../devel/gettext-lib/buildlink3.mk"
1.5       jlam       67:
1.26      jlam       68: # Fix some absolute paths in installed files.
                     69: post-build:
                     70:        for file in ${WRKSRC}/contrib/gpg.rc; do                        \
                     71:                ${MV} -f $$file $$file.save;                            \
                     72:                ${SED}  -e "s,/usr/bin/gpg,gpg,g"                       \
                     73:                        $$file.save > $$file;                           \
                     74:        done
                     75:        for file in ${WRKSRC}/doc/mutt.man; do                          \
                     76:                ${MV} -f $$file $$file.save;                            \
                     77:                ${SED}  -e "s,/etc/,${PKG_SYSCONFDIR}/,g"               \
                     78:                        -e "s,/usr/local/doc/mutt/,${DOCDIR}/,g"        \
                     79:                        -e "s,/usr/local/,${PREFIX}/,g"                 \
                     80:                        $$file.save > $$file;                           \
                     81:        done
                     82:
                     83: # Pre-create some directories and symlinks used during the installation
                     84: # process.
                     85: #
                     86: pre-install:
                     87:        ${INSTALL_DATA_DIR} ${EGDIR}
                     88:        ${INSTALL_DATA_DIR} ${DOCDIR}
                     89:        ${RM} -f ${DOCDIR}/samples
                     90:        ${LN} -sf ${EGDIR} ${DOCDIR}/samples
1.5       jlam       91:
1.1       tron       92: .include "../../mk/bsd.pkg.mk"

CVSweb <webmaster@jp.NetBSD.org>