[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / mail / maildrop

File: [cvs.NetBSD.org] / pkgsrc / mail / maildrop / Makefile (download)

Revision 1.35, Tue Mar 21 19:50:51 2006 UTC (18 years, 1 month ago) by jlam
Branch: MAIN
CVS Tags: pkgsrc-2006Q1-base, pkgsrc-2006Q1
Changes since 1.34: +2 -2 lines

Add a check for whether maildrop is invoked by courier or not before
doing courier-specific things, like accepting the values of certain
environment variables for things like location of the mail folder for
local delivery.  This addresses PR pkg/32369 in a way that still allows
for a future courier-mta package that just uses the maildrop package.

# $NetBSD: Makefile,v 1.35 2006/03/21 19:50:51 jlam Exp $

DISTNAME=	maildrop-2.0.1
PKGREVISION=	3
CATEGORIES=     security
MASTER_SITES=   ${MASTER_SITE_SOURCEFORGE:=courier/}
EXTRACT_SUFX=   .tar.bz2

MAINTAINER=	jlam@pkgsrc.org
COMMENT=	Courier mail delivery agent with filtering abilities
HOMEPAGE=	http://www.courier-mta.org/maildrop/

DEPENDS+=	courier-maildir>=0.52.1:../../mail/courier-maildir

USE_TOOLS+=		gmake
USE_LANGUAGES=		c c++
USE_LIBTOOL=		yes

PKG_SUPPORTED_OPTIONS=	authlib
PKG_SUGGESTED_OPTIONS=	authlib

# PKGNAME is a parameter to the following file.
PKGNAME=	${DISTNAME}
.include "../../mail/courier-maildir/Makefile.common"

.include "../../security/courier-authlib/Makefile.common"

# These are the users that may invoke maildrop with the "-d user"
# argument (mailbox delivery mode).
#
MAILDROP_TRUSTED_USERS?=	${ROOT_USER} ${COURIER_USER} qmaild

CONFIGURE_ARGS+=	--with-etcdir=${PKG_SYSCONFDIR:Q}
CONFIGURE_ARGS+=	--enable-maildirquota
CONFIGURE_ARGS+=	--enable-maildrop-uid=${ROOT_USER:Q}
CONFIGURE_ARGS+=	--enable-maildrop-gid=${COURIER_GROUP:Q}
CONFIGURE_ARGS+=	--enable-trusted-users=${MAILDROP_TRUSTED_USERS:Q}
CONFIGURE_ARGS+=	--enable-trusted-groups=${COURIER_GROUP:Q}
CONFIGURE_ARGS+=	--enable-syslog=1

.if !empty(PKG_OPTIONS:Mauthlib)
CONFIGURE_ARGS+=	--enable-authlib
.  include "../../security/courier-authlib/buildlink3.mk"
.else
CONFIGURE_ARGS+=	--disable-authlib
.endif

SPECIAL_PERMS=	bin/maildrop ${ROOT_USER} ${COURIER_GROUP} 4711

post-install:
	${INSTALL_DATA_DIR} ${DOCDIR}
	${INSTALL_DATA} ${WRKSRC}/README.postfix ${DOCDIR}
	${INSTALL_DATA} ${WRKSRC}/maildroptips.txt ${DOCDIR}

.include "../../devel/sysexits/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"