[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / mail / mail-notification

File: [cvs.NetBSD.org] / pkgsrc / mail / mail-notification / Attic / Makefile (download)

Revision 1.49, Tue Nov 10 20:33:38 2009 UTC (14 years, 5 months ago) by markd
Branch: MAIN
CVS Tags: pkgsrc-2009Q4-base, pkgsrc-2009Q4
Changes since 1.48: +20 -13 lines

Update mail-notification to 5.4

pkgsrc changes: patch to use gmime24

Changes since 5.3:
* The regression which caused some read IMAP messages to be reported as
  unread has been fixed.
* And more, see the NEWS file.
Changes since 5.2:
* A crash affecting IMAP, Maildir and POP3 mailboxes has been fixed.
* A crash affecting Evolution mailboxes on 64-bit systems has been fixed.
* And more, see the NEWS file.
Changes since 5.1:
* Default configuration values were not registered.
Changes since 5.0:
* A number of minor issues have been fixed. Most notably, the message
  count is now drawn properly.
* And more, see the NEWS file.

# $NetBSD: Makefile,v 1.49 2009/11/10 20:33:38 markd Exp $
#

DISTNAME=	mail-notification-5.4
CATEGORIES=	mail gnome
MASTER_SITES=	http://savannah.nongnu.org/download/mailnotify/
EXTRACT_SUFX=	.tar.bz2

MAINTAINER=	gdt@NetBSD.org
HOMEPAGE=	http://www.nongnu.org/mailnotify/
COMMENT=	Status icon that provides new mail notifications

PKG_DESTDIR_SUPPORT=	user-destdir

HAS_CONFIGURE=		YES
CONFIGURE_SCRIPT=	./jb configure
USE_TOOLS+=		gmake intltool msgfmt pkg-config
USE_PKGLOCALEDIR=	YES

CONFIGURE_ARGS=		prefix="${PREFIX}" destdir="${DESTDIR}" sysconfdir=${PKG_SYSCONFDIR:Q}
CONFIGURE_ARGS+=	cc="${CC}" cflags="${CFLAGS}" cppflags="${CPPFLAGS}" ldflags="${LDFLAGS}"
CONFIGURE_ENV+=		jb_cppflags="${CPPFLAGS}" jb_ldflags="${LDFLAGS}"

GCONF_SCHEMAS=		mail-notification.schemas

CONFIGURE_ARGS+=	evolution=no

PKG_OPTIONS_VAR=	PKG_OPTIONS.mail-notification
PKG_SUPPORTED_OPTIONS=	inet6 sasl ssl
PKG_SUGGESTED_OPTIONS=	ssl

.include "../../mk/bsd.options.mk"

# Whether to add IPv6 support.
.if empty(PKG_OPTIONS:Minet6)
CONFIGURE_ARGS+=	ipv6=no
.endif

# Whether to add SASL2 support.
.if !empty(PKG_OPTIONS:Msasl)
.  include "../../security/cyrus-sasl/buildlink3.mk"
.else
CONFIGURE_ARGS+=	sasl=no
.endif

# Whether to add SSL support.
.if !empty(PKG_OPTIONS:Mssl)
.  include "../../security/openssl/buildlink3.mk"
.else
CONFIGURE_ARGS+=	ssl=no
.endif

do-build:
	cd ${WRKSRC} && ./jb build

do-install:
	cd ${WRKSRC} && ./jb install

.include "../../devel/GConf/schemas.mk"
.include "../../devel/gettext-lib/buildlink3.mk"
.include "../../devel/glib2/buildlink3.mk"
.include "../../devel/libglade/buildlink3.mk"
.include "../../devel/libgnome/buildlink3.mk"
.include "../../devel/libgnomeui/buildlink3.mk"
.include "../../graphics/hicolor-icon-theme/buildlink3.mk"
.include "../../mail/gmime24/buildlink3.mk"
.include "../../sysutils/dbus-glib/buildlink3.mk"
.include "../../sysutils/gnome-vfs/buildlink3.mk"
.include "../../sysutils/libnotify/buildlink3.mk"
.include "../../mk/omf-scrollkeeper.mk"
.include "../../x11/gtk2/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"