[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / mail / mail-notification

File: [cvs.NetBSD.org] / pkgsrc / mail / mail-notification / Attic / Makefile (download)

Revision 1.26, Thu Apr 13 18:23:34 2006 UTC (18 years ago) by jlam
Branch: MAIN
Changes since 1.25: +2 -4 lines

BUILD_USE_MSGFMT and USE_MSGFMT_PLURALS are obsolete.  Replace with
USE_TOOLS+=msgfmt.

# $NetBSD: Makefile,v 1.26 2006/04/13 18:23:34 jlam Exp $
#

DISTNAME=	mail-notification-2.0
PKGREVISION=	7
CATEGORIES=	mail gnome
MASTER_SITES=	http://savannah.nongnu.org/download/mailnotify/

MAINTAINER=	gdt@NetBSD.org
HOMEPAGE=	http://www.nongnu.org/mailnotify/
COMMENT=	Status icon that provides new mail notifications

GNU_CONFIGURE=		YES
USE_DIRS+=		gnome2-1.5
USE_TOOLS+=		gmake msgfmt pkg-config
USE_PKGLOCALEDIR=	YES

CONFIGURE_ARGS+=	--sysconfdir=${PKG_SYSCONFDIR:Q}

GCONF2_SCHEMAS=		mail-notification.schemas

EGDIR=		${PREFIX}/share/examples/mail-notification
CONF_FILES=	${EGDIR}/sound/events/mail-notification.soundlist \
		${PKG_SYSCONFDIR}/sound/events/mail-notification.soundlist

PKG_OPTIONS_VAR=	PKG_OPTIONS.mail-notification
PKG_SUPPORTED_OPTIONS=	inet6 sasl ssl
PKG_SUGGESTED_OPTIONS=	ssl

.include "../../mk/bsd.options.mk"

# Whether to add IPv6 support.
.if empty(PKG_OPTIONS:Minet6)
CONFIGURE_ARGS+=	--disable-ipv6
.endif

# Whether to add SASL2 support.
.if !empty(PKG_OPTIONS:Msasl)
.  include "../../security/cyrus-sasl2/buildlink3.mk"
.else
CONFIGURE_ARGS+=	--disable-sasl
.endif

# Whether to add SSL support.
.if !empty(PKG_OPTIONS:Mssl)
.  include "../../security/openssl/buildlink3.mk"
.else
CONFIGURE_ARGS+=	--disable-ssl
.endif

.include "../../devel/eel2/buildlink3.mk"
.include "../../devel/GConf2/schemas.mk"
.include "../../devel/gettext-lib/buildlink3.mk"
.include "../../devel/glib2/buildlink3.mk"
.include "../../devel/libbonobo/buildlink3.mk"
.include "../../devel/libglade2/buildlink3.mk"
.include "../../devel/libgnomeui/buildlink3.mk"
.include "../../mail/gmime/buildlink3.mk"
.include "../../net/ORBit2/buildlink3.mk"
.include "../../sysutils/gnome-vfs2/buildlink3.mk"
.include "../../textproc/intltool/buildlink3.mk"
.include "../../textproc/scrollkeeper/omf.mk"
.include "../../x11/gtk2/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"