File:  [cvs.NetBSD.org] / pkgsrc / mail / im / Makefile
Revision 1.15: download - view: text, annotated - select for diffs
Wed Jun 8 19:23:55 2016 UTC (8 years, 6 months ago) by wiz
Branches: MAIN
CVS tags: pkgsrc-2016Q4-base, pkgsrc-2016Q4, pkgsrc-2016Q3-base, pkgsrc-2016Q3, pkgsrc-2016Q2-base, pkgsrc-2016Q2, HEAD
Bump PKGREVISION for perl-5.24.

# $NetBSD: Makefile,v 1.15 2016/06/08 19:23:55 wiz Exp $

DISTNAME=	im-152
PKGREVISION=	1
CATEGORIES=	mail
MASTER_SITES=	http://tats.haun.org/im/

MAINTAINER=	pkgsrc-users@NetBSD.org
HOMEPAGE=	http://tats.haun.org/im/
COMMENT=	E-Mail and NetNews user interface commands
LICENSE=	modified-bsd

GNU_CONFIGURE=	yes
USE_TOOLS+=	perl:run

CONFIGURE_ARGS+=	--sysconfdir=${PKG_SYSCONFBASEDIR}
CONFIGURE_ARGS+=	--with-perldir=${PREFIX}/${PERL5_SUB_INSTALLVENDORLIB}
CONFIGURE_ENV+=		im_path_perl=${PERL5:Q}

INSTALL_MAKE_FLAGS+=	sysconfdir=${PREFIX}/share/examples

PKG_SYSCONFSUBDIR=	im

CONF_FILES=	${PREFIX}/share/examples/im/SiteConfig ${PKG_SYSCONFDIR}/SiteConfig

DOCDIR=		${PREFIX}/share/doc/im
EXAMPLESDIR=	${PREFIX}/share/examples/im
DOCS=		00changes 00copyright 00copyright.jis 00perl 00readme 00usage
MAN=		imput
MAN_JA=		imali.jis imcat.jis imcd.jis imclean.jis imget.jis	\
		imhist.jis imjoin.jis immv.jis impack.jis imput.jis	\
		imrm.jis imsetup.jis imsort.jis imstore.jis imtar.jis

INSTALLATION_DIRS+=	${DOCDIR} ${EXAMPLESDIR} ${DOCDIR}/man ${DOCDIR}/man/ja

post-install:
.for file in ${DOCS}
	${INSTALL_DATA} ${WRKSRC}/${file} ${DESTDIR}${DOCDIR}
.endfor
.for file in ${MAN}
	${INSTALL_DATA} ${WRKSRC}/man/${file} ${DESTDIR}${DOCDIR}/man
.endfor
.for file in ${MAN_JA}
	${INSTALL_DATA} ${WRKSRC}/man/${file} ${DESTDIR}${DOCDIR}/man/ja
.endfor
	cp -r ${WRKSRC}/dot.im/* ${DESTDIR}${EXAMPLESDIR}

.include "../../lang/perl5/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

CVSweb <webmaster@jp.NetBSD.org>