[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / mail / ezmlm-idx

File: [cvs.NetBSD.org] / pkgsrc / mail / ezmlm-idx / Makefile (download)

Revision 1.5, Mon Jul 19 23:50:22 2004 UTC (19 years, 9 months ago) by schmonz
Branch: MAIN
Changes since 1.4: +33 -6 lines

Update ezmlm-idx to 0.421. From the changelog:

ezmlm-idx-0.421, 20040602
=========================
-Updated ezmlmrc.fr.  Thanks Jean-Marc Lasgouttes.
-Fixed bug in ezmlm-request when dealing with continuation lines.
 Thanks Sami Farin.
-Replaced many library with public-domain sources.
-Fixed "log" function conflicting with built-in math function.
-Fixed problem with "test -e" in makelang.sh for Solaris.
-Fixed typo bug in ezmlm-cron.
-Fixed uses of "head -#" and "tail -#" to "head -n #" and "tail -n #".

ezmlm-idx-0.42, 20040114 (New maintainer: Bruce Guenter <bruceg@em.ca>)
=======================================================================
-The ezmlmrc.* files were broken into two parts, to make them easier to
 write and maintain.  The language specific parts are stored in the
 "lang" subdirectory.
-Updated ezmlm-cgi to version 1.18, which includes the no banner
 security fix.
-Added ezmlmrc.hu.  Thanks Julian Severn-nek http://js.hu/
-Added ezmlmrc.nl.  Thanks Willem
-Fixed problem in ezmlm-send munging MIME attachments using implicit
 content types.  Thanks Ed
-Fixed typo in ezmlm-unsub -- manual unsubscriptions would be
 erroneously logged as "+manual"
-Fixed ezmlm-gate to handle the -Q option.  Thanks Bjoern Hansen.
-Fixed internal bug calling decodeHDR.
-Fix ezmlm-manage to properly send subscription confirmation to
moderators.  Thanks Mate Wierdl.
-Portability and bug fixes to ezmlm-test.
-Added a "dry-run" option to ezmlm-gate.
-Fixed ezmlm-send to fully handle QMQP relaying.  Thanks Bernhard Graf.
-Fixed ezmlm-gate to use "/bin/sh" consistently.  Thanks Bernhard Graf.
-Fixed ezmlm-cgi's output of non-standard port numbers.
-Fixed message archiving in subscribe-only moderated lists.

pkgsrc changes:

Set RESTRICTED directly in this package, rather than in
../ezmlm/Makefile.common, and clarify: in addition to the reasons
we cannot redistribute binary packages of ezmlm, ezmlm-idx is a
modification of the ezmlm source.

Set USE_BUILDLINK3=yes.

Introduce EZMLM_IDX_USE_{MY,PG}SQL. Each builds and runs, but I
haven't tested the database functions.

# $NetBSD: Makefile,v 1.5 2004/07/19 23:50:22 schmonz Exp $
#

.include "../../mail/ezmlm/Makefile.common"

DISTNAME=	ezmlm-idx-0.421
SITES_${DISTNAME}.tar.gz=	http://www.ezmlm.org/archive/0.421/

MAINTAINER=	tech-pkg@NetBSD.org
HOMEPAGE=	http://www.ezmlm.org/
COMMENT=	ezmlm with enhancements by third parties

CONFLICTS=	ezmlm-[0-9]*

DISTFILES+=	${EZMLM_VERS}.tar.gz
PLIST_SRC+=	PLIST.idx

USE_BUILDLINK3=	yes

# ezmlm-idx is a modification of the ezmlm source.
RESTRICTED=	"modified source and binaries may not be distributed"
NO_BIN_ON_CDROM=${RESTRICTED}
NO_BIN_ON_FTP=	${RESTRICTED}

USE_PKGINSTALL=	YES

PKG_SYSCONFSUBDIR=	ezmlm
CFLAGS+=	-DPKG_SYSCONFDIR=\"\\\"${PKG_SYSCONFDIR}\"\\\"

EGDIR=		${PREFIX}/share/examples/ezmlm-idx
CONF_FILES=	${EGDIR}/ezcgirc ${PKG_SYSCONFDIR}/ezcgirc
CONF_FILES+=	${EGDIR}/ezmlmrc ${PKG_SYSCONFDIR}/ezmlmrc

.include "../../mk/bsd.prefs.mk"

BUILD_DEFS+=	EZMLM_IDX_USE_MYSQL EZMLM_IDX_USE_PGSQL

.if !empty(EZMLM_IDX_USE_MYSQL:M[yY][eE][sS])
.include "../../databases/mysql-client/buildlink3.mk"
post-configure:
	${ECHO} -I${BUILDLINK_PREFIX.mysql-client}/include/mysql > ${WRKSRC}/sub_mysql/conf-sqlcc
	${ECHO} -L${BUILDLINK_PREFIX.mysql-client}/lib/mysql -Wl,-R${BUILDLINK_PREFIX.mysql-client}/lib/mysql -lmysqlclient > ${WRKSRC}/sub_mysql/conf-sqlld
	@cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${MAKE_PROGRAM} mysql
.endif

.if !empty(EZMLM_IDX_USE_PGSQL:M[yY][eE][sS])
.include "../../databases/postgresql-lib/buildlink3.mk"
post-configure:
	${ECHO} -I${BUILDLINK_PREFIX.postgresql-lib}/include > ${WRKSRC}/sub_pgsql/conf-sqlcc
	${ECHO} -L${BUILDLINK_PREFIX.postgresql-lib}/lib -Wl,-R${BUILDLINK_PREFIX.postgresql-lib}/lib -lpq > ${WRKSRC}/sub_pgsql/conf-sqlld
	@cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${MAKE_PROGRAM} pgsql
.endif

post-extract:
	@${MV} ${WRKSRC}/* ${WRKDIR}/${EZMLM_VERS}
	@${RMDIR} ${WRKSRC}
	@${MV} ${WRKDIR}/${EZMLM_VERS} ${WRKSRC}

pre-patch:
	@cd ${WRKSRC}; ${PATCH} ${PATCH_DIST_ARGS} < idx.patch

post-install:
	${INSTALL_DATA_DIR} ${EGDIR}
	${INSTALL_DATA} ${WRKSRC}/ezcgirc ${EGDIR}/ezcgirc
	${INSTALL_DATA} ${WRKSRC}/ezmlmrc ${EGDIR}/ezmlmrc
	${INSTALL_DATA} ${WRKSRC}/ezmlmglrc ${EGDIR}/ezmlmglrc
	${INSTALL_DATA} ${WRKSRC}/ezmlmsubrc ${EGDIR}/ezmlmsubrc

.include "../../mk/bsd.pkg.mk"