[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / mail / dovecot

File: [cvs.NetBSD.org] / pkgsrc / mail / dovecot / Attic / Makefile (download)

Revision 1.9, Sun Nov 2 17:24:07 2003 UTC (20 years, 4 months ago) by salo
Branch: MAIN
Changes since 1.8: +18 -16 lines

PKGREVISION++

- Some partial BODY[part] fetches may have returned data incorrectly,
  patch-ad fixes it.

- Add missing BUILD_DEFS, sort.

# $NetBSD: Makefile,v 1.9 2003/11/02 17:24:07 salo Exp $
#

DISTNAME=		dovecot-0.99.10
PKGREVISION=		3
CATEGORIES=		mail
MASTER_SITES=		http://dovecot.procontrol.fi/

PATCH_SITES=		${MASTER_SITES}
PATCHFILES=		auth-home.patch bodystructure.patch
PATCH_DIST_STRIP=	-p1

MAINTAINER=		tom@replic8.net
HOMEPAGE=		http://dovecot.procontrol.fi/
COMMENT=		Secure IMAP and POP3 server

USE_BUILDLINK2=		YES
USE_LIBTOOL=		YES
USE_PKGINSTALL= 	YES
GNU_CONFIGURE=		YES

LIBTOOL_OVERRIDE=	${WRKSRC}/libtool

CONFIGURE_ARGS+=	--sysconfdir=${PKG_SYSCONFDIR}
CONFIGURE_ARGS+=	--localstatedir=/var
CONFIGURE_ARGS+=	--with-ssldir=${SSLCERTS}

.include "../../mk/bsd.prefs.mk"

BUILD_DEFS+=		DOVECOT_USE_GNUTLS DOVECOT_USE_PGSQL	\
			USE_INET6 USE_OPENLDAP USE_SASL2

.if !empty(DOVECOT_USE_GNUTLS:M[Yy][Ee][Ss])
CONFIGURE_ARGS+=	--enable-ssl=gnutls
.include "../../security/gnutls/buildlink2.mk"
.else
CONFIGURE_ARGS+=        --enable-ssl=openssl
.include "../../security/openssl/buildlink2.mk"
.endif

.if !empty(DOVECOT_USE_PGSQL:M[Yy][Ee][Ss])
CONFIGURE_ARGS+=	--with-pgsql
CPPFLAGS=		-I${BUILDLINK_DIR}/include/pgsql
.include "../../databases/postgresql-lib/buildlink2.mk"
.endif

.if defined(USE_INET6) && !empty(USE_INET6:M[Yy][Ee][Ss])
CONFIGURE_ARGS+=	--enable-ipv6
.endif

.if !empty(USE_OPENLDAP:M[Yy][Ee][Ss])
CONFIGURE_ARGS+=	--with-ldap
.include "../../databases/openldap/buildlink2.mk"
.endif

.if defined(USE_SASL2) && !empty(USE_SASL2:M[Yy][Ee][Ss])
CONFIGURE_ARGS+=	--with-cyrus-sasl2
.include "../../security/cyrus-sasl2/buildlink2.mk"
.endif

RCD_SCRIPTS=	dovecot

DOVECOT_USER?=	dovecot
DOVECOT_GROUP?=	dovecot
PKG_GROUPS=	${DOVECOT_GROUP}
PKG_USERS=	${DOVECOT_USER}:${DOVECOT_GROUP}::Dovecot\\ IMAP/POP3\\ user

EGDIR=		${PREFIX}/share/examples/dovecot
CONF_FILES=	${EGDIR}/dovecot.conf.default ${PKG_SYSCONFDIR}/dovecot.conf

post-configure:
	@cd ${WRKSRC} &&						\
	(								\
		${MV} dovecot-example.conf dovecot-example.conf.orig;	\
		${SED} ${FILES_SUBST_SED} dovecot-example.conf.orig >	\
			dovecot-example.conf;				\
	)

post-install:
	${INSTALL_DATA_DIR} ${EGDIR}
	${INSTALL_DATA} ${WRKSRC}/dovecot-example.conf	\
		${EGDIR}/dovecot.conf.default
	${INSTALL_DATA} ${WRKSRC}/doc/dovecot-* ${EGDIR}
	${INSTALL_SCRIPT} ${WRKSRC}/doc/mkcert.sh ${EGDIR}

.include "../../mk/bsd.pkg.mk"