[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / mail / dovecot

File: [cvs.NetBSD.org] / pkgsrc / mail / dovecot / Attic / Makefile (download)

Revision 1.89, Wed Mar 14 14:14:52 2007 UTC (17 years ago) by ghen
Branch: MAIN
Changes since 1.88: +2 -2 lines

Update to dovecot-1.0rc26.  From the release announcement mail:

A few new small features and lots of index/mbox fixes. I've been heavily
stress testing this release, so I think it should be about perfect. :)

I think the only thing still missing from v1.0 is documentation. There
are some unwritten pages in the wiki, and I still haven't bothered to
write the wiki -> doc/*.txt conversion script. The script will probably
be pretty easy, but writing the docs can take a while.

	+ mbox and index file code handles silently out of quota/disk
	  space errors (maildir still has problems). They will give the user
	  a "Not enough disk space" error instead of flooding the log file.
	+ Added fsync_disable setting.
	+ mail-log plugin: Log the mailbox name, except if it's INBOX
	+ dovecot-auth: Added a lot more debug logging to passdbs and userdbs
	+ dovecot-auth: Added %c variable which expands to "secured" with
	  SSL/TLS/localhost.
	+ dovecot-auth: Added %m variable which expands to auth mechanism name
	- maildir++ quota: With ignore=box setting the quota was still updated
	  for the mailbox even though it was allowed to go over quota (but
	  quota recalculation ignored the box).
	- Index file handling fixes
	- mbox syncing fixes
	- Wrong endianess index files still weren't silently rebuilt
	- IMAP quota plugin: GETQUOTAROOT returned the mailbox name wrong the
	  namespace had a prefix or if its separator was non-default
	- IMAP: If client was appending multiple messages with MULTIAPPEND
	  and LITERAL+ extensions and one of the appends failed, Dovecot
	  treated the rest of the mail data as IMAP commands.
	- If mail was sent to client with sendfile() call, we could have
	  hanged the connection. This could happen only if mails were saved
	  with CR+LF linefeeds.

# $NetBSD: Makefile,v 1.89 2007/03/14 14:14:52 ghen Exp $

DISTNAME=		dovecot-1.0.rc27
PKGNAME=		${DISTNAME:S/.rc/rc/}
CATEGORIES=		mail
MASTER_SITES=		http://www.dovecot.org/releases/

MAINTAINER=		ghen@NetBSD.org
HOMEPAGE=		http://www.dovecot.org/
COMMENT=		Secure IMAP and POP3 server

PKG_INSTALLATION_TYPES=	overwrite pkgviews
PKG_DESTDIR_SUPPORT=	user-destdir

USE_LIBTOOL=		yes
GNU_CONFIGURE=		yes
USE_TOOLS+=		pkg-config

CONFIGURE_ARGS+=	--sysconfdir=${PKG_SYSCONFDIR:Q}
CONFIGURE_ARGS+=	--localstatedir=${VARBASE:Q}
CONFIGURE_ARGS+=	--with-ssldir=${SSLDIR:Q}

.include "../../mk/bsd.prefs.mk"
.include "options.mk"

RCD_SCRIPTS=		dovecot

DOVECOT_USER?=		dovecot
DOVECOT_GROUP?=		dovecot
PKG_GROUPS=		${DOVECOT_GROUP}
PKG_USERS=		${DOVECOT_USER}:${DOVECOT_GROUP}

PKG_GECOS.${DOVECOT_USER}=	Dovecot IMAP/POP3 user

EGDIR=			${PREFIX}/share/examples/dovecot
CONF_FILES=		${EGDIR}/dovecot.conf.default ${PKG_SYSCONFDIR}/dovecot.conf

INSTALLATION_DIRS=	libexec/dovecot sbin share/doc/dovecot		\
			share/examples/dovecot

SUBST_CLASSES+=		paths
SUBST_FILES.paths=	dovecot-example.conf
SUBST_SED.paths+=	-e 's,@PREFIX@,${PREFIX},g'
SUBST_STAGE.paths=	pre-configure

post-build:
	${SED} "s|/etc/ssl/|${SSLDIR}/|" ${WRKSRC}/dovecot-example.conf \
						> ${WRKDIR}/dovecot-example.conf
	${SED} "s|/etc/ssl|${SSLDIR}|" ${WRKSRC}/doc/mkcert.sh \
						> ${WRKDIR}/mkcert.sh

post-install:
	${INSTALL_DATA} ${WRKDIR}/dovecot-example.conf	\
		${DESTDIR}${EGDIR}/dovecot.conf.default
	${INSTALL_DATA} ${WRKSRC}/doc/dovecot-* ${DESTDIR}${EGDIR}
	${INSTALL_SCRIPT} ${WRKDIR}/mkcert.sh ${DESTDIR}${EGDIR}

.include "../../devel/zlib/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"