[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / mail / dovecot

File: [cvs.NetBSD.org] / pkgsrc / mail / dovecot / Attic / Makefile (download)

Revision 1.79, Mon Jan 22 17:58:50 2007 UTC (17 years, 1 month ago) by ghen
Branch: MAIN
Changes since 1.78: +2 -2 lines

Update to dovecot-1.0rc18.  From the release announcement mail:

I think we're quite near v1.0 now.

	* ACL plugin + Maildir: Moved dovecot-acl file from control directory
	  to maildir. To prevent accidents caused by this change, Dovecot
	  kills itself if it finds dovecot-acl file from the control directory.
	* When opening a maildir, check if tmp/'s atime is over 8h old. If it
	  is, delete files in it with ctime older than 36h. However if
	  atime - ctime > 36h, it means that there's nothing to be deleted and
	  the scanning isn't done. We update atime ourself if filesystem is
	  mounted with noatime.
	* base_dir doesn't need to be group-readable, don't force it.
	* mail_read_mmaped setting is deprecated and possibly broken. It's now
	  removed from dovecot-example.conf, but it still works for now.
	* Removed also umask setting from dovecot-example.conf since currently
	  it doesn't do what it's supposed to.

	+ Authentication cache caches now also userdb data.
	+ Added mail_log plugin to log various mail operations. Currently it
	  logs mail copies, deletions, expunges and mailbox deletions.
	- dict quota: messages=n parameter actually changed storage limit.
	- A lot of fixes to handling index files. This should fix almost all
	  of the problems ever reported.
	- LDAP: auth_bind=yes was more or less broken.
	- Saved mails and dovecot-keywords file didn't set the group from
	  dovecot-shared file.
	- Fixed potential assert-crash while searching messages
	- Fixed some crashes with invalid X-UID headers in mboxes
	- If you didn't have a namespace with empty prefix, giving STATUS
	  command for a non-existing namespace caused the connection to give
	  "NO Unknown namespace" errors for all the future commands.

# $NetBSD: Makefile,v 1.79 2007/01/22 17:58:50 ghen Exp $

DISTNAME=		dovecot-1.0.rc18
PKGNAME=		${DISTNAME:S/.rc/rc/}
CATEGORIES=		mail
MASTER_SITES=		http://www.dovecot.org/releases/

MAINTAINER=		ghen@NetBSD.org
HOMEPAGE=		http://www.dovecot.org/
COMMENT=		Secure IMAP and POP3 server

PKG_INSTALLATION_TYPES=	overwrite pkgviews
PKG_DESTDIR_SUPPORT=	user-destdir

USE_LIBTOOL=		yes
GNU_CONFIGURE=		yes
USE_TOOLS+=		pkg-config

CONFIGURE_ARGS+=	--sysconfdir=${PKG_SYSCONFDIR:Q}
CONFIGURE_ARGS+=	--localstatedir=${VARBASE:Q}
CONFIGURE_ARGS+=	--with-ssldir=${SSLDIR:Q}

.include "../../mk/bsd.prefs.mk"
.include "options.mk"

RCD_SCRIPTS=		dovecot

DOVECOT_USER?=		dovecot
DOVECOT_GROUP?=		dovecot
PKG_GROUPS=		${DOVECOT_GROUP}
PKG_USERS=		${DOVECOT_USER}:${DOVECOT_GROUP}

PKG_GECOS.${DOVECOT_USER}=	Dovecot IMAP/POP3 user

EGDIR=			${PREFIX}/share/examples/dovecot
CONF_FILES=		${EGDIR}/dovecot.conf.default ${PKG_SYSCONFDIR}/dovecot.conf

INSTALLATION_DIRS=	libexec/dovecot sbin share/doc/dovecot		\
			share/examples/dovecot

SUBST_CLASSES+=		paths
SUBST_FILES.paths=	dovecot-example.conf
SUBST_SED.paths+=	-e 's,@PREFIX@,${PREFIX},g'
SUBST_STAGE.paths=	pre-configure

post-build:
	${SED} "s|/etc/ssl/|${SSLDIR}/|" ${WRKSRC}/dovecot-example.conf \
						> ${WRKDIR}/dovecot-example.conf
	${SED} "s|/etc/ssl|${SSLDIR}|" ${WRKSRC}/doc/mkcert.sh \
						> ${WRKDIR}/mkcert.sh

post-install:
	${INSTALL_DATA} ${WRKDIR}/dovecot-example.conf	\
		${DESTDIR}${EGDIR}/dovecot.conf.default
	${INSTALL_DATA} ${WRKSRC}/doc/dovecot-* ${DESTDIR}${EGDIR}
	${INSTALL_SCRIPT} ${WRKDIR}/mkcert.sh ${DESTDIR}${EGDIR}

.include "../../devel/zlib/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"