[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / mail / dovecot

File: [cvs.NetBSD.org] / pkgsrc / mail / dovecot / Attic / Makefile (download)

Revision 1.68, Mon Oct 9 19:06:57 2006 UTC (17 years, 5 months ago) by ghen
Branch: MAIN
Changes since 1.67: +2 -2 lines

Update to dovecot-1.orc8.  From the release announcement mail:

I've still over 200 mails unread in the mailing list, and important
things left in TODO. This release is an improvement over rc7 anyway,
hopefully I'll have time to fix the rest soon.

	* GSSAPI: Changed POP3 service name to "pop", which is what the
	  standard says
	* "mbox:/var/mail/%u" no longer works as the mail location. You'll
	  have to specify the mail root explicitly, just like the examples
	  always have: "mbox:~/mail:INBOX=/var/mail/%u"

	+ SHA1, LDAP-MD5, PLAIN-MD5, PLAIN-MD4: The password can be now either
	  hex or base64 encoded. The encoding is detected automatically based
	  on the password string length.
	+ Allow running only Dovecot master and dovecot-auth processes with
	  protocols=none setting
	+ deliver: -f <envelope sender> parameter can be used to set mbox
	  From_-line's sender address
	+ deliver: Log all mail saves and failures
	+ Tru64 SIA passdb support. Patch by Simon L Jackson.
	- INBOX was listed twice in mailbox list if namespace prefix was used
	- INBOX-prefixed namespaces were a bit broken
	- kqueue: Fix 100% CPU usage
	- deliver: Duplicate storage was a bit broken
	- dictionary code was broken (ie. dict quota)
	- SIGHUP caused crashes sometimes

# $NetBSD: Makefile,v 1.68 2006/10/09 19:06:57 ghen Exp $

DISTNAME=		dovecot-1.0.rc8
PKGNAME=		${DISTNAME:S/.rc/rc/}
CATEGORIES=		mail
MASTER_SITES=		http://www.dovecot.org/releases/

MAINTAINER=		ghen@NetBSD.org
HOMEPAGE=		http://www.dovecot.org/
COMMENT=		Secure IMAP and POP3 server

PKG_INSTALLATION_TYPES=	overwrite pkgviews

USE_LIBTOOL=		yes
GNU_CONFIGURE=		yes
USE_TOOLS+=		pkg-config

CONFIGURE_ARGS+=	--sysconfdir=${PKG_SYSCONFDIR:Q}
CONFIGURE_ARGS+=	--localstatedir=${VARBASE:Q}
CONFIGURE_ARGS+=	--with-ssldir=${SSLDIR:Q}

.include "../../mk/bsd.prefs.mk"
.include "options.mk"

RCD_SCRIPTS=		dovecot

DOVECOT_USER?=		dovecot
DOVECOT_GROUP?=		dovecot
PKG_GROUPS=		${DOVECOT_GROUP}
PKG_USERS=		${DOVECOT_USER}:${DOVECOT_GROUP}

PKG_GECOS.${DOVECOT_USER}=	Dovecot IMAP/POP3 user

EGDIR=			${PREFIX}/share/examples/dovecot
CONF_FILES=		${EGDIR}/dovecot.conf.default ${PKG_SYSCONFDIR}/dovecot.conf

INSTALLATION_DIRS=	libexec/dovecot sbin share/doc/dovecot		\
			share/examples/dovecot

SUBST_CLASSES+=		paths
SUBST_FILES.paths=	dovecot-example.conf
SUBST_SED.paths+=	-e 's,@PREFIX@,${PREFIX},g'
SUBST_STAGE.paths=	pre-configure

post-build:
	${SED} "s|/etc/ssl/|${SSLDIR}/|" ${WRKSRC}/dovecot-example.conf \
						> ${WRKDIR}/dovecot-example.conf
	${SED} "s|/etc/ssl|${SSLDIR}|" ${WRKSRC}/doc/mkcert.sh \
						> ${WRKDIR}/mkcert.sh

post-install:
	${INSTALL_DATA_DIR} ${EGDIR}
	${INSTALL_DATA} ${WRKDIR}/dovecot-example.conf	\
		${EGDIR}/dovecot.conf.default
	${INSTALL_DATA} ${WRKSRC}/doc/dovecot-* ${EGDIR}
	${INSTALL_SCRIPT} ${WRKDIR}/mkcert.sh ${EGDIR}

.include "../../devel/zlib/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"