[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / mail / dovecot

File: [cvs.NetBSD.org] / pkgsrc / mail / dovecot / Attic / Makefile (download)

Revision 1.145, Fri Apr 30 10:43:26 2010 UTC (13 years, 10 months ago) by ghen
Branch: MAIN
Changes since 1.144: +3 -2 lines

Update the Pigeonhole Sieve plugin to 0.1.16, bump dovecot's PKGREVISION.

The main thing that this new release adds is full support for the spamtest,
spamtestplus and virustest extensions. These extensions implement a uniform
means of testing the content spam/virus status headers in mail messages:

  http://ietfreport.isoc.org/idref/rfc5235/

Not many people have tested these new features yet and therefore these are
currently considered experimental. Test these thoroughly before you start using
them! Documentation is available in share/doc/dovecot/spamtest-virustest.txt

Changelog Sieve v0.1.16:

   * Finished implementation of spamtest, spamtestplus and virustest
     extensions. These are not enabled by default and need to be
     activated with the sieve_extensions setting. Documentation available
     in doc/spamtest-virustest.txt
   + Vacation extension: the from address of the generated reply is now
     by default equal to whatever known recipient alias matched the
     headers of the message. If it is one of the aliases specified with
     :addresses, it is used in stead of the envelope recipient address
     that was used before.
   + Restructured and optimized the lexical scanner.
   + Added --with-docs configure option to allow disabling installation
     of documentation.
   - Accidentally omitted 'extern' in two declarations of global
     variables in header files, causing compile failures on certain
     systems.
   - Deprecated imapflags extension: fixed implicit assignment of flags.
     Turns out this never really worked, but the effect of this bug was
     obscured by the removeflag bug fixed in the previous release.
   - Fixed various memset argument mixups in enotify extension. This
     caused warnings on certain systems, but luckily no adverse effects
     at runtime.

# $NetBSD: Makefile,v 1.145 2010/04/30 10:43:26 ghen Exp $

DOVECOT_VERSION=	1.2
DOVECOT_SUBVERSION=	.11
PKGREVISION=		1
SIEVE_VERSION=		0.1.16
MANAGESIEVE_VERSION=	0.11.11
DISTNAME=		dovecot-${DOVECOT_VERSION}${DOVECOT_SUBVERSION}
CATEGORIES=		mail
MASTER_SITES=		http://www.dovecot.org/releases/${DOVECOT_VERSION}/
DOVECOT_SIEVE_SITES=	http://www.rename-it.nl/dovecot/${DOVECOT_VERSION}/

MANAGESIEVE_PATCH=			dovecot-${DOVECOT_VERSION}${DOVECOT_SUBVERSION}-managesieve-${MANAGESIEVE_VERSION}.diff.gz
SITES.${MANAGESIEVE_PATCH}=	${DOVECOT_SIEVE_SITES}
PATCH_DIST_STRIP.${MANAGESIEVE_PATCH}=	-p1

MAINTAINER=		ghen@NetBSD.org
HOMEPAGE=		http://www.dovecot.org/
COMMENT=		Secure IMAP and POP3 server
LICENSE=		mit AND gnu-lgpl-v2.1 AND modified-bsd

PKG_INSTALLATION_TYPES=	overwrite pkgviews
PKG_DESTDIR_SUPPORT=	user-destdir

USE_LIBTOOL=		yes
GNU_CONFIGURE=		yes
USE_TOOLS+=		pkg-config
USE_TOOLS+=		rpcgen

CONFIGURE_ARGS+=	--sysconfdir=${PKG_SYSCONFDIR}
CONFIGURE_ARGS+=	--localstatedir=${VARBASE}
CONFIGURE_ARGS+=	--with-ssldir=${SSLDIR}
CONFIGURE_ARGS+=	--enable-header-install

.include "../../mk/bsd.prefs.mk"
.include "options.mk"

RCD_SCRIPTS=		dovecot

DOVECOT_USER?=		dovecot
DOVECOT_GROUP?=		dovecot
PKG_GROUPS=		${DOVECOT_GROUP}
PKG_USERS=		${DOVECOT_USER}:${DOVECOT_GROUP}
PKG_GROUPS_VARS+=	DOVECOT_GROUP
PKG_USERS_VARS+=	DOVECOT_USER

PKG_GECOS.${DOVECOT_USER}=	Dovecot IMAP/POP3 user

EGDIR=			${PREFIX}/share/examples/dovecot
CONF_FILES=		${EGDIR}/dovecot-example.conf ${PKG_SYSCONFDIR}/dovecot.conf

INSTALLATION_DIRS=	libexec/dovecot sbin share/doc/dovecot		\
			share/examples/dovecot

SUBST_CLASSES+=		paths
SUBST_FILES.paths=	dovecot-example.conf
SUBST_SED.paths+=	-e 's,@PREFIX@,${PREFIX},g'
SUBST_STAGE.paths=	pre-configure

BUILD_DEFS+=		VARBASE

post-build:
	${SED} "s|/etc/ssl/|${SSLDIR}/|" ${WRKSRC}/dovecot-example.conf \
						> ${WRKDIR}/dovecot-example.conf
	${SED} "s|/etc/ssl|${SSLDIR}|" ${WRKSRC}/doc/mkcert.sh \
						> ${WRKDIR}/mkcert.sh
.if !empty(PKG_OPTIONS:Mdovecot-sieve)
# We need dovecot built in order to be able to configure sieve.
	cd ${WRKSRC.sieve} \
	&& env ${CONFIGURE_ENV} ${CONFIGURE_SCRIPT} ${CONFIGURE_ARGS} ${CONFIGURE_ARGS.sieve}
	cd ${WRKSRC.sieve} \
	&& env ${MAKE_ENV} ${MAKE_PROGRAM} ${BUILD_MAKE_FLAGS} -f ${MAKE_FILE} ${BUILD_TARGET}
.endif
.if !empty(PKG_OPTIONS:Mdovecot-managesieve)
# Wee need sieve built in order to configure and build managesieve. Sigh.
	cd ${WRKSRC.managesieve} \
	&& env ${CONFIGURE_ENV} ${CONFIGURE_SCRIPT} ${CONFIGURE_ARGS} ${CONFIGURE_ARGS.managesieve}
	cd ${WRKSRC.managesieve} \
	&& env ${MAKE_ENV} ${MAKE_PROGRAM} ${BUILD_MAKE_FLAGS} -f ${MAKE_FILE} ${BUILD_TARGET}
.endif

post-install:
	${INSTALL_DATA} ${WRKDIR}/dovecot-example.conf ${DESTDIR}${EGDIR}
	${INSTALL_DATA} ${WRKSRC}/doc/dovecot-* ${DESTDIR}${EGDIR}
	${INSTALL_SCRIPT} ${WRKDIR}/mkcert.sh ${DESTDIR}${EGDIR}
	${INSTALL_DATA} ${WRKSRC}/src/lib/liblib.a ${DESTDIR}${PREFIX}/lib/dovecot

.include "../../devel/zlib/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"