[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / mail / dovecot

File: [cvs.NetBSD.org] / pkgsrc / mail / dovecot / Attic / Makefile (download)

Revision 1.117, Sun Jun 22 17:41:23 2008 UTC (15 years, 8 months ago) by ghen
Branch: MAIN
Changes since 1.116: +4 -3 lines

Update to Dovecot 1.1.1.  Beta's and RC's have been tracked in pkgsrc-wip,
copy from there.

Update the Sieve plugin accordingly to 1.1.5.

Major changes since 1.0:

	* After Dovecot v1.1 has modified index or dovecot-uidlist files,
	  they can't be opened anymore with Dovecot versions earlier than
	  v1.0.2.
	* See doc/wiki/Upgrading.1.1.txt (or for latest changes,
	  http://wiki.dovecot.org/Upgrading/1.1) for list of changes since
	  v1.0 that you should be aware of when upgrading.

	+ IMAP: Added support for UIDPLUS and LIST-EXTENDED extensions.
	+ IMAP SORT: Sort keys are indexed, which makes SORT commands faster.
	+ When saving messages, update cache file immediately with the data
	  that we expect client to fetch later.
	+ NFS caches are are flushed whenever needed. See mail_nfs_storage and
	  mail_nfs_index settings.
	+ Out of order command execution (SEARCH, FETCH, LIST), nonstandard
	  command cancellation (X-CANCEL <tag>)
	+ IMAP: STATUS-IN-LIST draft implementation
	+ Expire plugin can be used to keep track of oldest messages in
	  specific mailboxes. A nightly run can then quickly expunge old
	  messages from the mailboxes that have them. The tracking is done
	  using lib-dict, so you can use either Berkeley DB or SQL database.
	+ Namespaces are supported everywhere now.
	+ Namespaces have new list and subscriptions settings.
	+ Full text search indexing support with Lucene and Squat backends.
	+ OTP and S/KEY authentication mechanisms (by Andrey Panin).
	+ mbox and Maildir works with both Maildir++ and FS layouts. You can
	  change these by appending :LAYOUT=3Dmaildir++ or :LAYOUT=3Dfs to
	  mail_location.
	+ LDAP: Support templates in pass_attrs and user_attrs
	+ Support for listening in multiple IPs/ports.
	+ Quota plugin rewrite: Support for multiple quota roots, warnings,
	  allow giving storage size in bytes or kilo/mega/giga/terabytes,
	  per-mailbox quota rules.
	+ Filesystem quota backend supports inode limits, group quota and
	  RPC quota for NFS.
	+ SEARCH and SORT finally compare non-ASCII characters
	  case-insensitively. We use i;unicode-casemap algorithm.
	+ Config files support splitting values to multiple lines with \

# $NetBSD: Makefile,v 1.117 2008/06/22 17:41:23 ghen Exp $

DISTNAME=		dovecot-1.1.1
CATEGORIES=		mail
MASTER_SITES=		http://www.dovecot.org/releases/1.1/

MAINTAINER=		ghen@NetBSD.org
HOMEPAGE=		http://www.dovecot.org/
COMMENT=		Secure IMAP and POP3 server

PKG_INSTALLATION_TYPES=	overwrite pkgviews
PKG_DESTDIR_SUPPORT=	user-destdir

USE_LIBTOOL=		yes
GNU_CONFIGURE=		yes
USE_TOOLS+=		pkg-config
USE_TOOLS+=		rpcgen

CONFIGURE_ARGS+=	--sysconfdir=${PKG_SYSCONFDIR:Q}
CONFIGURE_ARGS+=	--localstatedir=${VARBASE:Q}
CONFIGURE_ARGS+=	--with-ssldir=${SSLDIR:Q}
CONFIGURE_ARGS+=	--enable-header-install

.include "../../mk/bsd.prefs.mk"
.include "options.mk"

RCD_SCRIPTS=		dovecot

DOVECOT_USER?=		dovecot
DOVECOT_GROUP?=		dovecot
PKG_GROUPS=		${DOVECOT_GROUP}
PKG_USERS=		${DOVECOT_USER}:${DOVECOT_GROUP}
PKG_GROUPS_VARS+=	DOVECOT_GROUP
PKG_USERS_VARS+=	DOVECOT_USER

PKG_GECOS.${DOVECOT_USER}=	Dovecot IMAP/POP3 user

EGDIR=			${PREFIX}/share/examples/dovecot
CONF_FILES=		${EGDIR}/dovecot-example.conf ${PKG_SYSCONFDIR}/dovecot.conf

INSTALLATION_DIRS=	libexec/dovecot sbin share/doc/dovecot		\
			share/examples/dovecot

SUBST_CLASSES+=		paths
SUBST_FILES.paths=	dovecot-example.conf
SUBST_SED.paths+=	-e 's,@PREFIX@,${PREFIX},g'
SUBST_STAGE.paths=	pre-configure

BUILD_DEFS+=		VARBASE

post-build:
	${SED} "s|/etc/ssl/|${SSLDIR}/|" ${WRKSRC}/dovecot-example.conf \
						> ${WRKDIR}/dovecot-example.conf
	${SED} "s|/etc/ssl|${SSLDIR}|" ${WRKSRC}/doc/mkcert.sh \
						> ${WRKDIR}/mkcert.sh

post-install:
	${INSTALL_DATA} ${WRKDIR}/dovecot-example.conf ${DESTDIR}${EGDIR}
	${INSTALL_DATA} ${WRKSRC}/doc/dovecot-* ${DESTDIR}${EGDIR}
	${INSTALL_SCRIPT} ${WRKDIR}/mkcert.sh ${DESTDIR}${EGDIR}
	${INSTALL_DATA} ${WRKSRC}/src/lib/liblib.a ${DESTDIR}${PREFIX}/lib/dovecot

.include "../../devel/zlib/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"