[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / mail / dovecot

Annotation of pkgsrc/mail/dovecot/Makefile, Revision 1.19

1.19    ! cube        1: # $NetBSD: Makefile,v 1.18 2004/05/28 22:20:42 xtraeme Exp $
1.1       salo        2:
1.18      xtraeme     3: DISTNAME=              dovecot-0.99.10.5
1.19    ! cube        4: PKGREVISION=           1
1.6       salo        5: CATEGORIES=            mail
1.12      salo        6: MASTER_SITES=          http://dovecot.fi/
1.1       salo        7:
1.11      xtraeme     8: PATCH_SITES=           http://www.roughtrade.net/dovecot/
1.19    ! cube        9: PATCHFILES=            dovecot-crammd5-0.99.10.5.diff
1.6       salo       10: PATCH_DIST_STRIP=      -p1
1.1       salo       11:
1.6       salo       12: MAINTAINER=            tom@replic8.net
1.12      salo       13: HOMEPAGE=              http://dovecot.fi/
1.6       salo       14: COMMENT=               Secure IMAP and POP3 server
                     15:
1.13      jlam       16: USE_BUILDLINK3=                YES
1.6       salo       17: USE_LIBTOOL=           YES
                     18: USE_PKGINSTALL=        YES
                     19: GNU_CONFIGURE=         YES
1.1       salo       20:
                     21: CONFIGURE_ARGS+=       --sysconfdir=${PKG_SYSCONFDIR}
                     22: CONFIGURE_ARGS+=       --localstatedir=/var
1.7       xtraeme    23: CONFIGURE_ARGS+=       --with-ssldir=${SSLCERTS}
1.1       salo       24:
1.16      snj        25: # Avoid an ICE in gcc2 on sparc64
                     26: CONFIGURE_ENV+=                F77=${FALSE}
                     27:
1.4       salo       28: .include "../../mk/bsd.prefs.mk"
                     29:
1.18      xtraeme    30: BUILD_DEFS+=           DOVECOT_USE_GNUTLS DOVECOT_USE_MYSQL \
                     31:                        DOVECOT_USE_PGSQL USE_INET6 USE_OPENLDAP USE_SASL2
1.1       salo       32:
                     33: .if !empty(DOVECOT_USE_GNUTLS:M[Yy][Ee][Ss])
                     34: CONFIGURE_ARGS+=       --enable-ssl=gnutls
1.13      jlam       35: .  include "../../security/gnutls/buildlink3.mk"
1.1       salo       36: .else
                     37: CONFIGURE_ARGS+=        --enable-ssl=openssl
1.13      jlam       38: .  include "../../security/openssl/buildlink3.mk"
1.1       salo       39: .endif
                     40:
1.18      xtraeme    41: .if !empty(DOVECOT_USE_MYSQL:M[Yy][Ee][SS])
                     42: CONFIGURE_ARGS+=       --with-mysql
                     43: .  include "../../databases/mysql4-client/buildlink3.mk"
                     44: .endif
                     45:
1.1       salo       46: .if !empty(DOVECOT_USE_PGSQL:M[Yy][Ee][Ss])
                     47: CONFIGURE_ARGS+=       --with-pgsql
                     48: CPPFLAGS=              -I${BUILDLINK_DIR}/include/pgsql
1.13      jlam       49: .  include "../../databases/postgresql-lib/buildlink3.mk"
1.9       salo       50: .endif
                     51:
                     52: .if defined(USE_INET6) && !empty(USE_INET6:M[Yy][Ee][Ss])
                     53: CONFIGURE_ARGS+=       --enable-ipv6
                     54: .endif
                     55:
                     56: .if !empty(USE_OPENLDAP:M[Yy][Ee][Ss])
                     57: CONFIGURE_ARGS+=       --with-ldap
1.13      jlam       58: .  include "../../databases/openldap/buildlink3.mk"
1.9       salo       59: .endif
                     60:
                     61: .if defined(USE_SASL2) && !empty(USE_SASL2:M[Yy][Ee][Ss])
                     62: CONFIGURE_ARGS+=       --with-cyrus-sasl2
1.13      jlam       63: .  include "../../security/cyrus-sasl2/buildlink3.mk"
1.1       salo       64: .endif
                     65:
                     66: RCD_SCRIPTS=   dovecot
                     67:
                     68: DOVECOT_USER?= dovecot
                     69: DOVECOT_GROUP?=        dovecot
                     70: PKG_GROUPS=    ${DOVECOT_GROUP}
                     71: PKG_USERS=     ${DOVECOT_USER}:${DOVECOT_GROUP}::Dovecot\\ IMAP/POP3\\ user
                     72:
                     73: EGDIR=         ${PREFIX}/share/examples/dovecot
                     74: CONF_FILES=    ${EGDIR}/dovecot.conf.default ${PKG_SYSCONFDIR}/dovecot.conf
                     75:
                     76: post-configure:
1.13      jlam       77:        @cd ${WRKSRC};                                                  \
                     78:        for file in dovecot-example.conf; do                            \
                     79:                ${SED} ${FILES_SUBST_SED} $$file > $$file.new;          \
                     80:                ${MV} -f $$file.new $$file;                             \
                     81:        done
1.1       salo       82:
                     83: post-install:
                     84:        ${INSTALL_DATA_DIR} ${EGDIR}
                     85:        ${INSTALL_DATA} ${WRKSRC}/dovecot-example.conf  \
                     86:                ${EGDIR}/dovecot.conf.default
                     87:        ${INSTALL_DATA} ${WRKSRC}/doc/dovecot-* ${EGDIR}
                     88:        ${INSTALL_SCRIPT} ${WRKSRC}/doc/mkcert.sh ${EGDIR}
                     89:
                     90: .include "../../mk/bsd.pkg.mk"

CVSweb <webmaster@jp.NetBSD.org>