File:  [cvs.NetBSD.org] / pkgsrc / mail / dbmail / Makefile
Revision 1.76: download - view: text, annotated - select for diffs
Sat Oct 29 15:48:59 2022 UTC (2 years, 2 months ago) by tnn
Branches: MAIN
CVS tags: HEAD
dbmail: update to 3.3.1

3.3.1:
  MySQL 8 is supported and fixes an issue with 8.0.31 and libzdb
3.3.0:
  This release bumps gmime to version 3.0 (3.2), all other requirements
    are the same.
3.2.6:
  The maintenance(dbmail-util) process should be issued in a maintenance
    window do to massive changes on database
  compatibility compiler standard was raised to C17
 Added
  IMAP Daemon: added switch to control the sequence update strategy
  IMAP Daemon: added switch to control the sync between DELETE flag and
    the actual state of the message (deleted)
  Build: automatic installation script (v 0.5)
  Maintenance(dbmail-util): added option to upgrade to
    utf8mb4(MariaDB/MySQL)
 Optimizations
  IMAP: optimizing differential state
+ bugfixes

# $NetBSD: Makefile,v 1.76 2022/10/29 15:48:59 tnn Exp $

DISTNAME=	dbmail-3.3.1
CATEGORIES=	mail
MASTER_SITES=	${MASTER_SITE_GITHUB:=dbmail/}
GITHUB_TAG=	v${PKGVERSION_NOREV}

MAINTAINER=	pkgsrc-users@NetBSD.org
HOMEPAGE=	https://github.com/dbmail/dbmail
COMMENT=	Store and retrieve mail messages in a database
LICENSE=	gnu-gpl-v2

USE_TOOLS+=		gmake pkg-config pax
USE_LIBTOOL=		yes
USE_PKGLOCALEDIR=	yes
GNU_CONFIGURE=		yes
CONFIGURE_ARGS+=	--with-logdir=${VARBASE}/log
CONFIGURE_ARGS+=	--sysconfdir=${PKG_SYSCONFDIR}
CONFIGURE_ARGS+=	--localstatedir=${VARBASE}/run
CONFIGURE_ARGS+=	--with-zdb=${BUILDLINK_PREFIX.libzdb}

BUILD_DEFS+=		VARBASE

EGDIR=			${PREFIX}/share/examples/dbmail
CONF_FILES_PERMS+=	${EGDIR}/dbmail.conf ${PKG_SYSCONFDIR}/dbmail.conf \
			  ${REAL_ROOT_USER} ${REAL_ROOT_GROUP} 0640
RCD_SCRIPTS=		dbmail dbmailimapd dbmaillmtpd dbmailpop3d
DATADIR=		${PREFIX}/share/dbmail

MESSAGE_SUBST+=		DATADIR=${DATADIR}

SUBST_CLASSES+=		sysconf
SUBST_STAGE.sysconf=	do-configure
SUBST_FILES.sysconf=	man/commonopts.txt
SUBST_SED.sysconf=	-e 's|/etc/dbmail\.conf|${PKG_SYSCONFDIR}/dbmail.conf|g'
SUBST_MESSAGE.sysconf=	Fixing sysconf paths.

INSTALLATION_DIRS=	lib ${PKGMANDIR}/man1 ${PKGMANDIR}/man5 ${PKGMANDIR}/man8 sbin ${EGDIR} ${DATADIR}/sql

post-install:
	${INSTALL_DATA} ${WRKSRC}/dbmail.conf ${DESTDIR}${EGDIR}
.for f in mysql postgresql sqlite
	cd ${WRKSRC}/sql && pax -rw ${f} ${DESTDIR}${DATADIR}/sql/.
.endfor

.include "options.mk"

.include "../../databases/libzdb/buildlink3.mk"
BUILDLINK_API_DEPENDS.glib2+=	glib2>=2.8.0
.include "../../devel/glib2/buildlink3.mk"
.include "../../devel/libevent/buildlink3.mk"
.include "../../mail/gmime3/buildlink3.mk"
.include "../../security/mhash/buildlink3.mk"
.include "../../security/openssl/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

CVSweb <webmaster@jp.NetBSD.org>