[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / mail / claws-mail-pgpinline

File: [cvs.NetBSD.org] / pkgsrc / mail / claws-mail-pgpinline / Makefile (download)

Revision 1.62, Thu Nov 8 07:29:36 2018 UTC (5 years, 5 months ago) by markd
Branch: MAIN
Changes since 1.61: +1 -2 lines

claws-mail: update to 3.17.1

* 3.17.1
--------

* bug fixes:

* 3.17.0
--------

* the minimum GLib requirement is now 2.28.

* the mimimum GTK+2 requirement is now  2.24.

* nettle is now required, following removal of libcrypt from glibc.

* explicit use of --disable-gnutls is now required if gnuTLS support
  is not required.

* SOCKS proxy support has been added.
  Global settings can be found on the Mail Handling/Proxy page.
  This can be overridden by Account settings on the new Proxy page.

* Accounts can now have their own auto-check intervals, or follow the
  global interval.

* in the options for 'default selection when entering a folder',
  'first [...]' has been renamed to 'oldest [...]', and
  'newest [...]' items have been added.

* Message List: when changing sort key by clicking column header,
  the sort direction is now preserved

* Message View: keypress handling for scrolling, (PgUp/Down, Space,
  Backspace), has been improved.

* the Network Log now displays output from LDAP operations.

* "Go to last error" has been added to the Log Window context menu.

* Filtering/Processing: "mark_as_spam" is no longer a final action,
  since it does not move the marked message.

* Filtering/Processing: Resent-From and Resent-To have been added in
  Any/All header(s) (in Address Book) matcher rules.

* when a Return-Receipt request is received by an unknown address,
  the user is now required to choose which Account to send it from.

* Colour Labels: confirmation is asked for when clearing or
  overriding existing colour labels.

* Address Book: basic contact merging has been added.

* NetworkManager support: ported from libnm-util/libnm-glib to libnm.

* Dillo plugin: this HTML rendering plugin is now once again
  available.

* RSSyl plugin: the modified time is no longer considered when
  matching deleted items.

* RSSyl plugin: Handle 404 and other fetch failures better.

* Attachment Remover plugin: the user is now notified about what has
  been done when processing multiple selections.

* SpamAssassin plugin: added support for compression (the server must
  have compression enabled, and the local spamc too).

* SpamAssassin plugin: disabled SSLv3.

* when using the hidden preference, hide_timezone, the time in the
  Date header is converted to UTC.

* various other UI improvements.

* many behind-the-scenes improvements.

* bug fixes:

* 3.16.0
--------

* Preferences: for the 'default selection on entering a folder' on
  the Display/Summaries page, the first new, first unread, and first
  marked message options are now sort-order aware.

* Preferences: the previously hidden preference to 'Warn when sending
  to more recipients than []' has been added to the
  Mail Handling/Sending page.

* Preferences: Toolbars/Compose window: Sign/Encrypt toggle buttons
  can been added to the toolbar.

* Preferences: Fancy Plugin: allow stylesheet file/folder names to
  have spaces in them.

* Account Preferences: a 'Show password' checkbox has been added next
  to the password fields.

* Account Preferences: the OpenPGP and S/MIME preferences have been
  split into two separate pages.

* Account Preferences: newline characters are disallowed in account
  usernames and passwords, and warnings are shown to the user if this
  is attempted.

* Compose: more UTF-8 list-item characters have been added.

* Address book: a 'Show password' checkbox has been added next to the
  LDAP server 'bind password' field.

* GPG: full key/signature fingerprints are now shown instead of the
  short versions.

* SSL Certificate Manager: added support for ipv6 addresses.

* NNTP: Fetch XOVER and XHDR data in batches of 5000 and use the
  statusbar progress meter when opening/refreshing a NNTP folder.

* CLI: the --insert option has been added to --compose, to allow
  inserting files from the command line.

* Plugins window: keyboard shortcuts to Load/Unload buttons have
  been added.

* PDF Viewer Plugin: a print button has been added.

* The HTML parser now supports all entities.

* Tools: a simple bash completion helper has been added,
  tools/bash_completion/claws-mail.

* Bug fixes:

* 3.15.1
--------

* Bug fixes:

* 3.15.0
--------

* More granular options on when to open a selected message have been
  added. There are now several checkboxes on the Display/Summaries
  page of the Preferences which allow a greater flexibility.

* Compose window: Show the total size of attachments on the
  Attachments tab.

* Compose window: Bcc has been added to the headers drop-down list.

* Folder list: Top-level folders can now be copied.  They are created
  as regular folders in the target mailbox.

* Folder selection dialogue: Left/right keys collapse/expand rows.
  Further keypress will move the cursor to parent or first child,
  respectively.

* Menu items: 'Mark all unread [recursively]' has been added to the
  folder context menu, message list menu, and the main window menu
  and toolbar.

* Toolbar actions: Mark, Unmark, Lock, Unlock, Mark [all] read, Mark
  [all] unread, Ignore Thread, Watch Thread, and Delete Duplicate
  Messages have been added to the main window toolbar's Actions list.

* Account compose signature: The value of the signature file now
  takes a path relative to the user's home directory in addition to a
  full path.

* Icon Themes: Support for SVG themes with icon scaling capabilities
  has been added. This requires libRSVG 2.40.5 or newer.

* Hidden preferences: colours for specifying Tags, QuickSearch, and
  auto-filled header values have been added, both foreground and
  background. Respectively, tags_color, tags_bgcolor,
  qs_active_color, qs_active_bgcolor, qs_error_color,
  qs_error_bgcolor, default_header_color, and default_header_bgcolor.

* Hidden preferences: warn_sending_many_recipients_num, if greater
  than zero, a warning dialogue is shown when the number of
  recipients exceeds the number given.

* GData plugin: This plugin now requires libgdata version 0.17.2 or
  newer.

* TNEF parser plugin: This plugin now uses an external libytnef.

* vCalendar plugin: This plugin now uses an external libical, version
  2.0.0 or newer is required.

* Mail Archiver plugin: - updated to support some of the compression
  formats up to libarchive 3.2.2

* Several minor UI improvements.

* Bug fixes:

# $NetBSD: Makefile,v 1.62 2018/11/08 07:29:36 markd Exp $
#

PLUGIN_NAME=	pgpinline
.include "../../mail/claws-mail/plugins.mk"

MAINTAINER=	pkgsrc-users@NetBSD.org
COMMENT=	Handles PGP/Inline signed and/or encrypted mails

CONFIGURE_ARGS+=	--enable-pgpcore-plugin
CONFIGURE_ARGS+=	--enable-pgpinline-plugin

DEPENDS+=	claws-mail-pgpcore-${CLAWS_VERSION}{,nb[0-9]*}:../../mail/claws-mail-pgpcore

PLIST_SRC+=	PLIST

.include "../../security/gpgme/buildlink3.mk"
.include "../../x11/gtk2/buildlink3.mk"

.include "../../mk/bsd.pkg.mk"