[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / mail / balsa

File: [cvs.NetBSD.org] / pkgsrc / mail / balsa / Makefile (download)

Revision 1.166, Sun May 2 10:24:49 2021 UTC (2 years, 7 months ago) by nia
Branch: MAIN
Changes since 1.165: +2 -3 lines

*: Use the tools framework for itstool

Now it should be more obvious when a package needs it as a dependency,
as it will fail loudly if it isn't declared as a tool.

While here, some duplicate dependencies on itstool were removed from the
MATE packages

# $NetBSD: Makefile,v 1.166 2021/05/02 10:24:49 nia Exp $

DISTNAME=	balsa-2.6.2
PKGREVISION=	2
CATEGORIES=	mail
MASTER_SITES=	https://pawsa.fedorapeople.org/balsa/
EXTRACT_SUFX=	.tar.bz2

MAINTAINER=	pkgsrc-users@NetBSD.org
HOMEPAGE=	https://pawsa.fedorapeople.org/balsa/
COMMENT=	Email client using GTK3
LICENSE=	gnu-gpl-v3

USE_TOOLS+=	gmake intltool perl pkg-config
USE_TOOLS+=	msgfmt msgmerge xgettext itstool
USE_LIBTOOL=	yes
GNU_CONFIGURE=	yes

TOOL_DEPENDS+=	p5-XML-Parser-[0-9]*:../../textproc/p5-XML-Parser
TOOL_DEPENDS+=	libxslt-[0-9]*:../../textproc/libxslt
TOOL_DEPENDS+=	yelp-tools-[0-9]*:../../textproc/yelp-tools

CFLAGS.SunOS+=	-D__EXTENSIONS__

CONFIGURE_ARGS+=	--without-gnome
CONFIGURE_ARGS+=	--with-canberra
CONFIGURE_ARGS+=	--with-html-widget=no
CONFIGURE_ARGS+=	--with-libsecret
CONFIGURE_ARGS+=	--with-gtksourceview
CONFIGURE_ARGS+=	--with-sqlite

.include "options.mk"
.include "../../audio/libcanberra/buildlink3.mk"
.include "../../databases/sqlite3/buildlink3.mk"
.include "../../mail/gmime3/buildlink3.mk"
.include "../../security/gnutls/buildlink3.mk"
.include "../../security/gpgme/buildlink3.mk"
.include "../../security/libsecret/buildlink3.mk"
.include "../../textproc/enchant2/buildlink3.mk"
.include "../../time/libical/buildlink3.mk"
.include "../../x11/gtk3/buildlink3.mk"
.include "../../x11/gtksourceview4/buildlink3.mk"
.include "../../mk/pthread.buildlink3.mk"
.include "../../mk/bsd.pkg.mk"